aboutsummaryrefslogtreecommitdiff
path: root/biology/ncbi-toolkit
diff options
context:
space:
mode:
authorGuido Falsi <madpilot@FreeBSD.org>2013-09-04 18:06:07 +0000
committerGuido Falsi <madpilot@FreeBSD.org>2013-09-04 18:06:07 +0000
commit642be1b81d8342d3a3323f43bcf5a0bd87a5d363 (patch)
treef71b3671c7729b9cbc9368cea2f2fede7b20d5c8 /biology/ncbi-toolkit
parentbcaced2c93b58d27ca266602f4049df6ba6becb3 (diff)
downloadports-642be1b81d8342d3a3323f43bcf5a0bd87a5d363.tar.gz
ports-642be1b81d8342d3a3323f43bcf5a0bd87a5d363.zip
Notes
Diffstat (limited to 'biology/ncbi-toolkit')
-rw-r--r--biology/ncbi-toolkit/Makefile4
-rw-r--r--biology/ncbi-toolkit/files/patch-make-makeall.unx2
-rw-r--r--biology/ncbi-toolkit/files/patch-make-makenet.unx2
3 files changed, 5 insertions, 3 deletions
diff --git a/biology/ncbi-toolkit/Makefile b/biology/ncbi-toolkit/Makefile
index f829f790b278..1f5b7cf28ae5 100644
--- a/biology/ncbi-toolkit/Makefile
+++ b/biology/ncbi-toolkit/Makefile
@@ -13,7 +13,7 @@ COMMENT= NCBI development toolkit, including BLAST 2 and GenBank/Entrez support
OPTIONS_DEFINE= DOCS
-USES= motif
+USES= iconv motif
MAKE_JOBS_UNSAFE= yes
SUB_FILES= pkg-message
@@ -66,6 +66,8 @@ post-patch:
s|/usr/local|${LOCALBASE}|g ; \
s|-Wl,-Bstatic|| ; \
s|-Wl,-Bdynamic||' ${WRKSRC}/platform/freebsd.ncbi.mk
+ @${REINPLACE_CMD} -e 's/%%ICONV_LIB%%/${ICONV_LIB}/' \
+ ${WRKSRC}/make/makeall.unx ${WRKSRC}/make/makenet.unx
# the ncbi-toolkit provides a shell script to drive the build
# and we use it
diff --git a/biology/ncbi-toolkit/files/patch-make-makeall.unx b/biology/ncbi-toolkit/files/patch-make-makeall.unx
index 2c46de62b96f..8767a69f7dab 100644
--- a/biology/ncbi-toolkit/files/patch-make-makeall.unx
+++ b/biology/ncbi-toolkit/files/patch-make-makeall.unx
@@ -6,7 +6,7 @@
AR=ar
-OTHERLIBS = -lm
-VIBLIBS =
-+OTHERLIBS = -lm -liconv
++OTHERLIBS = -lm %%ICONV_LIB%%
+VIBLIBS = -lXft -lpng -ljpeg
VIBFLAG =
LIBCOPY = cp -p
diff --git a/biology/ncbi-toolkit/files/patch-make-makenet.unx b/biology/ncbi-toolkit/files/patch-make-makenet.unx
index 878c36e2abc9..2e51654e29e1 100644
--- a/biology/ncbi-toolkit/files/patch-make-makenet.unx
+++ b/biology/ncbi-toolkit/files/patch-make-makenet.unx
@@ -4,7 +4,7 @@
VIB =
VIBLIBS= -lXm -lXmu -lXt -lX11
VIBLIBS=
-+USERLIBS = -lXft -lpng -ljpeg -liconv
++USERLIBS = -lXft -lpng -ljpeg %%ICONV_LIB%%
SEQUIN_OPTS =
LIBCOPY = cp -p
SRCCOPY = ./ln-if-absent