aboutsummaryrefslogtreecommitdiff
path: root/biology/njplot/Makefile
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2008-05-14 14:07:01 +0000
committerPav Lucistnik <pav@FreeBSD.org>2008-05-14 14:07:01 +0000
commit0149bce295e707f5b9641b1c32d084824a6be0e3 (patch)
tree8ba56c084857fc85438923c66b64d18a16e3789c /biology/njplot/Makefile
parent191e9d97ce89d5cd47fdee8ca568129d85b81f96 (diff)
downloadports-0149bce295e707f5b9641b1c32d084824a6be0e3.tar.gz
ports-0149bce295e707f5b9641b1c32d084824a6be0e3.zip
Notes
Diffstat (limited to 'biology/njplot/Makefile')
-rw-r--r--biology/njplot/Makefile55
1 files changed, 55 insertions, 0 deletions
diff --git a/biology/njplot/Makefile b/biology/njplot/Makefile
new file mode 100644
index 000000000000..9e118db518cb
--- /dev/null
+++ b/biology/njplot/Makefile
@@ -0,0 +1,55 @@
+# New ports collection makefile for: njplot
+# Date created: 5 December 2007
+# Whom: Motomichi Matsuzaki <mzaki@biol.s.u-tokyo.ac.jp>
+#
+# $FreeBSD$
+#
+
+PORTNAME= njplot
+PORTVERSION= 2.1
+CATEGORIES= biology
+MASTER_SITES= ftp://pbil.univ-lyon1.fr/pub/mol_phylogeny/njplot/archive/
+
+MAINTAINER= mzaki@biol.s.u-tokyo.ac.jp
+COMMENT= Phylogenetic tree drawing program capable of interactive manipulation
+
+.ifndef (WITHOUT_X11)
+BUILD_DEPENDS= ${LOCALBASE}/lib/ncbi/libvibrant.a:${PORTSDIR}/biology/ncbi-toolkit
+USE_XLIB= yes
+USE_MOTIF= yes
+.endif
+
+MAKEFILE= makefile
+
+BINARIES= newicktops newicktotxt
+.ifndef (WITHOUT_X11)
+BINARIES+= njplot unrooted
+.endif
+.for file in ${BINARIES}
+PLIST_FILES+= bin/${file}
+.endfor
+
+PORTDOCS= njplot.help njplot.html njplot.gif
+
+MAN1= njplot.1 unrooted.1
+
+.ifdef (WITHOUT_X11)
+post-patch:
+ ${REINPLACE_CMD} -e 's|njplot.*unrooted||' ${WRKSRC}/makefile
+.endif
+
+do-install:
+.for file in ${BINARIES}
+ ${INSTALL_PROGRAM} ${WRKSRC}/${file} ${PREFIX}/bin
+.endfor
+.for file in ${MAN1}
+ ${INSTALL_MAN} ${WRKSRC}/${file} ${PREFIX}/man/man1
+.endfor
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+.for file in ${PORTDOCS}
+ ${INSTALL_MAN} ${WRKSRC}/${file} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>