aboutsummaryrefslogtreecommitdiff
path: root/biology/njplot
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2008-05-14 14:07:01 +0000
committerPav Lucistnik <pav@FreeBSD.org>2008-05-14 14:07:01 +0000
commit0149bce295e707f5b9641b1c32d084824a6be0e3 (patch)
tree8ba56c084857fc85438923c66b64d18a16e3789c /biology/njplot
parent191e9d97ce89d5cd47fdee8ca568129d85b81f96 (diff)
downloadports-0149bce295e707f5b9641b1c32d084824a6be0e3.tar.gz
ports-0149bce295e707f5b9641b1c32d084824a6be0e3.zip
Notes
Diffstat (limited to 'biology/njplot')
-rw-r--r--biology/njplot/Makefile55
-rw-r--r--biology/njplot/distinfo3
-rw-r--r--biology/njplot/files/patch-makefile69
-rw-r--r--biology/njplot/pkg-descr17
4 files changed, 144 insertions, 0 deletions
diff --git a/biology/njplot/Makefile b/biology/njplot/Makefile
new file mode 100644
index 000000000000..9e118db518cb
--- /dev/null
+++ b/biology/njplot/Makefile
@@ -0,0 +1,55 @@
+# New ports collection makefile for: njplot
+# Date created: 5 December 2007
+# Whom: Motomichi Matsuzaki <mzaki@biol.s.u-tokyo.ac.jp>
+#
+# $FreeBSD$
+#
+
+PORTNAME= njplot
+PORTVERSION= 2.1
+CATEGORIES= biology
+MASTER_SITES= ftp://pbil.univ-lyon1.fr/pub/mol_phylogeny/njplot/archive/
+
+MAINTAINER= mzaki@biol.s.u-tokyo.ac.jp
+COMMENT= Phylogenetic tree drawing program capable of interactive manipulation
+
+.ifndef (WITHOUT_X11)
+BUILD_DEPENDS= ${LOCALBASE}/lib/ncbi/libvibrant.a:${PORTSDIR}/biology/ncbi-toolkit
+USE_XLIB= yes
+USE_MOTIF= yes
+.endif
+
+MAKEFILE= makefile
+
+BINARIES= newicktops newicktotxt
+.ifndef (WITHOUT_X11)
+BINARIES+= njplot unrooted
+.endif
+.for file in ${BINARIES}
+PLIST_FILES+= bin/${file}
+.endfor
+
+PORTDOCS= njplot.help njplot.html njplot.gif
+
+MAN1= njplot.1 unrooted.1
+
+.ifdef (WITHOUT_X11)
+post-patch:
+ ${REINPLACE_CMD} -e 's|njplot.*unrooted||' ${WRKSRC}/makefile
+.endif
+
+do-install:
+.for file in ${BINARIES}
+ ${INSTALL_PROGRAM} ${WRKSRC}/${file} ${PREFIX}/bin
+.endfor
+.for file in ${MAN1}
+ ${INSTALL_MAN} ${WRKSRC}/${file} ${PREFIX}/man/man1
+.endfor
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+.for file in ${PORTDOCS}
+ ${INSTALL_MAN} ${WRKSRC}/${file} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/biology/njplot/distinfo b/biology/njplot/distinfo
new file mode 100644
index 000000000000..74d09b4c0b59
--- /dev/null
+++ b/biology/njplot/distinfo
@@ -0,0 +1,3 @@
+MD5 (njplot-2.1.tar.gz) = d98adc1e624e8fcc8cc86e7dfe65e67c
+SHA256 (njplot-2.1.tar.gz) = dd8a54c3903cd104d8322257a87b5fbf3afb7776a96fcf9bee504ae1ad54c0c1
+SIZE (njplot-2.1.tar.gz) = 85735
diff --git a/biology/njplot/files/patch-makefile b/biology/njplot/files/patch-makefile
new file mode 100644
index 000000000000..448fbe7d41be
--- /dev/null
+++ b/biology/njplot/files/patch-makefile
@@ -0,0 +1,69 @@
+--- makefile.orig Thu Oct 11 01:54:00 2007
++++ makefile Mon Dec 3 22:08:28 2007
+@@ -1,5 +1,5 @@
+ #uncomment and locally adapt next line to fix the full helpfile path name
+-HELPFILENAME = -DHELPFILENAME=\"/usr/share/njplot/njplot.help\"
++HELPFILENAME = -DHELPFILENAME=\"$(LOCALBASE)/doc/njplot/njplot.help\"
+
+ #comment out next line and uncomment next 2 to use the PDFLib Lite library
+ NO_PDF = -DNO_PDF
+@@ -7,43 +7,45 @@
+ #PDFLIB = -L$(PDF) -lpdf
+
+ # c compiler and linker
+-CC = gcc
++CC ?= gcc
+
+ # Vibrant top directory
+-VIBRANT = /banques0/ncbiJun04
++#VIBRANT = /banques0/ncbiJun04
++NCBIINC = $(LOCALBASE)/include/ncbi
++NCBILIB = $(LOCALBASE)/lib/ncbi
+
+
+ # X11 include directory
+-X11INCL = /usr/X11R6/include
++X11INCL = $(LOCALBASE)/include
+
+ # motif library directory
+-MOTIFLIB = /sw/lib
+-MOTIFINCL = /sw/include
++#MOTIFLIB = /sw/lib
++#MOTIFINCL = /sw/include
+
+ OBJECTS = njplot-vib.o
+ OBJUNROOTED = unrooted-vib.o preptree.o
+
+
+-CFLAGS = -c -DWIN_MOTIF -Dunix -I$(VIBRANT)/include -I$(VIBRANT)/vibrant -I$(VIBRANT)/corelib \
+- -I$(VIBRANT) -I$(PDF) -I$(X11INCL) -I$(MOTIFINCL) $(HELPFILENAME) $(NO_PDF) \
+- -Wimplicit-function-declaration -g
++CFLAGS = -c -DWIN_MOTIF -Dunix -I$(NCBIINC) \
++ -I$(X11INCL) $(HELPFILENAME) $(NO_PDF) \
++ -Wimplicit-function-declaration
+
+ all: njplot unrooted newicktops newicktotxt
+
+
+ njplot : $(OBJECTS)
+ $(CC) -g -o njplot $(OBJECTS) \
+- -L$(VIBRANT)/lib \
++ -L$(NCBILIB) \
+ -lvibrant -lncbi \
+ $(PDFLIB) \
+- -L$(MOTIFLIB) -lXm \
+- -L/usr/X11R6/lib -lXmu -lXt -lX11 -lm
++ $(MOTIFLIB) \
++ -L$(X11BASE)/lib -lXmu -lXt -lX11 -lm
+
+ unrooted : $(OBJUNROOTED)
+ $(CC) -g -o unrooted $(OBJUNROOTED) \
+- -L$(VIBRANT)/lib -lvibrant -lncbi \
+- -L$(MOTIFLIB) -lXm \
+- -L/usr/X11R6/lib -lXmu -lXt -lX11 -lm
++ -L$(NCBILIB) -lvibrant -lncbi \
++ $(MOTIFLIB) \
++ -L$(LOCALBASE)/lib -lXmu -lXt -lX11 -lm
+
+ newicktops: njplot-vib.c
+ $(CC) -DNO_GUI -DNO_PDF -o $@ njplot-vib.c -lm
diff --git a/biology/njplot/pkg-descr b/biology/njplot/pkg-descr
new file mode 100644
index 000000000000..679993f19121
--- /dev/null
+++ b/biology/njplot/pkg-descr
@@ -0,0 +1,17 @@
+NJplot is a tree drawing program able to draw any phylogenetic tree expressed
+in the Newick phylogenetic tree format (e.g., the format used by the PHYLIP
+package). NJplot is especially convenient for rooting the unrooted trees
+obtained from parsimony, distance or maximum likelihood tree-building methods.
+
+The package contains the following programs:
+njplot - draw phylogenetic trees and interactively modify them
+newicktops - non-interactive version rendering into a PostScript file
+newicktotxt - non-interactive version rendering into a text file
+unrooted - draw unrooted circular trees
+
+If you use NJplot in a published work, please cite the following reference:
+
+Perriere, G. and Gouy, M. (1996) WWW-Query: An on-line retrieval system for
+biological sequence banks. Biochimie, 78, 364-369.
+
+WWW: http://pbil.univ-lyon1.fr/software/njplot.html