aboutsummaryrefslogtreecommitdiff
path: root/biology/p5-Bio-Phylo/Makefile
diff options
context:
space:
mode:
authorWen Heping <wen@FreeBSD.org>2010-03-03 13:44:19 +0000
committerWen Heping <wen@FreeBSD.org>2010-03-03 13:44:19 +0000
commit22c4a3da76cf8258971aaa00afe9c93e10d227de (patch)
treed1a36e1afe34b75042a860bc0b233c173c630acd /biology/p5-Bio-Phylo/Makefile
parente1ad733bfe69d447ac9b4121b59416235008f10e (diff)
- Update to 0.18
- Adopt Feature safe: yes
Notes
Notes: svn path=/head/; revision=250536
Diffstat (limited to 'biology/p5-Bio-Phylo/Makefile')
-rw-r--r--biology/p5-Bio-Phylo/Makefile47
1 files changed, 31 insertions, 16 deletions
diff --git a/biology/p5-Bio-Phylo/Makefile b/biology/p5-Bio-Phylo/Makefile
index 263a1a415eba..7f0baeccf969 100644
--- a/biology/p5-Bio-Phylo/Makefile
+++ b/biology/p5-Bio-Phylo/Makefile
@@ -6,13 +6,12 @@
#
PORTNAME= Bio-Phylo
-PORTVERSION= 0.16
-PORTREVISION= 2
+PORTVERSION= 0.18
CATEGORIES= biology perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= wen@FreeBSD.org
COMMENT= Phylogenetic analysis using perl
BUILD_DEPENDS= p5-Exception-Class>1.22:${PORTSDIR}/devel/p5-Exception-Class \
@@ -22,25 +21,18 @@ BUILD_DEPENDS= p5-Exception-Class>1.22:${PORTSDIR}/devel/p5-Exception-Class \
p5-SVG>=1.07:${PORTSDIR}/textproc/p5-SVG
RUN_DEPENDS= ${BUILD_DEPENDS}
-MAN1= dndtag.pl.1 \
- droptip.pl.1 \
- bremer.pl.1 \
- age2bl.pl.1 \
- dnd2svg.pl.1
MAN3= Bio::Phylo.3 \
- Bio::ObjectCompat.3 \
- Bio::Phylo::Adaptor.3 \
- Bio::Phylo::ConfigData.3 \
+ Bio::Phylo::Annotation.3 \
+ Bio::Phylo::Dictionary.3 \
+ Bio::Phylo::Factory.3 \
+ Bio::Phylo::Forest::DrawNode.3 \
+ Bio::Phylo::Forest::DrawTree.3 \
Bio::Phylo::Forest.3 \
Bio::Phylo::Forest::Node.3 \
Bio::Phylo::Forest::Tree.3 \
Bio::Phylo::Generator.3 \
Bio::Phylo::IO.3 \
Bio::Phylo::Listable.3 \
- Bio::Phylo::Adaptor::Bioperl::Datum.3 \
- Bio::Phylo::Adaptor::Bioperl::Matrix.3 \
- Bio::Phylo::Adaptor::Bioperl::Node.3 \
- Bio::Phylo::Adaptor::Bioperl::Tree.3 \
Bio::Phylo::Manual.3 \
Bio::Phylo::Matrices.3 \
Bio::Phylo::Matrices::Datum.3 \
@@ -55,11 +47,25 @@ MAN3= Bio::Phylo.3 \
Bio::Phylo::Matrices::Datatype::Continuous.3 \
Bio::Phylo::Matrices::Datatype::Standard.3 \
Bio::Phylo::Matrices::Datatype::Mixed.3 \
+ Bio::Phylo::Meta.3 \
+ Bio::Phylo::Meta::XMLLiteral.3 \
+ Bio::Phylo::Mediators::NodeMediator.3 \
Bio::Phylo::Mediators::TaxaMediator.3 \
Bio::Phylo::Parsers::Newick.3 \
+ Bio::Phylo::Parsers::Nexml.3 \
Bio::Phylo::Parsers::Nexus.3 \
Bio::Phylo::Parsers::Table.3 \
Bio::Phylo::Parsers::Taxlist.3 \
+ Bio::Phylo::Parsers::Tolweb.3 \
+ Bio::Phylo::PhyloWS::Client.3 \
+ Bio::Phylo::PhyloWS::Service::Tolweb.3 \
+ Bio::Phylo::PhyloWS::Service.3 \
+ Bio::Phylo::PhyloWS::Resource::Description.3 \
+ Bio::Phylo::PhyloWS.3 \
+ Bio::Phylo::PhyloWS::Resource.3 \
+ Bio::Phylo::PhyloWS::Service::Timetree.3 \
+ Bio::Phylo::Project.3 \
+ Bio::Phylo::Set.3 \
Bio::Phylo::Taxa.3 \
Bio::Phylo::Taxa::TaxaLinker.3 \
Bio::Phylo::Taxa::Taxon.3 \
@@ -68,13 +74,22 @@ MAN3= Bio::Phylo.3 \
Bio::Phylo::Treedrawer::Svg.3 \
Bio::Phylo::Unparsers::Mrp.3 \
Bio::Phylo::Unparsers::Newick.3 \
+ Bio::Phylo::Unparsers::Nexml.3 \
Bio::Phylo::Unparsers::Nexus.3 \
Bio::Phylo::Unparsers::Pagel.3 \
Bio::Phylo::Util::CONSTANT.3 \
+ Bio::Phylo::Util::DOM.3 \
+ Bio::Phylo::Util::DOM::Document::libxml.3 \
+ Bio::Phylo::Util::DOM::Document::twig.3 \
+ Bio::Phylo::Util::DOM::DocumentI.3 \
+ Bio::Phylo::Util::DOM::Element::libxml.3 \
+ Bio::Phylo::Util::DOM::Element::twig.3 \
+ Bio::Phylo::Util::DOM::ElementI.3 \
Bio::Phylo::Util::Exceptions.3 \
Bio::Phylo::Util::IDPool.3 \
+ Bio::Phylo::Util::Logger.3 \
Bio::Phylo::Util::XMLWritable.3
-PERL_MODBUILD= 5.7.2+
+PERL_CONFIGURE= yes
.include <bsd.port.mk>