aboutsummaryrefslogtreecommitdiff
path: root/biology/p5-bioperl/Makefile
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2016-11-20 23:56:14 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2016-11-20 23:56:14 +0000
commit209b2393e37830d89b2e0b0b10089515e9ed6226 (patch)
tree2eecf3372e627314bba0023caf324cfb63ec8d6d /biology/p5-bioperl/Makefile
parent9a5f5dfd8eac2d47691c1af9fbceea01aec0b916 (diff)
Notes
Diffstat (limited to 'biology/p5-bioperl/Makefile')
-rw-r--r--biology/p5-bioperl/Makefile12
1 files changed, 8 insertions, 4 deletions
diff --git a/biology/p5-bioperl/Makefile b/biology/p5-bioperl/Makefile
index fd7f623d2668..4bd62f3df343 100644
--- a/biology/p5-bioperl/Makefile
+++ b/biology/p5-bioperl/Makefile
@@ -59,7 +59,7 @@ BUILD_DEPENDS= p5-Algorithm-Munkres>=0:math/p5-Algorithm-Munkres \
RUN_DEPENDS:= ${BUILD_DEPENDS}
-USES= perl5 shebangfix
+USES= perl5
USE_PERL5= modbuild
NO_ARCH= yes
@@ -74,17 +74,21 @@ SQLITETEST_BUILD_DEPENDS= p5-DBD-SQLite>=1:databases/p5-DBD-SQLite
post-patch:
@${FIND} ${WRKSRC}/examples ${WRKSRC}/doc -name "*.pl" -o -name "*.cgi" \
-o -name "*.PL" | ${XARGS} ${REINPLACE_CMD} -i '' -Ee \
- '1s|(/usr)?/bin/perl|${perl_CMD}|'
+ '1s|(/usr)?/bin/perl|${PERL}|'
post-install:
@${MKDIR} ${STAGEDIR}${DATADIR}
${CP} -R ${WRKSRC}/scripts ${WRKSRC}/models ${STAGEDIR}${DATADIR}
- @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
- ${CP} -R ${WRKSRC}/examples/* ${STAGEDIR}${EXAMPLESDIR}
+
+post-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
.for doc in AUTHORS BUGS Changes DEPENDENCIES DEPRECATED INSTALL LICENSE MANIFEST README
${INSTALL_MAN} ${WRKSRC}/${doc} ${STAGEDIR}${DOCSDIR}
.endfor
${CP} -R ${WRKSRC}/doc ${STAGEDIR}${DOCSDIR}
+post-install-EXAMPLES-on:
+ @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ ${CP} -R ${WRKSRC}/examples/* ${STAGEDIR}${EXAMPLESDIR}
+
.include <bsd.port.mk>