aboutsummaryrefslogtreecommitdiff
path: root/biology/p5-bioperl
diff options
context:
space:
mode:
authorNeil Blakey-Milner <nbm@FreeBSD.org>2000-07-28 14:06:03 +0000
committerNeil Blakey-Milner <nbm@FreeBSD.org>2000-07-28 14:06:03 +0000
commit4634742f54118dd1f27b1ed1ec8cd540c90e0d88 (patch)
tree9a0e5e4ae7768e9fb1fc12c88bfb59793cfd3669 /biology/p5-bioperl
parent167641b4f4961aaa7b26a7084250549a1ac4d096 (diff)
downloadports-4634742f54118dd1f27b1ed1ec8cd540c90e0d88.tar.gz
ports-4634742f54118dd1f27b1ed1ec8cd540c90e0d88.zip
Notes
Diffstat (limited to 'biology/p5-bioperl')
-rw-r--r--biology/p5-bioperl/Makefile124
-rw-r--r--biology/p5-bioperl/distinfo2
-rw-r--r--biology/p5-bioperl/files/patch-aa9
-rw-r--r--biology/p5-bioperl/pkg-comment1
-rw-r--r--biology/p5-bioperl/pkg-descr13
-rw-r--r--biology/p5-bioperl/pkg-plist109
6 files changed, 258 insertions, 0 deletions
diff --git a/biology/p5-bioperl/Makefile b/biology/p5-bioperl/Makefile
new file mode 100644
index 000000000000..ed8e5d58f44e
--- /dev/null
+++ b/biology/p5-bioperl/Makefile
@@ -0,0 +1,124 @@
+# New ports collection makefile for: p5-bioperl
+# Date created: 28 July 2000
+# Whom: Johann Visagie <johann@egenetics.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= bioperl
+PORTVERSION= 0.6.1
+CATEGORIES= biology perl5
+MASTER_SITES= ftp://bio.perl.org/pub/DIST/ \
+ http://bio.perl.org/Core/Latest/ \
+ ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR=Bio
+PKGNAMEPREFIX= p5-
+DISTFILES= ${DISTNAME}${EXTRACT_SUFX} bioperl-ext-0.6.tar.gz
+
+MAINTAINER= johann@egenetics.com
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/LWP/UserAgent.pm:${PORTSDIR}/www/p5-libwww \
+ ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/IO/Scalar.pm:${PORTSDIR}/devel/p5-IO-stringy \
+ ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/Ace.pm:${PORTSDIR}/biology/p5-AcePerl
+
+USE_PERL5= YES
+
+EXT_WRKSRC= ${WRKDIR}/bioperl-ext-06
+
+MAN3= Bio::Tools::CodonTable.3 \
+ Bio::PrimarySeq.3 \
+ Bio::Tools::SeqStats.3 \
+ Bio::SimpleAlign.3 \
+ Bio::Search::Processor::Fasta.3 \
+ Bio::Root::Xref.3 \
+ Bio::Annotation::DBLink.3 \
+ Bio::SeqIO::swiss.3 \
+ Bio::Annotation::Comment.3 \
+ Bio::Tools::Sim4::Results.3 \
+ Bio::Annotation::Reference.3 \
+ Bio::SeqIO::pir.3 \
+ Bio::Search::Hit::Fasta.3 \
+ Bio::Tools::SeqAnal.3 \
+ Bio::Annotation.3 \
+ Bio::Tools::Blast::HTML.3 \
+ Bio::Tools::HMMER::Results.3 \
+ Bio::SeqIO::scf.3 \
+ Bio::SeqIO::genbank.3 \
+ Bio::Root::RootI.3 \
+ Bio::Tools::SeqWords.3 \
+ Bio::Root::Global.3 \
+ Bio::Tools::pSW.3 \
+ Bio::SeqIO::raw.3 \
+ Bio::Tools::Blast::HSP.3 \
+ bioperl.3 \
+ Bio::RangeI.3 \
+ Bio::Search::Processor.3 \
+ Bio::Root::Object.3 \
+ Bio::Tools::WWW.3 \
+ Bio::PrimarySeqI.3 \
+ Bio::Index::Abstract.3 \
+ Bio::DB::Ace.3 \
+ Bio::SeqFeature::Generic.3 \
+ Bio::DB::SeqI.3 \
+ Bio::Root::Vector.3 \
+ Bio::Seq.3 \
+ Bio::Range.3 \
+ Bio::UnivAln.3 \
+ Bio::Tools::Blast::Run::Webblast.3 \
+ Bio::SeqIO::gcg.3 \
+ biodesign.3 \
+ Bio::Tools::RestrictionEnzyme.3 \
+ Bio::DB::RandomAccessI.3 \
+ biostart.3 \
+ Bio::Tools::Sim4::Exon.3 \
+ Bio::Search::Hit::HitI.3 \
+ bioback.3 \
+ Bio::Tools::HMMER::Domain.3 \
+ Bio::SeqIO::FTHelper.3 \
+ Bio::Root::IOManager.3 \
+ Bio::LocatableSeq.3 \
+ Bio::Index::AbstractSeq.3 \
+ Bio::Tools::Fasta.3 \
+ Bio::Tools::Blast::Sbjct.3 \
+ Bio::Tools::IUPAC.3 \
+ Bio::SeqIO.3 \
+ Bio::SeqIO::MultiFile.3 \
+ Bio::Tools::AlignFactory.3 \
+ Bio::SeqIO::fasta.3 \
+ Bio::SeqFeature::FeaturePair.3 \
+ Bio::DB::GenBank.3 \
+ Bio::SeqI.3 \
+ Bio::Tools::Blast.3 \
+ Bio::Tools::HMMER::Set.3 \
+ Bio::SeqFeatureI.3 \
+ Bio::SearchDist.3 \
+ Bio::Tools::Sigcleave.3 \
+ Bio::Search::Result::ResultI.3 \
+ Bio::Root::Utilities.3 \
+ Bio::Root::Err.3 \
+ Bio::Search::Result::Fasta.3 \
+ Bio::Tools::SeqPattern.3 \
+ Bio::Search::Processor::ProcessorI.3 \
+ Bio::Index::EMBL.3 \
+ Bio::Species.3 \
+ Bio::Tools::Blast::Run::LocalBlast.3 \
+ Bio::SeqIO::embl.3 \
+ Bio::Index::SwissPfam.3 \
+ Bio::DB::GenPept.3 \
+ Bio::Index::Fasta.3
+
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+
+do-configure:
+ @(cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${PERL5} Makefile.PL)
+ @(cd ${EXT_WRKSRC}/Bio/Ext/Align; ${SETENV} ${MAKE_ENV} ${PERL5} Makefile.PL)
+
+do-build:
+ @(cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${MAKE} ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} ${ALL_TARGET})
+ @(cd ${EXT_WRKSRC}/Bio/Ext/Align; ${MAKE} ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} ${ALL_TARGET})
+
+do-install:
+ @(cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${MAKE} ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} ${INSTALL_TARGET})
+ @(cd ${EXT_WRKSRC}/Bio/Ext/Align; ${SETENV} ${MAKE_ENV} ${MAKE} ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} ${INSTALL_TARGET})
+
+.include <bsd.port.mk>
diff --git a/biology/p5-bioperl/distinfo b/biology/p5-bioperl/distinfo
new file mode 100644
index 000000000000..dea595e5a767
--- /dev/null
+++ b/biology/p5-bioperl/distinfo
@@ -0,0 +1,2 @@
+MD5 (bioperl-0.6.1.tar.gz) = e3506188027a94ea87443389a78c2fdc
+MD5 (bioperl-ext-0.6.tar.gz) = 5bf87e0cf94d3d41fabbfd209971d240
diff --git a/biology/p5-bioperl/files/patch-aa b/biology/p5-bioperl/files/patch-aa
new file mode 100644
index 000000000000..4aecbfe2a166
--- /dev/null
+++ b/biology/p5-bioperl/files/patch-aa
@@ -0,0 +1,9 @@
+--- ../bioperl-ext-06/Bio/Ext/Align/libs/makefile.orig Thu Sep 16 15:33:08 1999
++++ ../bioperl-ext-06/Bio/Ext/Align/libs/makefile Fri Jul 28 11:57:27 2000
+@@ -47,5 +47,5 @@
+ # For NetBSD or Sun (solaris) installs, add -fPIC to the CFLAGS lines
+ #
+
+-CFLAGS = -c -O
++CFLAGS+= -c -O -fPIC
+ CC = cc
diff --git a/biology/p5-bioperl/pkg-comment b/biology/p5-bioperl/pkg-comment
new file mode 100644
index 000000000000..6603d94dc286
--- /dev/null
+++ b/biology/p5-bioperl/pkg-comment
@@ -0,0 +1 @@
+A collection of Perl modules for bioinformatics
diff --git a/biology/p5-bioperl/pkg-descr b/biology/p5-bioperl/pkg-descr
new file mode 100644
index 000000000000..bcf40d4ea703
--- /dev/null
+++ b/biology/p5-bioperl/pkg-descr
@@ -0,0 +1,13 @@
+The Bioperl Project is an international association of developers of open
+source Perl tools for bioinformatics, genomics and life science research.
+
+Bioperl is a collection of object-oriented Perl modules created by the
+Bioperl Project. It forms the basis of a large number of bioinformatics and
+genomics applications.
+
+(For an interesting aside on "How Perl saved the Human Genome Project", see
+http://bio.perl.org/GetStarted/tpj_ls_bio.html)
+
+WWW: http://bio.perl.org/
+
+-- Johann Visagie <johann@egenetics.com>
diff --git a/biology/p5-bioperl/pkg-plist b/biology/p5-bioperl/pkg-plist
new file mode 100644
index 000000000000..1edf34960626
--- /dev/null
+++ b/biology/p5-bioperl/pkg-plist
@@ -0,0 +1,109 @@
+lib/perl5/site_perl/%%PERL_VER%%/Bio/DB/GenBank.pm
+lib/perl5/site_perl/%%PERL_VER%%/Bio/DB/SeqI.pm
+lib/perl5/site_perl/%%PERL_VER%%/Bio/DB/Ace.pm
+lib/perl5/site_perl/%%PERL_VER%%/Bio/DB/RandomAccessI.pm
+lib/perl5/site_perl/%%PERL_VER%%/Bio/DB/GenPept.pm
+lib/perl5/site_perl/%%PERL_VER%%/Bio/Root/Err.pm
+lib/perl5/site_perl/%%PERL_VER%%/Bio/Root/RootI.pm
+lib/perl5/site_perl/%%PERL_VER%%/Bio/Root/Global.pm
+lib/perl5/site_perl/%%PERL_VER%%/Bio/Root/Xref.pm
+lib/perl5/site_perl/%%PERL_VER%%/Bio/Root/Object.pm
+lib/perl5/site_perl/%%PERL_VER%%/Bio/Root/Vector.pm
+lib/perl5/site_perl/%%PERL_VER%%/Bio/Root/Utilities.pm
+lib/perl5/site_perl/%%PERL_VER%%/Bio/Root/IOManager.pm
+lib/perl5/site_perl/%%PERL_VER%%/Bio/RangeI.pm
+lib/perl5/site_perl/%%PERL_VER%%/Bio/Annotation.pm
+lib/perl5/site_perl/%%PERL_VER%%/Bio/SeqI.pm
+lib/perl5/site_perl/%%PERL_VER%%/Bio/UnivAln.pm
+lib/perl5/site_perl/%%PERL_VER%%/Bio/SeqFeatureI.pm
+lib/perl5/site_perl/%%PERL_VER%%/Bio/SeqIO/genbank.pm
+lib/perl5/site_perl/%%PERL_VER%%/Bio/SeqIO/FTHelper.pm
+lib/perl5/site_perl/%%PERL_VER%%/Bio/SeqIO/raw.pm
+lib/perl5/site_perl/%%PERL_VER%%/Bio/SeqIO/embl.pm
+lib/perl5/site_perl/%%PERL_VER%%/Bio/SeqIO/scf.pm
+lib/perl5/site_perl/%%PERL_VER%%/Bio/SeqIO/gcg.pm
+lib/perl5/site_perl/%%PERL_VER%%/Bio/SeqIO/swiss.pm
+lib/perl5/site_perl/%%PERL_VER%%/Bio/SeqIO/fasta.pm
+lib/perl5/site_perl/%%PERL_VER%%/Bio/SeqIO/pir.pm
+lib/perl5/site_perl/%%PERL_VER%%/Bio/SeqIO/MultiFile.pm
+lib/perl5/site_perl/%%PERL_VER%%/Bio/Tools/Sim4/Results.pm
+lib/perl5/site_perl/%%PERL_VER%%/Bio/Tools/Sim4/Exon.pm
+lib/perl5/site_perl/%%PERL_VER%%/Bio/Tools/IUPAC.pm
+lib/perl5/site_perl/%%PERL_VER%%/Bio/Tools/CodonTable.pm
+lib/perl5/site_perl/%%PERL_VER%%/Bio/Tools/AlignFactory.pm
+lib/perl5/site_perl/%%PERL_VER%%/Bio/Tools/Blast/Run/Makefile.PL
+lib/perl5/site_perl/%%PERL_VER%%/Bio/Tools/Blast/Run/postclient.pl
+lib/perl5/site_perl/%%PERL_VER%%/Bio/Tools/Blast/Run/LocalBlast.pm
+lib/perl5/site_perl/%%PERL_VER%%/Bio/Tools/Blast/Run/Webblast.pm
+lib/perl5/site_perl/%%PERL_VER%%/Bio/Tools/Blast/CHANGES
+lib/perl5/site_perl/%%PERL_VER%%/Bio/Tools/Blast/HSP.pm
+lib/perl5/site_perl/%%PERL_VER%%/Bio/Tools/Blast/Sbjct.pm
+lib/perl5/site_perl/%%PERL_VER%%/Bio/Tools/Blast/README
+lib/perl5/site_perl/%%PERL_VER%%/Bio/Tools/Blast/HTML.pm
+lib/perl5/site_perl/%%PERL_VER%%/Bio/Tools/pSW.pm
+lib/perl5/site_perl/%%PERL_VER%%/Bio/Tools/Blast.pm
+lib/perl5/site_perl/%%PERL_VER%%/Bio/Tools/SeqPattern.pm
+lib/perl5/site_perl/%%PERL_VER%%/Bio/Tools/Fasta.pm
+lib/perl5/site_perl/%%PERL_VER%%/Bio/Tools/WWW.pm
+lib/perl5/site_perl/%%PERL_VER%%/Bio/Tools/HMMER/Results.pm
+lib/perl5/site_perl/%%PERL_VER%%/Bio/Tools/HMMER/Set.pm
+lib/perl5/site_perl/%%PERL_VER%%/Bio/Tools/HMMER/Domain.pm
+lib/perl5/site_perl/%%PERL_VER%%/Bio/Tools/Sigcleave.pm
+lib/perl5/site_perl/%%PERL_VER%%/Bio/Tools/SeqWords.pm
+lib/perl5/site_perl/%%PERL_VER%%/Bio/Tools/SeqStats.pm
+lib/perl5/site_perl/%%PERL_VER%%/Bio/Tools/SeqAnal.pm
+lib/perl5/site_perl/%%PERL_VER%%/Bio/Tools/RestrictionEnzyme.pm
+lib/perl5/site_perl/%%PERL_VER%%/Bio/SearchDist.pm
+lib/perl5/site_perl/%%PERL_VER%%/Bio/Search/Hit/HitI.pm
+lib/perl5/site_perl/%%PERL_VER%%/Bio/Search/Hit/Fasta.pm
+lib/perl5/site_perl/%%PERL_VER%%/Bio/Search/Processor/Fasta.pm
+lib/perl5/site_perl/%%PERL_VER%%/Bio/Search/Processor/ProcessorI.pm
+lib/perl5/site_perl/%%PERL_VER%%/Bio/Search/Processor.pm
+lib/perl5/site_perl/%%PERL_VER%%/Bio/Search/Result/ResultI.pm
+lib/perl5/site_perl/%%PERL_VER%%/Bio/Search/Result/Fasta.pm
+lib/perl5/site_perl/%%PERL_VER%%/Bio/Seq.pm
+lib/perl5/site_perl/%%PERL_VER%%/Bio/PrimarySeqI.pm
+lib/perl5/site_perl/%%PERL_VER%%/Bio/Range.pm
+lib/perl5/site_perl/%%PERL_VER%%/Bio/SimpleAlign.pm
+lib/perl5/site_perl/%%PERL_VER%%/Bio/SeqIO.pm
+lib/perl5/site_perl/%%PERL_VER%%/Bio/Index/EMBL.pm
+lib/perl5/site_perl/%%PERL_VER%%/Bio/Index/AbstractSeq.pm
+lib/perl5/site_perl/%%PERL_VER%%/Bio/Index/Fasta.pm
+lib/perl5/site_perl/%%PERL_VER%%/Bio/Index/Abstract.pm
+lib/perl5/site_perl/%%PERL_VER%%/Bio/Index/SwissPfam.pm
+lib/perl5/site_perl/%%PERL_VER%%/Bio/Species.pm
+lib/perl5/site_perl/%%PERL_VER%%/Bio/PrimarySeq.pm
+lib/perl5/site_perl/%%PERL_VER%%/Bio/LocatableSeq.pm
+lib/perl5/site_perl/%%PERL_VER%%/Bio/Annotation/Comment.pm
+lib/perl5/site_perl/%%PERL_VER%%/Bio/Annotation/Reference.pm
+lib/perl5/site_perl/%%PERL_VER%%/Bio/Annotation/DBLink.pm
+lib/perl5/site_perl/%%PERL_VER%%/Bio/SeqFeature/FeaturePair.pm
+lib/perl5/site_perl/%%PERL_VER%%/Bio/SeqFeature/Generic.pm
+lib/perl5/site_perl/%%PERL_VER%%/bioperl.pod
+lib/perl5/site_perl/%%PERL_VER%%/bioback.pod
+lib/perl5/site_perl/%%PERL_VER%%/biodesign.pod
+lib/perl5/site_perl/%%PERL_VER%%/biostart.pod
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Bio/.packlist
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Bio/Ext/Align/Align.bs
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Bio/Ext/Align/Align.so
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/Bio/Ext/Align.pm
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Bio/Ext/Align/.packlist
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/Bio/DB
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/Bio/Root
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/Bio/SeqIO
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/Bio/Tools/Sim4
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/Bio/Tools/Blast/Run
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/Bio/Tools/Blast
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/Bio/Tools/HMMER
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/Bio/Tools
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/Bio/Search/Hit
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/Bio/Search/Processor
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/Bio/Search/Result
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/Bio/Search
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/Bio/Index
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/Bio/Annotation
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/Bio/SeqFeature
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/Bio
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Bio/Ext/Align/
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Bio/Ext
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Bio