aboutsummaryrefslogtreecommitdiff
path: root/biology/phd2fasta
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2008-05-24 07:01:56 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2008-05-24 07:01:56 +0000
commitf30ad7580d7a6f3c5dab9d8077303c626f666103 (patch)
tree772f2e31232aeb3f4b81dc2c607b3c4eed5a0742 /biology/phd2fasta
parent69ef603a618688f044050396aace9411be47fe96 (diff)
downloadports-f30ad7580d7a6f3c5dab9d8077303c626f666103.tar.gz
ports-f30ad7580d7a6f3c5dab9d8077303c626f666103.zip
Notes
Diffstat (limited to 'biology/phd2fasta')
-rw-r--r--biology/phd2fasta/Makefile48
1 files changed, 48 insertions, 0 deletions
diff --git a/biology/phd2fasta/Makefile b/biology/phd2fasta/Makefile
new file mode 100644
index 000000000000..ef0df20fa7dc
--- /dev/null
+++ b/biology/phd2fasta/Makefile
@@ -0,0 +1,48 @@
+# New ports collection makefile for: phd2fasta
+# Date created: 6 December 2007
+# Whom: Motomichi Matsuzaki <mzaki@biol.s.u-tokyo.ac.jp>
+#
+# $FreeBSD$
+#
+
+PORTNAME= phd2fasta
+PORTVERSION= 0.990622.f
+CATEGORIES= biology
+MASTER_SITES= # put the tarball manually
+DISTFILES= phd2fasta-acd-dist.tar.Z
+
+MAINTAINER= mzaki@biol.s.u-tokyo.ac.jp
+COMMENT= A converter from output files of Phred/Consed to FASTA files
+
+RESTRICTED= Redistribution is not permitted in any form. You must request the tarball via e-mail. Free for academic use.
+
+NO_WRKSUBDIR= yes
+
+ALL_TARGET= phd2fasta
+
+BINMODE= 0111 # avoid copying binaries as required by the agreement
+BINARIES= phd2fasta
+PLIST_FILES= bin/phd2fasta
+
+PORTDOCS= PHD2FASTA.DOC
+
+.include <bsd.port.pre.mk>
+
+.for f in ${DISTFILES}
+.if !exists(${DISTDIR}/${f})
+IGNORE= you must request the source code \(${f}\) via e-mail, place it manually in ${DISTDIR}, and then try it again
+.endif
+.endfor
+
+do-install:
+.for f in ${BINARIES}
+ @${INSTALL_PROGRAM} ${WRKSRC}/${f} ${PREFIX}/bin/
+.endfor
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+.for f in ${PORTDOCS}
+ @${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.post.mk>