aboutsummaryrefslogtreecommitdiff
path: root/biology/phrap
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2008-05-24 07:04:45 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2008-05-24 07:04:45 +0000
commit5081af2c649bf6005a0472de4f6dfe99b6786f36 (patch)
treef9a70ac725d6822494225b59eb82fcd00bde8e55 /biology/phrap
parentc65af41a3b0e8a047f8159fa8fbd0bc8473e69e4 (diff)
downloadports-5081af2c649bf6005a0472de4f6dfe99b6786f36.tar.gz
ports-5081af2c649bf6005a0472de4f6dfe99b6786f36.zip
Notes
Diffstat (limited to 'biology/phrap')
-rw-r--r--biology/phrap/Makefile62
-rw-r--r--biology/phrap/distinfo3
-rw-r--r--biology/phrap/files/patch-makefile27
-rw-r--r--biology/phrap/pkg-descr21
4 files changed, 113 insertions, 0 deletions
diff --git a/biology/phrap/Makefile b/biology/phrap/Makefile
new file mode 100644
index 000000000000..094d772390aa
--- /dev/null
+++ b/biology/phrap/Makefile
@@ -0,0 +1,62 @@
+# New ports collection makefile for: phrap
+# Date created: 21 June 2005
+# Whom: Motomichi Matsuzaki <mzaki@biol.s.u-tokyo.ac.jp>
+#
+# $FreeBSD$
+#
+
+PORTNAME= phrap
+PORTVERSION= 0.990329
+CATEGORIES= biology
+MASTER_SITES= # put the tarball manually
+DISTFILES= distrib.tar.Z
+DIST_SUBDIR= ${PORTNAME}
+
+MAINTAINER= mzaki@biol.s.u-tokyo.ac.jp
+COMMENT= Phrap is a program for assembling shotgun DNA sequence data
+
+RESTRICTED= Redistribution is not permitted in any form. You must request the tarball via e-mail. Free for academic use.
+
+NO_WRKSUBDIR= yes
+
+MAKEFILE= makefile
+ALL_TARGET= all manyreads
+
+BINARIES= cluster cross_match cross_match.manyreads loco \
+ phrap phrap.longreads phrap.manyreads swat
+SCRIPTS= phrapview
+.for f in ${BINARIES} ${SCRIPTS}
+PLIST_FILES+= bin/${f}
+.endfor
+
+PORTDATA= BLOSUM50 BLOSUM62 PAM250 mat50 mat70 penalty2 vector.seq
+PORTDOCS= general.doc phrap.doc swat.doc
+
+.include <bsd.port.pre.mk>
+
+.for f in ${DISTFILES}
+.if !exists(${DISTDIR}/${DIST_SUBDIR}/${f})
+IGNORE= you must request the source code \(${DISTFILES}\) via e-mail, place it manually in ${DISTDIR}/${DIST_SUBDIR}, and then try it again
+.endif
+.endfor
+
+do-install:
+.for f in ${BINARIES}
+ @${INSTALL_PROGRAM} ${WRKSRC}/${f} ${PREFIX}/bin/
+ @${CHMOD} a-r ${PREFIX}/bin/${f} # as required by the agreement
+.endfor
+.for f in ${SCRIPTS}
+ @${INSTALL_SCRIPT} ${WRKSRC}/${f} ${PREFIX}/bin/
+.endfor
+ @${MKDIR} ${DATADIR}
+.for f in ${PORTDATA}
+ @${INSTALL_DATA} ${WRKSRC}/${f} ${DATADIR}
+.endfor
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+.for f in ${PORTDOCS}
+ @${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/biology/phrap/distinfo b/biology/phrap/distinfo
new file mode 100644
index 000000000000..ad0d45f9a994
--- /dev/null
+++ b/biology/phrap/distinfo
@@ -0,0 +1,3 @@
+MD5 (phrap/distrib.tar.Z) = 35175595801cafd22ec348fb9dba0ce4
+SHA256 (phrap/distrib.tar.Z) = e0be79818e3a8ca17391f42cc0ffbaf1a63299c8845a0b9ac3aaeb3cac641fcc
+SIZE (phrap/distrib.tar.Z) = 366163
diff --git a/biology/phrap/files/patch-makefile b/biology/phrap/files/patch-makefile
new file mode 100644
index 000000000000..7fccdb3846a1
--- /dev/null
+++ b/biology/phrap/files/patch-makefile
@@ -0,0 +1,27 @@
+--- makefile.orig 1999-03-11 15:13:20.000000000 +0900
++++ makefile 2007-12-11 13:19:39.000000000 +0900
+@@ -23,8 +23,8 @@
+ #*****************************************************************************/
+
+ # Makefile for swat, phrap, cross_match, phrapview; also swprobs (currently inactivated)
+-CC= cc
+-CFLAGS= -O2
++CC?= cc
++#CFLAGS= -O2
+ LFLAGS= -lm
+
+ SWATOBJS= swat.o weibull.o
+@@ -55,11 +55,11 @@
+
+ manyreads:
+ touch swat.h;
+- make CFLAGS="-O2 -DMANYREADS" phrap cross_match;
++ make CFLAGS="$(CFLAGS) -DMANYREADS" phrap cross_match;
+ mv phrap phrap.manyreads;
+ mv cross_match cross_match.manyreads;
+ touch swat.h;
+- make CFLAGS="-O2 -DLONGREADS" phrap;
++ make CFLAGS="$(CFLAGS) -DLONGREADS" phrap;
+ mv phrap phrap.longreads;
+ touch swat.h;
+ make phrap cross_match;
diff --git a/biology/phrap/pkg-descr b/biology/phrap/pkg-descr
new file mode 100644
index 000000000000..d8d44bb5d37c
--- /dev/null
+++ b/biology/phrap/pkg-descr
@@ -0,0 +1,21 @@
+Phrap is a program for assembling shotgun DNA sequence data.
+Among other features, it allows use of the entire read and not just the
+trimmed high quality part, it uses a combination of user-supplied and
+internally computed data quality information to improve assembly accuracy
+in the presence of repeats, it constructs the contig sequence as a mosaic
+of the highest quality read segments rather than a consensus, it provides
+extensive assembly information to assist in trouble-shooting assembly
+problems, and it handles large datasets.
+
+This package also contains Swat and Cross_match.
+Swat is a program for searching one or more DNA or protein query sequences
+against a sequence database, using (an efficient implementation of) the
+Smith-Waterman-Gotoh algorithm.
+Cross_Match is a general-purpose utility based on Swat for comparing any
+two sets of DNA sequences, and it can be used to:
+* produce vector-masked versions of a set of reads
+* compare a set of cDNA sequences to a set of cosmids
+* compare contigs found by two altanative assembly procedures to each other
+* compare phrap contigs to the final edited cosmid sequence.
+
+WWW: http://www.phrap.org/phredphrapconsed.html