aboutsummaryrefslogtreecommitdiff
path: root/biology/phylip
diff options
context:
space:
mode:
authorSam Lawrance <lawrance@FreeBSD.org>2006-02-08 14:45:45 +0000
committerSam Lawrance <lawrance@FreeBSD.org>2006-02-08 14:45:45 +0000
commitc6f127a070f4ab6b39018113a89aebcb72a9ddf2 (patch)
tree974b3ff62925162e5455044883466772be849746 /biology/phylip
parent830c9d1598d0ab0201e4121783463dc98433d5ab (diff)
downloadports-c6f127a070f4ab6b39018113a89aebcb72a9ddf2.tar.gz
ports-c6f127a070f4ab6b39018113a89aebcb72a9ddf2.zip
Notes
Diffstat (limited to 'biology/phylip')
-rw-r--r--biology/phylip/Makefile41
-rw-r--r--biology/phylip/distinfo6
-rw-r--r--biology/phylip/pkg-plist43
3 files changed, 17 insertions, 73 deletions
diff --git a/biology/phylip/Makefile b/biology/phylip/Makefile
index d49910a8b370..e9bead002b1c 100644
--- a/biology/phylip/Makefile
+++ b/biology/phylip/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= phylip
-PORTVERSION= 3.6
-PORTEPOCH= 1
+PORTVERSION= 3.65
CATEGORIES= biology
MASTER_SITES= ftp://evolution.genetics.washington.edu/pub/phylip/ \
http://bioinformatics.weizmann.ac.il/software/linkage_and_mapping/phylip/ \
@@ -17,6 +16,7 @@ MASTER_SITE_SUBDIR= distfiles
MAINTAINER= dbader@ece.unm.edu
COMMENT= A Phylogeny Inference Package
+WRKSRC= ${WRKDIR}/${PORTNAME}${PORTVERSION}
USE_XLIB= yes
BUILD_WRKSRC= ${WRKSRC}/src
@@ -24,36 +24,23 @@ MAKE_ARGS= CC="${CC} ${CFLAGS}" \
DC="${CC} -DX -I${X11BASE}/include ${CFLAGS}" \
GLIBS="-L${X11BASE}/lib -lX11 -lm"
-BINARIES= clique consense contml contrast dnacomp dnadist dnainvar \
- dnaml dnamlk dnamove dnapars dnapenny dollop dolmove \
- dolpenny drawgram drawtree factor fitch gendist kitsch \
- mix move neighbor pars penny proml promlk protdist \
- protpars restdist restml retree seqboot treedist
-DOCFILES= clique.html consense.html contchar.html contml.html \
- contrast.html discrete.html distance.html dnacomp.html \
- dnadist.html dnainvar.html dnaml.html dnamlk.html \
- dnamove.html dnapars.html dnapenny.html dollop.html \
- dolmove.html dolpenny.html draw.html drawgram.html \
- drawtree.html factor.html fitch.html gendist.html \
- kitsch.html main.html mix.html move.html neighbor.html \
- pars.html penny.html phylip.gif proml.html promlk.html \
- protdist.html protpars.html restdist.html restml.html \
- retree.html seqboot.html sequence.html treedist.html
-FONTFILES= font1 font2 font3 font4 font5 font6
+PORTDOCS= *
do-install:
-.for f in ${BINARIES}
- ${INSTALL_PROGRAM} ${BUILD_WRKSRC}/${f} ${PREFIX}/bin
-.endfor
+ @cd ${BUILD_WRKSRC} && ${MAKE} install
+
+ @cd ${WRKSRC}/exe && \
+ ${FIND} . -not -type d -not -name 'font*' -exec ${INSTALL_PROGRAM} "{}" "${PREFIX}/bin/{}" \;
+
${MKDIR} ${DATADIR}
-.for font in ${FONTFILES}
- ${INSTALL_DATA} ${BUILD_WRKSRC}/${font} ${DATADIR}
-.endfor
+ @cd ${WRKSRC}/exe && \
+ ${FIND} . -not -type d -name 'font*' -exec ${INSTALL_DATA} "{}" "${DATADIR}/{}" \;
+
+post-install:
.if !defined(NOPORTDOCS)
${MKDIR} ${DOCSDIR}
-.for f in ${DOCFILES}
- ${INSTALL_DATA} ${WRKDIR}/${DISTNAME}/doc/${f} ${DOCSDIR}
-.endfor
+ @cd ${WRKSRC}/doc && \
+ ${FIND} . -not -type d -exec ${INSTALL_DATA} "{}" "${DOCSDIR}/{}" \;
.endif
.include <bsd.port.mk>
diff --git a/biology/phylip/distinfo b/biology/phylip/distinfo
index 9ad7147099e4..4c9fc0ab8b76 100644
--- a/biology/phylip/distinfo
+++ b/biology/phylip/distinfo
@@ -1,3 +1,3 @@
-MD5 (phylip-3.6.tar.gz) = ff0ded7756db29d948f355ed5cc020cc
-SHA256 (phylip-3.6.tar.gz) = 2e5ccf074ae33d17302afc75dd0533a189502bb2b83ed361ccc345cad09a142b
-SIZE (phylip-3.6.tar.gz) = 855538
+MD5 (phylip-3.65.tar.gz) = c89a92c8692faaba4310b69b2d89bc33
+SHA256 (phylip-3.65.tar.gz) = 8f8ab66a58dbe1fdf0b615c13b6d358d6c49195fbaeaabc6190253e895c0d528
+SIZE (phylip-3.65.tar.gz) = 1036976
diff --git a/biology/phylip/pkg-plist b/biology/phylip/pkg-plist
index a5523cad3ad2..86a349a1e9d8 100644
--- a/biology/phylip/pkg-plist
+++ b/biology/phylip/pkg-plist
@@ -33,48 +33,6 @@ bin/restml
bin/retree
bin/seqboot
bin/treedist
-%%PORTDOCS%%%%DOCSDIR%%/clique.html
-%%PORTDOCS%%%%DOCSDIR%%/consense.html
-%%PORTDOCS%%%%DOCSDIR%%/contchar.html
-%%PORTDOCS%%%%DOCSDIR%%/contml.html
-%%PORTDOCS%%%%DOCSDIR%%/contrast.html
-%%PORTDOCS%%%%DOCSDIR%%/discrete.html
-%%PORTDOCS%%%%DOCSDIR%%/distance.html
-%%PORTDOCS%%%%DOCSDIR%%/dnacomp.html
-%%PORTDOCS%%%%DOCSDIR%%/dnadist.html
-%%PORTDOCS%%%%DOCSDIR%%/dnainvar.html
-%%PORTDOCS%%%%DOCSDIR%%/dnaml.html
-%%PORTDOCS%%%%DOCSDIR%%/dnamlk.html
-%%PORTDOCS%%%%DOCSDIR%%/dnamove.html
-%%PORTDOCS%%%%DOCSDIR%%/dnapars.html
-%%PORTDOCS%%%%DOCSDIR%%/dnapenny.html
-%%PORTDOCS%%%%DOCSDIR%%/dollop.html
-%%PORTDOCS%%%%DOCSDIR%%/dolmove.html
-%%PORTDOCS%%%%DOCSDIR%%/dolpenny.html
-%%PORTDOCS%%%%DOCSDIR%%/draw.html
-%%PORTDOCS%%%%DOCSDIR%%/drawgram.html
-%%PORTDOCS%%%%DOCSDIR%%/drawtree.html
-%%PORTDOCS%%%%DOCSDIR%%/factor.html
-%%PORTDOCS%%%%DOCSDIR%%/fitch.html
-%%PORTDOCS%%%%DOCSDIR%%/gendist.html
-%%PORTDOCS%%%%DOCSDIR%%/kitsch.html
-%%PORTDOCS%%%%DOCSDIR%%/main.html
-%%PORTDOCS%%%%DOCSDIR%%/mix.html
-%%PORTDOCS%%%%DOCSDIR%%/move.html
-%%PORTDOCS%%%%DOCSDIR%%/neighbor.html
-%%PORTDOCS%%%%DOCSDIR%%/pars.html
-%%PORTDOCS%%%%DOCSDIR%%/penny.html
-%%PORTDOCS%%%%DOCSDIR%%/phylip.gif
-%%PORTDOCS%%%%DOCSDIR%%/proml.html
-%%PORTDOCS%%%%DOCSDIR%%/promlk.html
-%%PORTDOCS%%%%DOCSDIR%%/protdist.html
-%%PORTDOCS%%%%DOCSDIR%%/protpars.html
-%%PORTDOCS%%%%DOCSDIR%%/restdist.html
-%%PORTDOCS%%%%DOCSDIR%%/restml.html
-%%PORTDOCS%%%%DOCSDIR%%/retree.html
-%%PORTDOCS%%%%DOCSDIR%%/seqboot.html
-%%PORTDOCS%%%%DOCSDIR%%/sequence.html
-%%PORTDOCS%%%%DOCSDIR%%/treedist.html
%%DATADIR%%/font1
%%DATADIR%%/font2
%%DATADIR%%/font3
@@ -82,4 +40,3 @@ bin/treedist
%%DATADIR%%/font5
%%DATADIR%%/font6
@dirrm %%DATADIR%%
-%%PORTDOCS%%@dirrm %%DOCSDIR%%