aboutsummaryrefslogtreecommitdiff
path: root/biology/plink
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2014-02-16 17:15:31 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2014-02-16 17:15:31 +0000
commit564a799c7173c288d4d3a9be78ac3d2db983d512 (patch)
tree49e521faa408bc4bd163bfb0febf91e262772c1c /biology/plink
parentaf1790bfbbcd5831281907db9c04f3776b8d601c (diff)
downloadports-564a799c7173c288d4d3a9be78ac3d2db983d512.tar.gz
ports-564a799c7173c288d4d3a9be78ac3d2db983d512.zip
Notes
Diffstat (limited to 'biology/plink')
-rw-r--r--biology/plink/Makefile13
-rw-r--r--biology/plink/files/patch-Makefile9
2 files changed, 11 insertions, 11 deletions
diff --git a/biology/plink/Makefile b/biology/plink/Makefile
index bfd37ec1e825..a9711e69d1b5 100644
--- a/biology/plink/Makefile
+++ b/biology/plink/Makefile
@@ -3,10 +3,11 @@
PORTNAME= plink
PORTVERSION= 1.07
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= biology science
MASTER_SITES= http://pngu.mgh.harvard.edu/~purcell/plink/dist/
DISTNAME= ${PORTNAME}-${PORTVERSION}-src
+EXTRACT_SUFX= .zip
MAINTAINER= jwbacon@tds.net
COMMENT= Whole genome association analysis toolset
@@ -15,15 +16,13 @@ LICENSE= GPLv2
LIB_DEPENDS= liblapack.so:${PORTSDIR}/math/lapack
-USES= gmake
-USE_ZIP= yes
-USE_FORTRAN= yes # Make it use the same compiler as lapack
+# We need Fortran LDFLAGS to link with Lapack.
+USES= fortran gmake
PLIST_FILES= bin/plink
-NO_STAGE= yes
do-install:
- ${MKDIR} ${PREFIX}/bin
- ${INSTALL_PROGRAM} ${WRKSRC}/plink ${PREFIX}/bin
+ ${MKDIR} ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/plink ${STAGEDIR}${PREFIX}/bin
.include <bsd.port.mk>
diff --git a/biology/plink/files/patch-Makefile b/biology/plink/files/patch-Makefile
index cb1e7f5fc537..e98b69aa6559 100644
--- a/biology/plink/files/patch-Makefile
+++ b/biology/plink/files/patch-Makefile
@@ -1,15 +1,16 @@
--- Makefile.orig 2009-10-10 11:00:20.000000000 -0500
+++ Makefile 2012-09-07 08:24:26.000000000 -0500
-@@ -26,7 +26,7 @@
+@@ -26,25 +26,25 @@
WITH_WEBCHECK = 1
FORCE_32BIT =
WITH_ZLIB = 1
-WITH_LAPACK =
+-FORCE_DYNAMIC =
+WITH_LAPACK = 1
- FORCE_DYNAMIC =
++FORCE_DYNAMIC = 1
# Put C++ compiler here; Windows has it's own specific version
-@@ -34,17 +34,17 @@
+ CXX_UNIX = g++
CXX_WIN = c:\bin\mingw\bin\mingw32-g++.exe
# Any other compiler flags here ( -Wall, -g, etc)
@@ -18,7 +19,7 @@
# Misc
-LIB_LAPACK = /usr/lib/liblapack.so.3
-+LIB_LAPACK = -L${LOCALBASE}/lib -llapack -lblas -lgfortran
++LIB_LAPACK = ${LDFLAGS} -L${LOCALBASE}/lib -llapack -lblas
# --------------------------------------------------------------------