aboutsummaryrefslogtreecommitdiff
path: root/biology/py-biom-format
diff options
context:
space:
mode:
authorOlivier Duchateau <olivierd@FreeBSD.org>2016-05-09 16:37:44 +0000
committerOlivier Duchateau <olivierd@FreeBSD.org>2016-05-09 16:37:44 +0000
commit0eea70a2a038b7550bf9f1351f06fb3fd4577950 (patch)
tree84a1a89316adf9732c48a7052d3ef61848b1459e /biology/py-biom-format
parent481c6fe6c96e64363ac277f304bcfeddc9bf203c (diff)
downloadports-0eea70a2a038b7550bf9f1351f06fb3fd4577950.tar.gz
ports-0eea70a2a038b7550bf9f1351f06fb3fd4577950.zip
Notes
Diffstat (limited to 'biology/py-biom-format')
-rw-r--r--biology/py-biom-format/Makefile26
-rw-r--r--biology/py-biom-format/distinfo2
-rw-r--r--biology/py-biom-format/pkg-descr19
3 files changed, 47 insertions, 0 deletions
diff --git a/biology/py-biom-format/Makefile b/biology/py-biom-format/Makefile
new file mode 100644
index 000000000000..adb20e4c7484
--- /dev/null
+++ b/biology/py-biom-format/Makefile
@@ -0,0 +1,26 @@
+# Created by: Joseph Mingrone <jrm@ftfl.ca>
+# $FreeBSD$
+
+PORTNAME= biom-format
+PORTVERSION= 2.1.5
+CATEGORIES= biology python
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= jrm@ftfl.ca
+COMMENT= Biological Observation Matrix (BIOM) Format Project
+
+LICENSE= BSD3CLAUSE
+
+BUILD_DEPENDS= ${PYNUMPY}
+RUN_DEPENDS= ${PYNUMPY} ${PYTHON_PKGNAMEPREFIX}h5py>0:science/py-h5py
+
+USE_GITHUB= yes
+GH_ACCOUNT= biocore
+
+USES= python
+USE_PYTHON= autoplist distutils
+
+post-install:
+ ${STRIP_CMD} ${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}/biom/*.so
+
+.include <bsd.port.mk>
diff --git a/biology/py-biom-format/distinfo b/biology/py-biom-format/distinfo
new file mode 100644
index 000000000000..50be5f77ff2b
--- /dev/null
+++ b/biology/py-biom-format/distinfo
@@ -0,0 +1,2 @@
+SHA256 (biocore-biom-format-2.1.5_GH0.tar.gz) = e808db612291536e3ca2297c6d72b99154a324fb55fb8898baabc71ceee045d8
+SIZE (biocore-biom-format-2.1.5_GH0.tar.gz) = 11963101
diff --git a/biology/py-biom-format/pkg-descr b/biology/py-biom-format/pkg-descr
new file mode 100644
index 000000000000..2b0a35032361
--- /dev/null
+++ b/biology/py-biom-format/pkg-descr
@@ -0,0 +1,19 @@
+The BIOM file format (canonically pronounced biome) is designed to be a
+general-use format for representing biological sample by observation contingency
+tables. BIOM is a recognized standard for the Earth Microbiome Project and is a
+Genomics Standards Consortium supported project.
+
+The BIOM format is designed for general use in broad areas of comparative
+-omics. For example, in marker-gene surveys, the primary use of this format is
+to represent OTU tables: the observations in this case are OTUs and the matrix
+contains counts corresponding to the number of times each OTU is observed in
+each sample. With respect to metagenome data, this format would be used to
+represent metagenome tables: the observations in this case might correspond to
+SEED subsystems, and the matrix would contain counts corresponding to the number
+of times each subsystem is observed in each metagenome. Similarly, with respect
+to genome data, this format may be used to represent a set of genomes: the
+observations in this case again might correspond to SEED subsystems, and the
+counts would correspond to the number of times each subsystem is observed in
+each genome.
+
+WWW: http://biom-format.org