aboutsummaryrefslogtreecommitdiff
path: root/biology/sim4/Makefile
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2004-03-12 13:53:23 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2004-03-12 13:53:23 +0000
commit03062baaf5081cb4949714a58f22f562e6855cbe (patch)
tree42f918d033c39be46732858ba892d88649b6dcc7 /biology/sim4/Makefile
parentc3ec81783c1a034dc04b8bf5b33a28ce876ddb8f (diff)
Notes
Diffstat (limited to 'biology/sim4/Makefile')
-rw-r--r--biology/sim4/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/biology/sim4/Makefile b/biology/sim4/Makefile
index dedfc9fc9ca1..7864d6efa064 100644
--- a/biology/sim4/Makefile
+++ b/biology/sim4/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= sim4
-PORTVERSION= 2002.03.03
+PORTVERSION= 2003.09.21
CATEGORIES= biology
MASTER_SITES= http://globin.cse.psu.edu/ftp/dist/sim4/
DISTNAME= ${PORTNAME}.${PORTVERSION:S/./-/g}
@@ -16,9 +16,15 @@ COMMENT= An algorithm for aligning expressed DNA with genomic sequences
WRKSRC= ${WRKDIR}/sim4.${PORTVERSION:S/./-/g}
+USE_REINPLACE= yes
+
ALL_TARGET= sim4
PLIST_FILES= bin/sim4
+post-patch:
+ ${REINPLACE_CMD} -e 's|^CC=|CC?=|g ; \
+ s|^CFLAGS=|CFLAGS+=|g' ${WRKSRC}/Makefile
+
do-install:
@ ${INSTALL_PROGRAM} ${WRKSRC}/sim4 ${PREFIX}/bin