aboutsummaryrefslogtreecommitdiff
path: root/biology/t_coffee/Makefile
diff options
context:
space:
mode:
authorMarcelo Araujo <araujo@FreeBSD.org>2013-01-14 08:04:38 +0000
committerMarcelo Araujo <araujo@FreeBSD.org>2013-01-14 08:04:38 +0000
commit05e78fe84a921ae6ae0693ad331d263c75d14dff (patch)
tree2817937a8e693b4cc507bc086546dfff7275d443 /biology/t_coffee/Makefile
parent3b850ce68d852965134102be1c43b7a5a26ba585 (diff)
downloadports-05e78fe84a921ae6ae0693ad331d263c75d14dff.tar.gz
ports-05e78fe84a921ae6ae0693ad331d263c75d14dff.zip
Notes
Diffstat (limited to 'biology/t_coffee/Makefile')
-rw-r--r--biology/t_coffee/Makefile42
1 files changed, 23 insertions, 19 deletions
diff --git a/biology/t_coffee/Makefile b/biology/t_coffee/Makefile
index 216884fc8d47..6e6c28d7b721 100644
--- a/biology/t_coffee/Makefile
+++ b/biology/t_coffee/Makefile
@@ -2,36 +2,40 @@
# $FreeBSD$
PORTNAME= t_coffee
-PORTVERSION= 5.68
+PORTVERSION= 9.03
+DISTVERSIONSUFFIX= .r1318
CATEGORIES= biology
-MASTER_SITES= http://www.tcoffee.org/Packages/
-DISTNAME= T-COFFEE_distribution_Version_${PORTVERSION}
+MASTER_SITES= http://www.tcoffee.org/Packages/Stable/%SUBDIR%/
+MASTER_SITE_SUBDIR= Version_${PORTVERSION}${DISTVERSIONSUFFIX}
+DISTNAME= T-COFFEE_distribution_Version_${PORTVERSION}${DISTVERSIONSUFFIX}
MAINTAINER= ports@FreeBSD.org
COMMENT= A multiple DNA or protein sequence alignment package
-BUILD_DEPENDS= clustalw:${PORTSDIR}/biology/clustalw
-RUN_DEPENDS:= ${BUILD_DEPENDS}
+LICENSE= GPLv2
+
+RUN_DEPENDS= clustalw:${PORTSDIR}/biology/clustalw
+
+OPTIONS_DEFINE= EXAMPLES
BUILD_WRKSRC= ${WRKSRC}/t_coffee_source
-MAKE_ENV= MV=${MV} USER_BIN=${PREFIX}/bin \
- CLUSTALW_4_TCOFFEE=${LOCALBASE}/bin/clustalw
+USE_FORTRAN= yes
+MAKE_ENV= FCC="${FC} ${FFLAGS}"
MAKEFILE= makefile
+MAKE_JOBS_SAFE= yes
+
+PORTEXAMPLES= *
+PLIST_FILES= bin/TMalign bin/t_coffee
+
+.include <bsd.port.options.mk>
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/bin/t_coffee ${PREFIX}/bin
-
-post-install:
-.if !defined(NOPORTDOCS)
- @ ${MKDIR} ${DOCSDIR}/html
- ${INSTALL_DATA} ${WRKSRC}/doc/* ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/license.txt ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/html/* ${DOCSDIR}/html
-.endif
-.if !defined(NOPORTEXAMPLES)
- @ ${MKDIR} ${EXAMPLESDIR}
- cd ${WRKSRC}/example && ${COPYTREE_SHARE} \* ${EXAMPLESDIR}
+ (cd ${BUILD_WRKSRC} \
+ && ${INSTALL_PROGRAM} TMalign t_coffee ${PREFIX}/bin)
+.if ${PORT_OPTIONS:MEXAMPLES}
+ @${MKDIR} ${EXAMPLESDIR}
+ @(cd ${WRKSRC}/example && ${COPYTREE_SHARE} . ${EXAMPLESDIR})
.endif
.include <bsd.port.mk>