aboutsummaryrefslogtreecommitdiff
path: root/biology/tinker
diff options
context:
space:
mode:
authorThomas Zander <riggs@FreeBSD.org>2014-04-22 19:28:18 +0000
committerThomas Zander <riggs@FreeBSD.org>2014-04-22 19:28:18 +0000
commit50fd87108f3acb28a48988322425c3128b68ed4b (patch)
tree7eb4ce8c1e501aafa639e81ce5432adc2afede82 /biology/tinker
parent53fb1c446184a0b0e65a08a4b71314b3ab342507 (diff)
Notes
Diffstat (limited to 'biology/tinker')
-rw-r--r--biology/tinker/Makefile11
-rw-r--r--biology/tinker/distinfo4
-rw-r--r--biology/tinker/files/patch-make__Makefile22
-rw-r--r--biology/tinker/files/pkg-message.in7
-rw-r--r--biology/tinker/pkg-plist2
5 files changed, 34 insertions, 12 deletions
diff --git a/biology/tinker/Makefile b/biology/tinker/Makefile
index d5f72a424a66..2532bfdfb905 100644
--- a/biology/tinker/Makefile
+++ b/biology/tinker/Makefile
@@ -2,17 +2,20 @@
# $FreeBSD$
PORTNAME= tinker
-PORTVERSION= 6.2.06
-PORTREVISION= 4
+PORTVERSION= 6.2.6
+PORTREVISION= 5
CATEGORIES= biology
MASTER_SITES= http://dasher.wustl.edu/tinker/downloads/
MAINTAINER= ports@FreeBSD.org
COMMENT= General purpose molecular modelling package
-RESTRICTED= author requests no distribution except from his FTP site
+LICENSE= tinker
+LICENSE_NAME= TINKER license agreement
+LICENSE_FILE= ${WRKSRC}/doc/license.txt
+LICENSE_PERMS= auto-accept
-CONFLICTS_INSTALL= hunspell-[0-9]*
+RESTRICTED= author requests no distribution except from his FTP site
OPTIONS_DEFINE= OPTIMIZED_FFLAGS DOCS EXAMPLES
OPTIMIZED_FFLAGS_DESC= compilation optimizations
diff --git a/biology/tinker/distinfo b/biology/tinker/distinfo
index 72d46d1ab4cc..bc1c2532d74e 100644
--- a/biology/tinker/distinfo
+++ b/biology/tinker/distinfo
@@ -1,2 +1,2 @@
-SHA256 (tinker-6.2.06.tar.gz) = a6eb5cb31b7e93a1f2d323ca73e45f16291763a3e0faa3615a3219e6f9814277
-SIZE (tinker-6.2.06.tar.gz) = 20181780
+SHA256 (tinker-6.2.6.tar.gz) = a6eb5cb31b7e93a1f2d323ca73e45f16291763a3e0faa3615a3219e6f9814277
+SIZE (tinker-6.2.6.tar.gz) = 20181780
diff --git a/biology/tinker/files/patch-make__Makefile b/biology/tinker/files/patch-make__Makefile
index 8417bb2c8ce7..ae08857b8632 100644
--- a/biology/tinker/files/patch-make__Makefile
+++ b/biology/tinker/files/patch-make__Makefile
@@ -1,5 +1,5 @@
---- make/Makefile.orig 2012-06-29 14:51:42.000000000 +0900
-+++ make/Makefile 2012-11-10 00:12:19.000000000 +0900
+--- make/Makefile.orig 2013-07-14 11:23:53.000000000 +0900
++++ make/Makefile 2014-03-14 16:59:17.000000000 +0900
@@ -30,9 +30,9 @@
## LINKDIR Linked Copies of TINKER Executables
##
@@ -73,7 +73,7 @@
all: ${EXEFILES}
-@@ -612,70 +625,70 @@
+@@ -612,74 +625,74 @@
rm -f *.o *.a *.x
listing:
@@ -143,7 +143,7 @@
- mv xyzpdb.x $(BINDIR)/xyzpdb
- mv xyzsybyl.x $(BINDIR)/xyzsybyl
+ ${BSD_INSTALL_PROGRAM} alchemy.x $(BINDIR)/alchemy
-+ ${BSD_INSTALL_PROGRAM} analyze.x $(BINDIR)/analyze
++ ${BSD_INSTALL_PROGRAM} analyze.x $(BINDIR)/analyze_t
+ ${BSD_INSTALL_PROGRAM} anneal.x $(BINDIR)/anneal
+ ${BSD_INSTALL_PROGRAM} archive.x $(BINDIR)/archive
+ ${BSD_INSTALL_PROGRAM} bar.x $(BINDIR)/bar
@@ -206,3 +206,17 @@
remove_links:
rm -f $(LINKDIR)/alchemy
+- rm -f $(LINKDIR)/analyze
++ rm -f $(LINKDIR)/analyze_t
+ rm -f $(LINKDIR)/anneal
+ rm -f $(LINKDIR)/archive
+ rm -f $(LINKDIR)/bar
+@@ -742,7 +755,7 @@
+
+ create_links:
+ ln -s $(BINDIR)/alchemy $(LINKDIR)/alchemy
+- ln -s $(BINDIR)/analyze $(LINKDIR)/analyze
++ ln -s $(BINDIR)/analyze_t $(LINKDIR)/analyze_t
+ ln -s $(BINDIR)/anneal $(LINKDIR)/anneal
+ ln -s $(BINDIR)/archive $(LINKDIR)/archive
+ ln -s $(BINDIR)/bar $(LINKDIR)/bar
diff --git a/biology/tinker/files/pkg-message.in b/biology/tinker/files/pkg-message.in
index 3e97fbda506c..58158ef0e8ac 100644
--- a/biology/tinker/files/pkg-message.in
+++ b/biology/tinker/files/pkg-message.in
@@ -2,5 +2,10 @@
The author requests that you return a license form
to him if you find Tinker to be useful.
- See %%DOCSDIR%% for license forms.
+ See %%PREFIX%%/share/licenses for license forms.
+
+ The name of TINKER's 'analyze' program has been changed
+ to 'analyze_t' during installation to allow for use on
+ systems where the very common hunspell package is
+ installed as well.
**********************************************************
diff --git a/biology/tinker/pkg-plist b/biology/tinker/pkg-plist
index 2a034a061e4f..b54913e9fe71 100644
--- a/biology/tinker/pkg-plist
+++ b/biology/tinker/pkg-plist
@@ -1,5 +1,5 @@
bin/alchemy
-bin/analyze
+bin/analyze_t
bin/anneal
bin/archive
bin/bar