aboutsummaryrefslogtreecommitdiff
path: root/biology/treeviewx
diff options
context:
space:
mode:
authorJohann Visagie <wjv@FreeBSD.org>2001-08-17 08:39:28 +0000
committerJohann Visagie <wjv@FreeBSD.org>2001-08-17 08:39:28 +0000
commit490da9f942df7f3ec3b9ba5c969ce24e19556336 (patch)
treeec9e81e1fefbe8a7174467009242cd1ea5770751 /biology/treeviewx
parent6e3e0cc16f48d805206f4af1d33e5ae36dc94a40 (diff)
downloadports-490da9f942df7f3ec3b9ba5c969ce24e19556336.tar.gz
ports-490da9f942df7f3ec3b9ba5c969ce24e19556336.zip
Notes
Diffstat (limited to 'biology/treeviewx')
-rw-r--r--biology/treeviewx/Makefile21
-rw-r--r--biology/treeviewx/distinfo1
-rw-r--r--biology/treeviewx/files/patch-Makefile.am11
-rw-r--r--biology/treeviewx/files/patch-Makefile.in28
-rw-r--r--biology/treeviewx/files/patch-configure10
-rw-r--r--biology/treeviewx/pkg-comment1
-rw-r--r--biology/treeviewx/pkg-descr8
-rw-r--r--biology/treeviewx/pkg-plist1
8 files changed, 81 insertions, 0 deletions
diff --git a/biology/treeviewx/Makefile b/biology/treeviewx/Makefile
new file mode 100644
index 000000000000..ca08369c2c1d
--- /dev/null
+++ b/biology/treeviewx/Makefile
@@ -0,0 +1,21 @@
+# Ports collection makefile for: treeviewx
+# Date created: 04 August 2001
+# Whom: tonym
+#
+# $FreeBSD$
+#
+
+PORTNAME= treeviewx
+PORTVERSION= 0.1.1
+CATEGORIES= biology
+MASTER_SITES= http://darwin.zoology.gla.ac.uk/~rpage/treeviewx/
+DISTNAME= tv-${PORTVERSION}
+
+MAINTAINER= tonym@biolateral.com.au
+
+LIB_DEPENDS= wx_gtk.2:${PORTSDIR}/x11-toolkits/wxgtk
+
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+
+.include <bsd.port.mk>
diff --git a/biology/treeviewx/distinfo b/biology/treeviewx/distinfo
new file mode 100644
index 000000000000..90645024694c
--- /dev/null
+++ b/biology/treeviewx/distinfo
@@ -0,0 +1 @@
+MD5 (tv-0.1.1.tar.gz) = 8cb3111130fa4623fb74d458659516fc
diff --git a/biology/treeviewx/files/patch-Makefile.am b/biology/treeviewx/files/patch-Makefile.am
new file mode 100644
index 000000000000..2aa04c00a381
--- /dev/null
+++ b/biology/treeviewx/files/patch-Makefile.am
@@ -0,0 +1,11 @@
+--- Makefile.am.orig Sat Aug 4 13:17:56 2001
++++ Makefile.am Sat Aug 4 13:18:17 2001
+@@ -125,7 +125,7 @@
+
+
+ all:
+- cd ncl-2.0/src; make libncl.a; # Paul Lewis Nexus Class Library
++ cd ncl-2.0/src; $(MAKE) libncl.a; # Paul Lewis Nexus Class Library
+
+ ${MAKE} $(PROGRAM);
+
diff --git a/biology/treeviewx/files/patch-Makefile.in b/biology/treeviewx/files/patch-Makefile.in
new file mode 100644
index 000000000000..c443674c804f
--- /dev/null
+++ b/biology/treeviewx/files/patch-Makefile.in
@@ -0,0 +1,28 @@
+--- Makefile.in.orig Sat Aug 4 05:09:46 2001
++++ Makefile.in Sat Aug 4 15:45:59 2001
+@@ -263,7 +263,7 @@
+ $(CC) -c $(CFLAGS) -I$(NCLDIR) -I$(TREELIBDIR) -I$(GPORTDIR) -DUSE_WXWINDOWS -o $@ $<
+
+ all:
+- cd ncl-2.0/src; make libncl.a; # Paul Lewis Nexus Class Library
++ cd ncl-2.0/src; $(MAKE) libncl.a; # Paul Lewis Nexus Class Library
+
+ ${MAKE} $(PROGRAM);
+
+@@ -273,6 +273,16 @@
+ tview.o : tview.cpp tview.h tproject.h
+ tv.o : tv.cpp tv.h tdoc.h tview.h tproject.h
+ tdoc.o: tdoc.cpp tdoc.h tview.h
++
++install : $(PROGRAM)
++ $(mkinstalldirs) $(DESTDIR)$(bindir)
++ @list='$(PROGRAM)'; for p in $$list; do \
++ if test -f $$p; then \
++ echo " $(INSTALL_PROGRAM) $$p $(DESTDIR)$(bindir)/`echo $$p|sed '$(transform)'`"; \
++ $(INSTALL_PROGRAM) $$p $(DESTDIR)$(bindir)/`echo $$p|sed '$(transform)' `; \
++ else :; fi; \
++ done
++
+
+ # Tell versions [3.59,3.63) of GNU make to not export all variables.
+ # Otherwise a system limit (for SysV at least) may be exceeded.
diff --git a/biology/treeviewx/files/patch-configure b/biology/treeviewx/files/patch-configure
new file mode 100644
index 000000000000..e205838a6d41
--- /dev/null
+++ b/biology/treeviewx/files/patch-configure
@@ -0,0 +1,10 @@
+--- configure.orig Thu Aug 16 15:55:01 2001
++++ configure Thu Aug 16 15:55:13 2001
+@@ -520,7 +520,6 @@
+ ac_n= ac_c='\c' ac_t=
+ fi
+
+- (tview.cpp)
+ ac_aux_dir=
+ for ac_dir in $srcdir $srcdir/.. $srcdir/../..; do
+ if test -f $ac_dir/install-sh; then
diff --git a/biology/treeviewx/pkg-comment b/biology/treeviewx/pkg-comment
new file mode 100644
index 000000000000..727dcca534d0
--- /dev/null
+++ b/biology/treeviewx/pkg-comment
@@ -0,0 +1 @@
+A phylogenetic tree viewer
diff --git a/biology/treeviewx/pkg-descr b/biology/treeviewx/pkg-descr
new file mode 100644
index 000000000000..c664fd364a8c
--- /dev/null
+++ b/biology/treeviewx/pkg-descr
@@ -0,0 +1,8 @@
+"TreeView X is program to display phylogenetic trees on Unix-like platforms.
+It can read and display NEXUS and Newick format tree files (such as those
+output by PAUP*, ClustalX, TREE-PUZZLE, and other programs)."
+
+WWW: http://darwin.zoology.gla.ac.uk/~rpage/treeviewx/
+
+--
+Tony Maher <tonym@biolateral.com.au>
diff --git a/biology/treeviewx/pkg-plist b/biology/treeviewx/pkg-plist
new file mode 100644
index 000000000000..1a3fda3a4d6a
--- /dev/null
+++ b/biology/treeviewx/pkg-plist
@@ -0,0 +1 @@
+bin/tv