aboutsummaryrefslogtreecommitdiff
path: root/biology/vcftools
diff options
context:
space:
mode:
authorRaphael Kubo da Costa <rakuco@FreeBSD.org>2016-02-26 17:07:59 +0000
committerRaphael Kubo da Costa <rakuco@FreeBSD.org>2016-02-26 17:07:59 +0000
commitfeaee54d6e02c143f5f3567f8c282b6fc408058b (patch)
tree9c455ffefa318620a3e3b235bd7b1c2ac46b80a8 /biology/vcftools
parent60e4e1d2616c676be98b780f940e5b44bfa92439 (diff)
downloadports-feaee54d6e02c143f5f3567f8c282b6fc408058b.tar.gz
ports-feaee54d6e02c143f5f3567f8c282b6fc408058b.zip
Notes
Diffstat (limited to 'biology/vcftools')
-rw-r--r--biology/vcftools/Makefile23
-rw-r--r--biology/vcftools/distinfo2
-rw-r--r--biology/vcftools/pkg-descr4
-rw-r--r--biology/vcftools/pkg-plist29
4 files changed, 58 insertions, 0 deletions
diff --git a/biology/vcftools/Makefile b/biology/vcftools/Makefile
new file mode 100644
index 000000000000..ef02fc16c34a
--- /dev/null
+++ b/biology/vcftools/Makefile
@@ -0,0 +1,23 @@
+# Created by: Jason Bacon <bacon4000@gmail.com>
+# $FreeBSD$
+
+PORTNAME= vcftools
+PORTVERSION= 0.1.14
+DISTVERSIONPREFIX= v
+CATEGORIES= biology
+DISTNAME= ${PORTNAME}_${PORTVERSION}
+
+MAINTAINER= bacon4000@gmail.com
+COMMENT= Tools for working with VCF genomics files
+
+LICENSE= LGPL3
+
+USES= autoreconf gmake perl5 pkgconfig
+
+GNU_CONFIGURE= yes
+# No zlib.pc on 9.x
+CONFIGURE_ENV= ZLIB_CFLAGS=" " ZLIB_LIBS="-lz"
+
+USE_GITHUB= yes
+
+.include <bsd.port.mk>
diff --git a/biology/vcftools/distinfo b/biology/vcftools/distinfo
new file mode 100644
index 000000000000..b4ab7d46ff00
--- /dev/null
+++ b/biology/vcftools/distinfo
@@ -0,0 +1,2 @@
+SHA256 (vcftools_0.1.14_GH0.tar.gz) = ba440584645e9901c1eeb6b769ccd828591f0575c73349072cde3efa77da6fdf
+SIZE (vcftools_0.1.14_GH0.tar.gz) = 241228
diff --git a/biology/vcftools/pkg-descr b/biology/vcftools/pkg-descr
new file mode 100644
index 000000000000..e9ceaa246e18
--- /dev/null
+++ b/biology/vcftools/pkg-descr
@@ -0,0 +1,4 @@
+A set of tools written in Perl and C++ for working with VCF files, such as
+those generated by the 1000 Genomes Project.
+
+WWW: https://github.com/vcftools/vcftools
diff --git a/biology/vcftools/pkg-plist b/biology/vcftools/pkg-plist
new file mode 100644
index 000000000000..0ad450ca4f19
--- /dev/null
+++ b/biology/vcftools/pkg-plist
@@ -0,0 +1,29 @@
+bin/fill-aa
+bin/fill-an-ac
+bin/fill-fs
+bin/fill-ref-md5
+bin/vcf-annotate
+bin/vcf-compare
+bin/vcf-concat
+bin/vcf-consensus
+bin/vcf-contrast
+bin/vcf-convert
+bin/vcf-fix-newlines
+bin/vcf-fix-ploidy
+bin/vcf-indel-stats
+bin/vcf-isec
+bin/vcf-merge
+bin/vcf-phased-join
+bin/vcf-query
+bin/vcf-shuffle-cols
+bin/vcf-sort
+bin/vcf-stats
+bin/vcf-subset
+bin/vcf-to-tab
+bin/vcf-tstv
+bin/vcf-validator
+bin/vcftools
+%%SITE_PERL%%/FaSlice.pm
+%%SITE_PERL%%/Vcf.pm
+%%SITE_PERL%%/VcfStats.pm
+man/man1/vcftools.1.gz