aboutsummaryrefslogtreecommitdiff
path: root/biology
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2018-10-19 02:05:37 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2018-10-19 02:05:37 +0000
commitac2652a87788097f19838182299cfe498b1a1d0f (patch)
treed5897f498a81440f8a618133371e3255e3e893b0 /biology
parentee084d897aaba510297460547150d067ee35ab0e (diff)
downloadports-ac2652a87788097f19838182299cfe498b1a1d0f.tar.gz
ports-ac2652a87788097f19838182299cfe498b1a1d0f.zip
New port: biology/py-pyfaidx: Efficient pythonic random access to fasta subsequences
Notes
Notes: svn path=/head/; revision=482399
Diffstat (limited to 'biology')
-rw-r--r--biology/Makefile1
-rw-r--r--biology/py-pyfaidx/Makefile21
-rw-r--r--biology/py-pyfaidx/distinfo3
-rw-r--r--biology/py-pyfaidx/pkg-descr13
4 files changed, 38 insertions, 0 deletions
diff --git a/biology/Makefile b/biology/Makefile
index 57778a520b56..520042420826 100644
--- a/biology/Makefile
+++ b/biology/Makefile
@@ -109,6 +109,7 @@
SUBDIR += py-macs2
SUBDIR += py-orange3-bioinformatics
SUBDIR += py-orange3-single-cell
+ SUBDIR += py-pyfaidx
SUBDIR += py-pysam
SUBDIR += pycogent
SUBDIR += pyfasta
diff --git a/biology/py-pyfaidx/Makefile b/biology/py-pyfaidx/Makefile
new file mode 100644
index 000000000000..7f97f9c4fc3d
--- /dev/null
+++ b/biology/py-pyfaidx/Makefile
@@ -0,0 +1,21 @@
+# $FreeBSD$
+
+PORTNAME= pyfaidx
+DISTVERSION= 0.5.5.1
+CATEGORIES= biology python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Efficient pythonic random access to fasta subsequences
+
+LICENSE= BSD3CLAUSE
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}six>0:devel/py-six@${PY_FLAVOR}
+
+USES= python
+USE_PYTHON= distutils concurrent autoplist
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/biology/py-pyfaidx/distinfo b/biology/py-pyfaidx/distinfo
new file mode 100644
index 000000000000..9229e09ed11f
--- /dev/null
+++ b/biology/py-pyfaidx/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1539913803
+SHA256 (pyfaidx-0.5.5.1.tar.gz) = d216924c901f39d445e13e574583442cd09f67424e13c2d33a5aacdfd367d39d
+SIZE (pyfaidx-0.5.5.1.tar.gz) = 30205
diff --git a/biology/py-pyfaidx/pkg-descr b/biology/py-pyfaidx/pkg-descr
new file mode 100644
index 000000000000..7bbfc03d6bf1
--- /dev/null
+++ b/biology/py-pyfaidx/pkg-descr
@@ -0,0 +1,13 @@
+FASTA is a format to exchange generic information, partial or of the entire
+organism.
+
+A function "faidx" (FAsta InDeX) creates a small flat index file ".fai" allowing
+for fast random access to any subsequence in the indexed FASTA file, while
+loading a minimal amount of the file in to memory. This python module implements
+pure Python classes for indexing, retrieval, and in-place modification of FASTA
+files using a samtools compatible index. The pyfaidx module is API compatible
+with the pygr seqdb module. A command-line script "faidx" is installed alongside
+the pyfaidx module, and facilitates complex manipulation of FASTA files without
+any programming knowledge.
+
+WWW: https://github.com/mdshw5/pyfaidx