aboutsummaryrefslogtreecommitdiff
path: root/biology
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2018-10-08 07:54:49 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2018-10-08 07:54:49 +0000
commitf9fa5e635a1bfc7bbcad622544ca9557ee527d58 (patch)
tree284acfa60ea36e30f9f5dc6beffbbba2be36e304 /biology
parenta6735661236cf5b304e186709fd906535a9f617e (diff)
downloadports-f9fa5e635a1bfc7bbcad622544ca9557ee527d58.tar.gz
ports-f9fa5e635a1bfc7bbcad622544ca9557ee527d58.zip
New port: biology/ncbi-cxx-toolkit: NCBI C++ Toolkit
Notes
Notes: svn path=/head/; revision=481520
Diffstat (limited to 'biology')
-rw-r--r--biology/Makefile1
-rw-r--r--biology/ncbi-cxx-toolkit/Makefile31
-rw-r--r--biology/ncbi-cxx-toolkit/distinfo3
-rw-r--r--biology/ncbi-cxx-toolkit/files/patch-src_build-system_Makefile.in.top11
-rw-r--r--biology/ncbi-cxx-toolkit/pkg-descr24
5 files changed, 70 insertions, 0 deletions
diff --git a/biology/Makefile b/biology/Makefile
index 0d1fc6e56bb2..7f2a505609ac 100644
--- a/biology/Makefile
+++ b/biology/Makefile
@@ -65,6 +65,7 @@
SUBDIR += mummer
SUBDIR += muscle
SUBDIR += ncbi-blast+
+ SUBDIR += ncbi-cxx-toolkit
SUBDIR += ncbi-toolkit
SUBDIR += ngs-sdk
SUBDIR += njplot
diff --git a/biology/ncbi-cxx-toolkit/Makefile b/biology/ncbi-cxx-toolkit/Makefile
new file mode 100644
index 000000000000..0e49364492dd
--- /dev/null
+++ b/biology/ncbi-cxx-toolkit/Makefile
@@ -0,0 +1,31 @@
+# $FreeBSD$
+
+PORTNAME= ncbi-cxx-toolkit
+DISTVERSION= 21_0_0
+CATEGORIES= biology science devel
+MASTER_SITES= ftp://ftp.ncbi.nih.gov/toolbox/ncbi_tools++/2018/Apr_2_2018/
+DISTNAME= ncbi_cxx--${DISTVERSION}
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= NCBI C++ Toolkit
+
+LICENSE= PD
+LICENSE_FILE= ${WRKSRC}/doc/public/LICENSE
+
+LIB_DEPENDS= libpcre.so:devel/pcre
+RUN_DEPENDS= bash:shells/bash
+
+USES= compiler:c++11-lang gmake mysql perl5 python shebangfix ssl
+SHEBANG_FILES= src/app/blast/get_species_taxids.sh src/app/blast/legacy_blast.pl src/app/blast/update_blastdb.pl src/app/winmasker/windowmasker_2.2.22_adapter.py
+USE_XORG= x11 xpm
+
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --without-debug --with-dll --without-static
+
+post-install: # autoplist: thousands of files
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/run_with_lock
+ @cd ${STAGEDIR}${PREFIX} && \
+ ${RMDIR} include/ncbi-tools++/algo/blast/bl2api include/ncbi-tools++/objtools/test && \
+ ${FIND} * -type f -or -type l >> ${TMPPLIST}
+
+.include <bsd.port.mk>
diff --git a/biology/ncbi-cxx-toolkit/distinfo b/biology/ncbi-cxx-toolkit/distinfo
new file mode 100644
index 000000000000..d752283ccc1c
--- /dev/null
+++ b/biology/ncbi-cxx-toolkit/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1538937167
+SHA256 (ncbi_cxx--21_0_0.tar.gz) = 48cc3ae24ca63d1ab1be148e7525e8c5b9f4eaa5eb36d172800784b640a84a4f
+SIZE (ncbi_cxx--21_0_0.tar.gz) = 52661343
diff --git a/biology/ncbi-cxx-toolkit/files/patch-src_build-system_Makefile.in.top b/biology/ncbi-cxx-toolkit/files/patch-src_build-system_Makefile.in.top
new file mode 100644
index 000000000000..99719edf9d98
--- /dev/null
+++ b/biology/ncbi-cxx-toolkit/files/patch-src_build-system_Makefile.in.top
@@ -0,0 +1,11 @@
+--- src/build-system/Makefile.in.top.orig 2018-10-08 01:14:08 UTC
++++ src/build-system/Makefile.in.top
+@@ -4,7 +4,7 @@
+ # include @builddir@/Makefile.mk
+ include @build_root@/build/Makefile.mk
+
+-prefix = @prefix@
++prefix = $(DESTDIR)@prefix@
+ exec_prefix = @exec_prefix@
+ PACKAGE_NAME = @PACKAGE_NAME@
+ bindir = @bindir@
diff --git a/biology/ncbi-cxx-toolkit/pkg-descr b/biology/ncbi-cxx-toolkit/pkg-descr
new file mode 100644
index 000000000000..0c1364ee0976
--- /dev/null
+++ b/biology/ncbi-cxx-toolkit/pkg-descr
@@ -0,0 +1,24 @@
+NCBI C++ Toolkit provides free, portable, public domain libraries with no
+restrictions use. It has been written in the National Center for Biotechnology
+Information in Bethesda, MD.
+
+It is vaguely a successor, or a new generation of biology/ncbi-toolkit.
+
+It contains:
+* Networking and Interprocess Communication (IPC) library
+* MultiThreading Library
+* CGI and Fast-CGI Library, HTML Generation Library
+* SQL Database Access Library, C++ wrapper library for BerkeleyDB
+* C++ IOSTREAM Adaptor/Wrapper Library
+* GZIP and BZ2 C++ Wrapper Library with IOSTREAM adaptors
+* ASN.1 and XML Serialization Library with C++ Code Generator Tool (datatool)
+* Date and Time Library
+* File System Function Library
+* Command-Line Argument, Configuration and Environment Processing Library
+* Sequence Alignment Algorithms Library
+* BLAST Engine Library
+* Biological Sequences Retrieval and Processing Library
+* Portable FLTK and OpenGL based GUI and graphic libraries
+* XmlWrapp (XML parsing and handling, XSLT, XPath)
+
+WWW: https://www.ncbi.nlm.nih.gov/IEB/ToolBox/CPP_DOC/