aboutsummaryrefslogtreecommitdiff
path: root/biology
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2013-12-10 17:54:12 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2013-12-10 17:54:12 +0000
commit732ab835ac1463b91e3c99dcbdb17d0c739e0fab (patch)
tree3935729a8970dc4e84df1e5bc7da74e73e91a225 /biology
parent67c403a63a11dacf7f2865a0c6c496b92bcd322f (diff)
downloadports-732ab835ac1463b91e3c99dcbdb17d0c739e0fab.tar.gz
ports-732ab835ac1463b91e3c99dcbdb17d0c739e0fab.zip
Notes
Diffstat (limited to 'biology')
-rw-r--r--biology/mrbayes/Makefile13
1 files changed, 5 insertions, 8 deletions
diff --git a/biology/mrbayes/Makefile b/biology/mrbayes/Makefile
index a4da98f72ec9..ffdc52d736ad 100644
--- a/biology/mrbayes/Makefile
+++ b/biology/mrbayes/Makefile
@@ -10,23 +10,20 @@ MASTER_SITES= SF
MAINTAINER= mzaki@m.u-tokyo.ac.jp
COMMENT= Bayesian inference of phylogeny
-USE_GMAKE= yes
+OPTIONS_DEFINE= EXAMPLES
-LIB_DEPENDS+= readline.6:${PORTSDIR}/devel/readline
+USES= gmake readline:port
PLIST_FILES= bin/mb
PORTEXAMPLES= adh.nex anolis.nex avian_ovomucoids.nex bglobin.nex \
cynmix.nex kim.nex primates.nex replicase.nex
-NO_STAGE= yes
do-install:
- @${INSTALL_PROGRAM} ${WRKSRC}/mb ${PREFIX}/bin/
-.if !defined(NOPORTEXAMPLES)
- @${MKDIR} ${EXAMPLESDIR}
+ @${INSTALL_PROGRAM} ${WRKSRC}/mb ${STAGEDIR}${PREFIX}/bin/
+ @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
.for file in ${PORTEXAMPLES}
- @${INSTALL_DATA} ${WRKSRC}/${file} ${EXAMPLESDIR}
+ @${INSTALL_DATA} ${WRKSRC}/${file} ${STAGEDIR}${EXAMPLESDIR}
.endfor
-.endif
.include <bsd.port.mk>