aboutsummaryrefslogtreecommitdiff
path: root/biology
diff options
context:
space:
mode:
authorWen Heping <wen@FreeBSD.org>2010-11-17 06:24:38 +0000
committerWen Heping <wen@FreeBSD.org>2010-11-17 06:24:38 +0000
commit4cfe377eb9bbca6d631e201fd3a5fa04e9e67b02 (patch)
treeead5480a6f5a1a56760ea68234003b812fdc5a45 /biology
parenta79870013b17ea78b6733985cb1d2aca3844748b (diff)
downloadports-4cfe377eb9bbca6d631e201fd3a5fa04e9e67b02.tar.gz
ports-4cfe377eb9bbca6d631e201fd3a5fa04e9e67b02.zip
Notes
Diffstat (limited to 'biology')
-rw-r--r--biology/p5-Bio-Phylo/Makefile147
-rw-r--r--biology/p5-Bio-Phylo/distinfo4
2 files changed, 76 insertions, 75 deletions
diff --git a/biology/p5-Bio-Phylo/Makefile b/biology/p5-Bio-Phylo/Makefile
index d48822fc4412..d6c0ff48baf8 100644
--- a/biology/p5-Bio-Phylo/Makefile
+++ b/biology/p5-Bio-Phylo/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= Bio-Phylo
-PORTVERSION= 0.28
+PORTVERSION= 0.30
CATEGORIES= biology perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
@@ -14,81 +14,82 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= Phylogenetic analysis using perl
-BUILD_DEPENDS= p5-Exception-Class>1.22:${PORTSDIR}/devel/p5-Exception-Class \
+RUN_DEPENDS= p5-Math-CDF>=0:${PORTSDIR}/math/p5-Math-CDF \
p5-Math-Random>=0.67:${PORTSDIR}/math/p5-Math-Random \
- p5-IO-String>=1.05:${PORTSDIR}/devel/p5-IO-String \
+ p5-SVG>=1.07:${PORTSDIR}/textproc/p5-SVG \
+ p5-SWF-Builder>=0:${PORTSDIR}/graphics/p5-SWF-Builder \
+ p5-XML-Twig>=0:${PORTSDIR}/textproc/p5-XML-Twig \
p5-bioperl>=0:${PORTSDIR}/biology/p5-bioperl \
- p5-SVG>=1.07:${PORTSDIR}/textproc/p5-SVG
-RUN_DEPENDS= ${BUILD_DEPENDS}
-
-MAN3= Bio::Phylo.3 \
- Bio::Phylo::EvolutionaryModels.3 \
- Bio::Phylo::Factory.3 \
- Bio::Phylo::Forest::DrawNode.3 \
- Bio::Phylo::Forest::DrawTree.3 \
- Bio::Phylo::Forest.3 \
- Bio::Phylo::Forest::Node.3 \
- Bio::Phylo::Forest::Tree.3 \
- Bio::Phylo::Generator.3 \
- Bio::Phylo::IO.3 \
- Bio::Phylo::Listable.3 \
- Bio::Phylo::Manual.3 \
- Bio::Phylo::Matrices.3 \
- Bio::Phylo::Matrices::Datum.3 \
- Bio::Phylo::Matrices::Datatype.3 \
- Bio::Phylo::Matrices::Matrix.3 \
- Bio::Phylo::Matrices::TypeSafeData.3 \
- Bio::Phylo::Matrices::Datatype::Custom.3 \
- Bio::Phylo::Matrices::Datatype::Dna.3 \
- Bio::Phylo::Matrices::Datatype::Rna.3 \
- Bio::Phylo::Matrices::Datatype::Restriction.3 \
- Bio::Phylo::Matrices::Datatype::Protein.3 \
- Bio::Phylo::Matrices::Datatype::Continuous.3 \
- Bio::Phylo::Matrices::Datatype::Standard.3 \
- Bio::Phylo::Matrices::Datatype::Mixed.3 \
- Bio::Phylo::Mediators::TaxaMediator.3 \
- Bio::Phylo::NeXML::DOM::Element::Twig.3 \
- Bio::Phylo::NeXML::DOM::Document::Twig.3 \
- Bio::Phylo::NeXML::DOM::Document::Libxml.3 \
- Bio::Phylo::NeXML::DOM.3 \
- Bio::Phylo::NeXML::Meta.3 \
- Bio::Phylo::NeXML::Writable.3 \
- Bio::Phylo::NeXML::DOM::Document.3 \
- Bio::Phylo::NeXML::DOM::Element::Libxml.3 \
- Bio::Phylo::NeXML::DOM::Element.3 \
- Bio::Phylo::NeXML::Meta::XMLLiteral.3 \
- Bio::Phylo::Parsers::Newick.3 \
- Bio::Phylo::Parsers::Nexml.3 \
- Bio::Phylo::Parsers::Nexus.3 \
- Bio::Phylo::Parsers::Table.3 \
- Bio::Phylo::Parsers::Taxlist.3 \
- Bio::Phylo::Parsers::Tolweb.3 \
- Bio::Phylo::Project.3 \
- Bio::Phylo::Set.3 \
- Bio::Phylo::Taxa.3 \
- Bio::Phylo::Taxa::TaxaLinker.3 \
- Bio::Phylo::Taxa::Taxon.3 \
- Bio::Phylo::Taxa::TaxonLinker.3 \
- Bio::Phylo::Treedrawer.3 \
- Bio::Phylo::Treedrawer::Abstract.3 \
- Bio::Phylo::Treedrawer::Canvas.3 \
- Bio::Phylo::Treedrawer::Gif.3 \
- Bio::Phylo::Treedrawer::Jpeg.3 \
- Bio::Phylo::Treedrawer::Pdf.3 \
- Bio::Phylo::Treedrawer::Png.3 \
- Bio::Phylo::Treedrawer::Swf.3 \
- Bio::Phylo::Treedrawer::Svg.3 \
- Bio::Phylo::Unparsers::Mrp.3 \
- Bio::Phylo::Unparsers::Newick.3 \
- Bio::Phylo::Unparsers::Nexml.3 \
- Bio::Phylo::Unparsers::Nexus.3 \
- Bio::Phylo::Unparsers::Pagel.3 \
- Bio::Phylo::Util::CONSTANT.3 \
- Bio::Phylo::Util::Logger.3 \
- Bio::Phylo::Util::IDPool.3 \
- Bio::Phylo::Util::Exceptions.3 \
- Bio::Phylo::Util::StackTrace.3
+ p5-libxml>=0:${PORTSDIR}/textproc/p5-libxml
PERL_CONFIGURE= yes
+MAN3= Bio::Phylo.3 \
+ Bio::Phylo::EvolutionaryModels.3 \
+ Bio::Phylo::Factory.3 \
+ Bio::Phylo::Forest::DrawNode.3 \
+ Bio::Phylo::Forest::DrawTree.3 \
+ Bio::Phylo::Forest.3 \
+ Bio::Phylo::Forest::Node.3 \
+ Bio::Phylo::Forest::Tree.3 \
+ Bio::Phylo::Generator.3 \
+ Bio::Phylo::IO.3 \
+ Bio::Phylo::Listable.3 \
+ Bio::Phylo::Manual.3 \
+ Bio::Phylo::Matrices.3 \
+ Bio::Phylo::Matrices::Datum.3 \
+ Bio::Phylo::Matrices::Datatype.3 \
+ Bio::Phylo::Matrices::Matrix.3 \
+ Bio::Phylo::Matrices::TypeSafeData.3 \
+ Bio::Phylo::Matrices::Datatype::Custom.3 \
+ Bio::Phylo::Matrices::Datatype::Dna.3 \
+ Bio::Phylo::Matrices::Datatype::Rna.3 \
+ Bio::Phylo::Matrices::Datatype::Restriction.3 \
+ Bio::Phylo::Matrices::Datatype::Protein.3 \
+ Bio::Phylo::Matrices::Datatype::Continuous.3 \
+ Bio::Phylo::Matrices::Datatype::Standard.3 \
+ Bio::Phylo::Matrices::Datatype::Mixed.3 \
+ Bio::Phylo::Mediators::TaxaMediator.3 \
+ Bio::Phylo::NeXML::DOM::Element::Twig.3 \
+ Bio::Phylo::NeXML::DOM::Document::Twig.3 \
+ Bio::Phylo::NeXML::DOM::Document::Libxml.3 \
+ Bio::Phylo::NeXML::DOM.3 \
+ Bio::Phylo::NeXML::Meta.3 \
+ Bio::Phylo::NeXML::Writable.3 \
+ Bio::Phylo::NeXML::DOM::Document.3 \
+ Bio::Phylo::NeXML::DOM::Element::Libxml.3 \
+ Bio::Phylo::NeXML::DOM::Element.3 \
+ Bio::Phylo::NeXML::Meta::XMLLiteral.3 \
+ Bio::Phylo::Parsers::Newick.3 \
+ Bio::Phylo::Parsers::Nexml.3 \
+ Bio::Phylo::Parsers::Nexus.3 \
+ Bio::Phylo::Parsers::Table.3 \
+ Bio::Phylo::Parsers::Taxlist.3 \
+ Bio::Phylo::Parsers::Tolweb.3 \
+ Bio::Phylo::Project.3 \
+ Bio::Phylo::Set.3 \
+ Bio::Phylo::Taxa.3 \
+ Bio::Phylo::Taxa::TaxaLinker.3 \
+ Bio::Phylo::Taxa::Taxon.3 \
+ Bio::Phylo::Taxa::TaxonLinker.3 \
+ Bio::Phylo::Treedrawer.3 \
+ Bio::Phylo::Treedrawer::Abstract.3 \
+ Bio::Phylo::Treedrawer::Canvas.3 \
+ Bio::Phylo::Treedrawer::Gif.3 \
+ Bio::Phylo::Treedrawer::Jpeg.3 \
+ Bio::Phylo::Treedrawer::Pdf.3 \
+ Bio::Phylo::Treedrawer::Png.3 \
+ Bio::Phylo::Treedrawer::Swf.3 \
+ Bio::Phylo::Treedrawer::Svg.3 \
+ Bio::Phylo::Unparsers::Mrp.3 \
+ Bio::Phylo::Unparsers::Newick.3 \
+ Bio::Phylo::Unparsers::Nexml.3 \
+ Bio::Phylo::Unparsers::Nexus.3 \
+ Bio::Phylo::Unparsers::Pagel.3 \
+ Bio::Phylo::Util::CONSTANT.3 \
+ Bio::Phylo::Util::Logger.3 \
+ Bio::Phylo::Util::IDPool.3 \
+ Bio::Phylo::Util::Exceptions.3 \
+ Bio::Phylo::Util::StackTrace.3
+
.include <bsd.port.mk>
diff --git a/biology/p5-Bio-Phylo/distinfo b/biology/p5-Bio-Phylo/distinfo
index bb03a2b64ad2..a6999a0d0cdf 100644
--- a/biology/p5-Bio-Phylo/distinfo
+++ b/biology/p5-Bio-Phylo/distinfo
@@ -1,2 +1,2 @@
-SHA256 (Bio-Phylo-0.28.tar.gz) = f72e5a9e43502ea9020faa17c9c20e0a4cd5f34db967888547fbce0dc742b835
-SIZE (Bio-Phylo-0.28.tar.gz) = 241143
+SHA256 (Bio-Phylo-0.30.tar.gz) = 9600ecdedc5147fb1e15265c6a7e3b3648ec9d953c234864e779ed83edfcf087
+SIZE (Bio-Phylo-0.30.tar.gz) = 241313