aboutsummaryrefslogtreecommitdiff
path: root/biology
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2016-06-21 09:05:06 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2016-06-21 09:05:06 +0000
commit642d72c8d8e078989a033c08b233fd9511d72f63 (patch)
treed02b42b448e2cdb7e57d5e0c8e557a401a3afade /biology
parent4b88390e7c6db1570122d167574bbfcadea64bc5 (diff)
downloadports-642d72c8d8e078989a033c08b233fd9511d72f63.tar.gz
ports-642d72c8d8e078989a033c08b233fd9511d72f63.zip
Notes
Diffstat (limited to 'biology')
-rw-r--r--biology/wise/Makefile16
-rw-r--r--biology/wise/files/patch-src_models_phasemodel.c2
2 files changed, 11 insertions, 7 deletions
diff --git a/biology/wise/Makefile b/biology/wise/Makefile
index f6385382960b..8c499fa90ead 100644
--- a/biology/wise/Makefile
+++ b/biology/wise/Makefile
@@ -10,8 +10,6 @@ DISTNAME= ${PORTNAME}${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= Intelligent algorithms for DNA searches
-OPTIONS_DEFINE= DOCS EXAMPLES
-
BUILD_WRKSRC= ${WRKSRC}/src
USES= pkgconfig
@@ -20,10 +18,6 @@ MAKEFILE= makefile
SUB_FILES= pkg-message
-PORTDOCS= *
-PORTEXAMPLES= *
-PLIST_FILES= ${BINFILES:S,^,bin/,} ${DATAFILES:S,^,%%DATADIR%%/,}
-
#
# Actually want an 'ALL_TARGET = all perl' which then requires
# 'USE_PERL5= yes' but the perl sub-build is currently broken.
@@ -42,6 +36,12 @@ DATAFILES= BLOSUM30.bla BLOSUM45.bla BLOSUM62.bla BLOSUM80.bla aa.rnd \
human.stats idenity.bla methods pb.gf pombe.gf tm.pri \
wise.2 wise.per worm.gf
+PORTDOCS= *
+PORTEXAMPLES= *
+PLIST_FILES= ${BINFILES:S,^,bin/,} ${DATAFILES:S,^,%%DATADIR%%/,}
+
+OPTIONS_DEFINE= DOCS EXAMPLES
+
post-patch:
@${FIND} ${BUILD_WRKSRC} -name "makefile" | ${XARGS} \
${REINPLACE_CMD} -e \
@@ -60,8 +60,12 @@ do-install:
@${MKDIR} ${STAGEDIR}${DATADIR}
(cd ${WRKSRC}/wisecfg && ${INSTALL_DATA} ${DATAFILES} \
${STAGEDIR}${DATADIR})
+
+do-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
(cd ${WRKSRC}/docs && ${COPYTREE_SHARE} . ${STAGEDIR}${DOCSDIR})
+
+do-install-EXAMPLES-on:
@${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
(cd ${WRKSRC}/test_data && ${COPYTREE_SHARE} . ${STAGEDIR}${EXAMPLESDIR})
diff --git a/biology/wise/files/patch-src_models_phasemodel.c b/biology/wise/files/patch-src_models_phasemodel.c
index fa7516acc7e9..e76d8cdac567 100644
--- a/biology/wise/files/patch-src_models_phasemodel.c
+++ b/biology/wise/files/patch-src_models_phasemodel.c
@@ -1,4 +1,4 @@
---- src/models/phasemodel.c.orig 2007-09-08 08:05:32.000000000 +0000
+--- src/models/phasemodel.c.orig 2007-09-08 08:05:32 UTC
+++ src/models/phasemodel.c
@@ -3,6 +3,10 @@ extern "C" {
#endif