aboutsummaryrefslogtreecommitdiff
path: root/biology
diff options
context:
space:
mode:
authorMatthew Seaman <matthew@FreeBSD.org>2016-06-09 01:39:58 +0000
committerMatthew Seaman <matthew@FreeBSD.org>2016-06-09 01:39:58 +0000
commit7a2d475f5ad9e27144a4df8c88ea71cc71456b14 (patch)
tree0dfa1580a97dd33fb35a6bb45f6a38b6c542b36d /biology
parent2be1d46a5f11301f3437eb4680d10c601f7999ba (diff)
downloadports-7a2d475f5ad9e27144a4df8c88ea71cc71456b14.tar.gz
ports-7a2d475f5ad9e27144a4df8c88ea71cc71456b14.zip
Notes
Diffstat (limited to 'biology')
-rw-r--r--biology/diamond/Makefile11
-rw-r--r--biology/diamond/distinfo5
-rw-r--r--biology/diamond/files/patch-CMakeLists.txt36
3 files changed, 18 insertions, 34 deletions
diff --git a/biology/diamond/Makefile b/biology/diamond/Makefile
index 64e0f3b59ffa..8125f301f7cc 100644
--- a/biology/diamond/Makefile
+++ b/biology/diamond/Makefile
@@ -2,9 +2,8 @@
# $FreeBSD$
PORTNAME= diamond
-PORTVERSION= 0.7.12
+PORTVERSION= 0.8.5
DISTVERSIONPREFIX= v
-PORTREVISION= 1
CATEGORIES= biology
MAINTAINER= jrm@ftfl.ca
@@ -12,11 +11,9 @@ COMMENT= BLAST-compatible local sequence aligner
LICENSE= BSD2CLAUSE
-LIB_DEPENDS= libboost_system.so:devel/boost-libs
-
ONLY_FOR_ARCHS= amd64
-USES= cmake:outsource
+USES= cmake:outsource compiler:c++11-lang
CFLAGS+= -DNDEBUG
@@ -25,4 +22,8 @@ GH_ACCOUNT= bbuchfink
PLIST_FILES= bin/diamond
+.if ! defined(PACKAGE_BUILDING)
+CXXFLAGS+=-march=native
+.endif
+
.include <bsd.port.mk>
diff --git a/biology/diamond/distinfo b/biology/diamond/distinfo
index 9fc724f22800..8579488cc0c0 100644
--- a/biology/diamond/distinfo
+++ b/biology/diamond/distinfo
@@ -1,2 +1,3 @@
-SHA256 (bbuchfink-diamond-v0.7.12_GH0.tar.gz) = 16f8f618e4e5e81071ef8b66dc39685a1e969434ddeff3d88fa01091971b662f
-SIZE (bbuchfink-diamond-v0.7.12_GH0.tar.gz) = 1826614
+TIMESTAMP = 1464949238
+SHA256 (bbuchfink-diamond-v0.8.5_GH0.tar.gz) = 8ba092647af7c980ddd83acc6686acd2ba18744774c669027859dbaec644fda3
+SIZE (bbuchfink-diamond-v0.8.5_GH0.tar.gz) = 203133
diff --git a/biology/diamond/files/patch-CMakeLists.txt b/biology/diamond/files/patch-CMakeLists.txt
index 167cf967e353..7ac5dbedcd72 100644
--- a/biology/diamond/files/patch-CMakeLists.txt
+++ b/biology/diamond/files/patch-CMakeLists.txt
@@ -1,33 +1,15 @@
---- CMakeLists.txt.orig 2016-03-29 09:23:52 UTC
+--- CMakeLists.txt.orig 2016-05-29 16:12:02 UTC
+++ CMakeLists.txt
-@@ -9,6 +9,7 @@ if(BUILD_STATIC)
+@@ -9,12 +9,6 @@ if(BUILD_STATIC)
set(CMAKE_EXE_LINKER_FLAGS "-static")
endif()
-+FIND_PACKAGE(Threads REQUIRED)
- find_package(Boost
- 1.53.0 REQUIRED
- COMPONENTS program_options timer iostreams thread
-@@ -16,9 +17,6 @@ find_package(Boost
-
- find_package(ZLIB REQUIRED)
-
--set(CMAKE_BUILD_TYPE Release)
--set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Wall -Wno-uninitialized")
+-include(CheckCXXCompilerFlag)
+-CHECK_CXX_COMPILER_FLAG("-march=native" COMPILER_SUPPORTS_MARCHNATIVE)
+-if(COMPILER_SUPPORTS_MARCHNATIVE)
+- set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -march=native")
+-endif()
-
- add_subdirectory("src/algo/blast/core")
- include_directories(
- "${CMAKE_SOURCE_DIR}/src"
-@@ -29,6 +27,11 @@ add_executable(diamond src/main.cpp
- src/basic/options.cpp
- src/util/tinythread.cpp)
-
--target_link_libraries(diamond blast_core ${Boost_LIBRARIES} ${ZLIB_LIBRARY})
-+target_link_libraries(diamond blast_core ${Boost_LIBRARIES} ${CMAKE_THREAD_LIBS_INIT} ${ZLIB_LIBRARY})
+ find_package(ZLIB REQUIRED)
+ find_package(Threads REQUIRED)
- install(TARGETS diamond DESTINATION bin)
-+
-+get_cmake_property(_variableNames VARIABLES)
-+foreach (_variableName ${_variableNames})
-+ message(STATUS "${_variableName}=${${_variableName}}")
-+endforeach()