aboutsummaryrefslogtreecommitdiff
path: root/biology
diff options
context:
space:
mode:
authorTim Bishop <tdb@FreeBSD.org>2005-12-06 15:13:17 +0000
committerTim Bishop <tdb@FreeBSD.org>2005-12-06 15:13:17 +0000
commitef117d6358b818557652a5cc0172b81602f8c942 (patch)
treeafefd78d9d5a9c3e7e2f9df8806c6125faa781c6 /biology
parentf5b55cca3b1e9429eb3c3976228a59f6cbc11789 (diff)
downloadports-ef117d6358b818557652a5cc0172b81602f8c942.tar.gz
ports-ef117d6358b818557652a5cc0172b81602f8c942.zip
Notes
Diffstat (limited to 'biology')
-rw-r--r--biology/seaview/Makefile7
-rw-r--r--biology/seaview/distinfo5
-rw-r--r--biology/seaview/files/patch-Makefile25
3 files changed, 31 insertions, 6 deletions
diff --git a/biology/seaview/Makefile b/biology/seaview/Makefile
index a31f9e6773b5..d04448fda4df 100644
--- a/biology/seaview/Makefile
+++ b/biology/seaview/Makefile
@@ -7,7 +7,7 @@
#
PORTNAME= seaview
-PORTVERSION= 2004.12.16
+PORTVERSION= 2005.13.07
CATEGORIES= biology
MASTER_SITES= ftp://pbil.univ-lyon1.fr/pub/mol_phylogeny/seaview/
DISTNAME= ${PORTNAME}
@@ -17,9 +17,8 @@ DIST_SUBDIR= ${PORTNAME}-${PORTVERSION}
MAINTAINER= fernan@iib.unsam.edu.ar
COMMENT= Multiple DNA/protein sequence alignment editor
-LIB_DEPENDS= fltk.1:${PORTSDIR}/x11-toolkits/fltk
-
-BROKEN= Size mismatch
+LIB_DEPENDS= fltk.1:${PORTSDIR}/x11-toolkits/fltk \
+ pdf.7:${PORTSDIR}/print/pdflib
USE_X_PREFIX= yes
NO_WRKSUBDIR= yes
diff --git a/biology/seaview/distinfo b/biology/seaview/distinfo
index 225255604d4b..7b53eba62c52 100644
--- a/biology/seaview/distinfo
+++ b/biology/seaview/distinfo
@@ -1,2 +1,3 @@
-MD5 (seaview-2004.12.16/seaview.tar) = 2786e787fb45f4d7f065aeed3c4a7903
-SIZE (seaview-2004.12.16/seaview.tar) = 561152
+MD5 (seaview-2005.13.07/seaview.tar) = 0971b3485351f6a1f56a7b56ead2359c
+SHA256 (seaview-2005.13.07/seaview.tar) = 7f48c494e5bee5dacef28bab2a52eab8aff6b66ceff8fab47fe77a18de376fc5
+SIZE (seaview-2005.13.07/seaview.tar) = 595968
diff --git a/biology/seaview/files/patch-Makefile b/biology/seaview/files/patch-Makefile
new file mode 100644
index 000000000000..192839897672
--- /dev/null
+++ b/biology/seaview/files/patch-Makefile
@@ -0,0 +1,25 @@
+--- Makefile.orig Wed Apr 6 05:54:30 2005
++++ Makefile Mon Dec 5 08:31:05 2005
+@@ -1,18 +1,15 @@
+-FLTK = ../fltk
+-PDF = ../PDFlib-Lite-6.0.1/libs/pdflib
+-X11 = /usr/X11R6
+ CXX = g++
+
+-CFLAGS = -Dunix -U__APPLE__ -c $(OPT) -I$(FLTK) -I$(PDF) -I$(X11)/include
++CFLAGS = -Dunix -c $(OPT) -I$(X11BASE)/include -I$(LOCALBASE)/include
+
+
+ OBJECTS = seaview.o pdf.o custom.o use_mase_files.o regions.o load_seq.o align.o xfmatpt.o comlines.o chooser_plus.o resource.o nexus.o old_file_chooser.o
+
+
+ seaview : $(OBJECTS)
+- $(CXX) -o $@ $(OBJECTS) -L$(FLTK)/lib -lfltk \
+- -Xlinker -Bstatic -L$(PDF)/.libs -lpdf -Xlinker -Bdynamic \
+- -L$(X11)/lib -lX11 -lm
++ $(CXX) -o $@ $(OBJECTS) -L$(LOCALBASE)/lib -lfltk \
++ -Xlinker -Bstatic -lpdf -Xlinker -Bdynamic \
++ -L$(X11BASE)/lib -lX11 -lm
+ strip $@
+
+