aboutsummaryrefslogtreecommitdiff
path: root/biology
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2019-06-24 19:30:15 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2019-06-24 19:30:15 +0000
commit428a2eddb19b482b505bc0b3065574ada707be78 (patch)
tree0d21b2d5d4526e39c48bb42863078145483f6551 /biology
parent6d1ea547008a7dd92f7b2941da38aada72623c98 (diff)
downloadports-428a2eddb19b482b505bc0b3065574ada707be78.tar.gz
ports-428a2eddb19b482b505bc0b3065574ada707be78.zip
biology/viennarna: Make it less/not prone to failures due to hardcoded C++ library name
configure and Makefile.in provided in tarballs have -lstdc++ hard-coded in them. The previous version of the port patches these to be -lc++, which still might fail on gcc systems, depending on which C++ library is used. This change adds USES=autoreconf which makes it to regenerate configure and Makefile.in and hopefully have the proper C++ library in these files. GNU libtool links with the C compiler, not with the C++ compiler, in this project. This is what I think triggers link failures due to a wrong C++ library getting into the link lines. GNU libtool likely chooses C compiler because this project has its 'main' functions in .c files, but also includes C++ object modules. This likely causes GNU tools confusion and it uses the C compiler to link and fails due to wrong C++ libraries added there.
Notes
Notes: svn path=/head/; revision=505049
Diffstat (limited to 'biology')
-rw-r--r--biology/viennarna/Makefile2
-rw-r--r--biology/viennarna/files/patch-RNA-Tutorial_Makefile.am11
-rw-r--r--biology/viennarna/files/patch-RNA-Tutorial_Makefile.in11
-rw-r--r--biology/viennarna/files/patch-configure11
-rw-r--r--biology/viennarna/files/patch-examples_Makefile.am (renamed from biology/viennarna/files/patch-examples_Makefile.in)9
5 files changed, 15 insertions, 29 deletions
diff --git a/biology/viennarna/Makefile b/biology/viennarna/Makefile
index 0b7521b7a9b9..6a9ac252d81b 100644
--- a/biology/viennarna/Makefile
+++ b/biology/viennarna/Makefile
@@ -20,7 +20,7 @@ LIB_DEPENDS= libgmp.so:math/gmp \
libgsl.so:math/gsl \
libmpfr.so:math/mpfr
-USES= compiler:c++11-lang gmake libtool localbase perl5
+USES= autoreconf compiler:c++11-lang gmake libtool localbase perl5 pkgconfig # w/out autoreconf -lstdc++ is present in configure and Makefiles and this causes link failure
USE_XORG= x11 xext # only for build
GNU_CONFIGURE= yes
diff --git a/biology/viennarna/files/patch-RNA-Tutorial_Makefile.am b/biology/viennarna/files/patch-RNA-Tutorial_Makefile.am
new file mode 100644
index 000000000000..170cccfc6eb7
--- /dev/null
+++ b/biology/viennarna/files/patch-RNA-Tutorial_Makefile.am
@@ -0,0 +1,11 @@
+--- RNA-Tutorial/Makefile.am.orig 2019-06-24 18:48:09 UTC
++++ RNA-Tutorial/Makefile.am
+@@ -95,7 +95,7 @@ vrna_htmltutorial_uninst:
+
+ if WITH_TUTORIAL_PDF
+
+-tut_datadir = $(pkgdatadir)/tutorial
++tut_datadir = $(prefix)/share/doc/ViennaRNA/tutorial
+ tut_programsdir = $(tut_datadir)/programs
+ tut_alifoldzdir = $(tut_datadir)/alifoldz
+ tut_qrnadir = $(tut_datadir)/qrna
diff --git a/biology/viennarna/files/patch-RNA-Tutorial_Makefile.in b/biology/viennarna/files/patch-RNA-Tutorial_Makefile.in
deleted file mode 100644
index 98d93d82be86..000000000000
--- a/biology/viennarna/files/patch-RNA-Tutorial_Makefile.in
+++ /dev/null
@@ -1,11 +0,0 @@
---- RNA-Tutorial/Makefile.in.orig 2019-06-24 07:18:45 UTC
-+++ RNA-Tutorial/Makefile.in
-@@ -459,7 +459,7 @@ clean_tutorial_html = rm -f *.html *.css *.4ct *.4tc *
- @WITH_TUTORIAL_BUILD_TRUE@@WITH_TUTORIAL_PDFLATEX_FALSE@@WITH_TUTORIAL_PDF_TRUE@@WITH_TUTORIAL_TRUE@CONVERT_TUT_TO_PDF = $(TUTORIAL_CMD_DVIPDF) tutorial.dvi;
- html_DATA = $(TUTORIAL_FILES_HTML)
- pdf_DATA = $(TUTORIAL_FILES_PDF)
--@WITH_TUTORIAL_PDF_TRUE@tut_datadir = $(pkgdatadir)/tutorial
-+@WITH_TUTORIAL_PDF_TRUE@tut_datadir = $(prefix)/share/doc/ViennaRNA/tutorial
- @WITH_TUTORIAL_PDF_TRUE@tut_programsdir = $(tut_datadir)/programs
- @WITH_TUTORIAL_PDF_TRUE@tut_alifoldzdir = $(tut_datadir)/alifoldz
- @WITH_TUTORIAL_PDF_TRUE@tut_qrnadir = $(tut_datadir)/qrna
diff --git a/biology/viennarna/files/patch-configure b/biology/viennarna/files/patch-configure
deleted file mode 100644
index bbcd28ef6c87..000000000000
--- a/biology/viennarna/files/patch-configure
+++ /dev/null
@@ -1,11 +0,0 @@
---- configure.orig 2019-05-31 13:31:21 UTC
-+++ configure
-@@ -22325,7 +22325,7 @@ fi
- if test "x$enable_static_executables" = "xyes"; then
-
- SAVED_LDFLAGS=$LDFLAGS
-- LDFLAGS="$LDFLAGS -static -lstdc++"
-+ LDFLAGS="$LDFLAGS -static -lc++"
-
- { $as_echo "$as_me:${as_lineno-$LINENO}: Checking possiblity to build statically linked executables using C++ compiler" >&5
- $as_echo "$as_me: Checking possiblity to build statically linked executables using C++ compiler" >&6;}
diff --git a/biology/viennarna/files/patch-examples_Makefile.in b/biology/viennarna/files/patch-examples_Makefile.am
index 7b408df151cd..b74a80c994ca 100644
--- a/biology/viennarna/files/patch-examples_Makefile.in
+++ b/biology/viennarna/files/patch-examples_Makefile.am
@@ -1,9 +1,6 @@
---- examples/Makefile.in.orig 2019-06-24 07:09:07 UTC
-+++ examples/Makefile.in
-@@ -441,7 +441,7 @@ target_alias = @target_alias@
- top_build_prefix = @top_build_prefix@
- top_builddir = @top_builddir@
- top_srcdir = @top_srcdir@
+--- examples/Makefile.am.orig 2019-06-24 18:49:57 UTC
++++ examples/Makefile.am
+@@ -1,4 +1,4 @@
-pkgexampledir = $(pkgdatadir)/examples
+pkgexampledir = $(prefix)/share/examples/ViennaRNA
pkgexampledatadir = $(pkgexampledir)/data