aboutsummaryrefslogtreecommitdiff
path: root/biology
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2018-09-21 08:04:50 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2018-09-21 08:04:50 +0000
commit738670ed85a13eb7178af7f8024c13c839ef0ff4 (patch)
treebb9f386d1b26851520797969bec53649e048705b /biology
parentec7eec723710bb183227b721f6e58ccc8e54deea (diff)
downloadports-738670ed85a13eb7178af7f8024c13c839ef0ff4.tar.gz
ports-738670ed85a13eb7178af7f8024c13c839ef0ff4.zip
Notes
Diffstat (limited to 'biology')
-rw-r--r--biology/Makefile1
-rw-r--r--biology/py-loompy/Makefile24
-rw-r--r--biology/py-loompy/distinfo3
-rw-r--r--biology/py-loompy/pkg-descr16
4 files changed, 44 insertions, 0 deletions
diff --git a/biology/Makefile b/biology/Makefile
index c4803253114f..b9f804fdcab7 100644
--- a/biology/Makefile
+++ b/biology/Makefile
@@ -103,6 +103,7 @@
SUBDIR += py-biopython
SUBDIR += py-bx-python
SUBDIR += py-cutadapt
+ SUBDIR += py-loompy
SUBDIR += py-macs2
SUBDIR += py-orange3-bioinformatics
SUBDIR += py-orange3-single-cell
diff --git a/biology/py-loompy/Makefile b/biology/py-loompy/Makefile
new file mode 100644
index 000000000000..5878058309bc
--- /dev/null
+++ b/biology/py-loompy/Makefile
@@ -0,0 +1,24 @@
+# $FreeBSD$
+
+PORTNAME= loompy
+DISTVERSION= 2.0.14
+CATEGORIES= biology python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Work with .loom files for single-cell RNA-seq data
+
+LICENSE= BSD2CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= ${PYNUMPY} \
+ ${PYTHON_PKGNAMEPREFIX}h5py>0:science/py-h5py@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pandas>0:math/py-pandas@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}scipy>0:science/py-scipy@${PY_FLAVOR}
+
+USES= python:3.6+
+USE_PYTHON= distutils autoplist
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/biology/py-loompy/distinfo b/biology/py-loompy/distinfo
new file mode 100644
index 000000000000..2fcdb351106c
--- /dev/null
+++ b/biology/py-loompy/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1537516516
+SHA256 (loompy-2.0.14.tar.gz) = 9ffc5e717d7932d72f80a301bef3a9a8d62b84ecf379c4b1ffd750f6b1388e88
+SIZE (loompy-2.0.14.tar.gz) = 30942
diff --git a/biology/py-loompy/pkg-descr b/biology/py-loompy/pkg-descr
new file mode 100644
index 000000000000..65d3e8d7f75d
--- /dev/null
+++ b/biology/py-loompy/pkg-descr
@@ -0,0 +1,16 @@
+Loom is an efficient file format for large omics datasets. Loom files contain
+a main matrix, optional additional layers, a variable number of row and column
+annotations, and sparse graph objects. Under the hood, Loom files are HDF5 and
+can be opened from many programming languages, including Python, R, C, C++,
+Java, MATLAB, Mathematica, and Julia.
+
+Key features:
+* Single file that can be moved around
+* Metadata travels with the main data
+* Data, clustering, layout, annotation stored together
+* Efficient random access
+* Automatic, on-the-fly compression
+* Out-of-memory data processing
+* Open source, BSD license
+
+WWW: https://loompy.org/