aboutsummaryrefslogtreecommitdiff
path: root/biology
diff options
context:
space:
mode:
authorPawel Pekala <pawel@FreeBSD.org>2014-03-24 10:46:35 +0000
committerPawel Pekala <pawel@FreeBSD.org>2014-03-24 10:46:35 +0000
commit030b55b39778511d36d5f24d7aa42c89119f9e65 (patch)
tree1e4f22d3913f45376b2087103d7610b69a61999a /biology
parent0ca8d2f855782e65a517758d81619a3e05b71d3d (diff)
- Add staging support
- Unmute install commands
Notes
Notes: svn path=/head/; revision=348933
Diffstat (limited to 'biology')
-rw-r--r--biology/wise/Makefile28
1 files changed, 9 insertions, 19 deletions
diff --git a/biology/wise/Makefile b/biology/wise/Makefile
index a6af80d84a0c..387a15bf7293 100644
--- a/biology/wise/Makefile
+++ b/biology/wise/Makefile
@@ -43,9 +43,6 @@ DATAFILES= BLOSUM30.bla BLOSUM45.bla BLOSUM62.bla BLOSUM80.bla aa.rnd \
human.stats idenity.bla methods pb.gf pombe.gf tm.pri \
wise.2 wise.per worm.gf
-NO_STAGE= yes
-.include <bsd.port.options.mk>
-
post-patch:
@${FIND} ${BUILD_WRKSRC} -name "makefile" | ${XARGS} \
${REINPLACE_CMD} -e \
@@ -59,21 +56,14 @@ post-patch:
/welcome.csh/s|^|#|'
do-install:
-.for i in ${BINFILES}
- (cd ${BUILD_WRKSRC}/bin && ${INSTALL_PROGRAM} ${i} ${PREFIX}/bin)
-.endfor
- @${MKDIR} ${DATADIR}
-.for i in ${DATAFILES}
- (cd ${WRKSRC}/wisecfg && ${INSTALL_DATA} ${i} ${DATADIR})
-.endfor
-.if ${PORT_OPTIONS:MDOCS}
- @${MKDIR} ${DOCSDIR}
- @(cd ${WRKSRC}/docs && ${COPYTREE_SHARE} . ${DOCSDIR})
-.endif
-.if ${PORT_OPTIONS:MEXAMPLES}
- @${MKDIR} ${EXAMPLESDIR}
- @(cd ${WRKSRC}/test_data && ${COPYTREE_SHARE} . ${EXAMPLESDIR})
-.endif
- @${CAT} ${PKGMESSAGE}
+ (cd ${BUILD_WRKSRC}/bin && ${INSTALL_PROGRAM} ${BINFILES} \
+ ${STAGEDIR}${PREFIX}/bin)
+ @${MKDIR} ${STAGEDIR}${DATADIR}
+ (cd ${WRKSRC}/wisecfg && ${INSTALL_DATA} ${DATAFILES} \
+ ${STAGEDIR}${DATADIR})
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ (cd ${WRKSRC}/docs && ${COPYTREE_SHARE} . ${STAGEDIR}${DOCSDIR})
+ @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ (cd ${WRKSRC}/test_data && ${COPYTREE_SHARE} . ${STAGEDIR}${EXAMPLESDIR})
.include <bsd.port.mk>