aboutsummaryrefslogtreecommitdiff
path: root/biology
diff options
context:
space:
mode:
authorJason W. Bacon <jwb@FreeBSD.org>2020-03-01 16:01:12 +0000
committerJason W. Bacon <jwb@FreeBSD.org>2020-03-01 16:01:12 +0000
commitc37fa58a73920b0b01f414a8ea5d7acd0ff6c441 (patch)
tree1692e5851360544a509648c79e7a178ded304884 /biology
parent622922e74c957ab35af7a6e795d3adc16859d448 (diff)
downloadports-c37fa58a73920b0b01f414a8ea5d7acd0ff6c441.tar.gz
ports-c37fa58a73920b0b01f414a8ea5d7acd0ff6c441.zip
biology/bowtie2: Upgrade to 2.4.1
Numerous bugfixes and enhancements Enable experimental support for aarch64 Reported by: portscout
Notes
Notes: svn path=/head/; revision=527560
Diffstat (limited to 'biology')
-rw-r--r--biology/bowtie2/Makefile5
-rw-r--r--biology/bowtie2/distinfo6
-rw-r--r--biology/bowtie2/files/patch-Makefile72
3 files changed, 30 insertions, 53 deletions
diff --git a/biology/bowtie2/Makefile b/biology/bowtie2/Makefile
index 09b922fdcb67..df031164588d 100644
--- a/biology/bowtie2/Makefile
+++ b/biology/bowtie2/Makefile
@@ -2,8 +2,7 @@
PORTNAME= bowtie2
DISTVERSIONPREFIX= v
-DISTVERSION= 2.3.5.1
-PORTREVISION= 2
+DISTVERSION= 2.4.1
CATEGORIES= biology perl5 python
MAINTAINER= jwb@FreeBSD.org
@@ -14,7 +13,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
# Requires a 64-bit processor and depends on hard-coded SSE instructions
# Experimental support for AARCH64 as of 2.3.5
-ONLY_FOR_ARCHS= amd64
+ONLY_FOR_ARCHS= aarch64 amd64
LIB_DEPENDS= libtbb.so:devel/tbb
RUN_DEPENDS= bash:shells/bash
diff --git a/biology/bowtie2/distinfo b/biology/bowtie2/distinfo
index 08c9e69bacfd..da64a3e3c0f3 100644
--- a/biology/bowtie2/distinfo
+++ b/biology/bowtie2/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1555781941
-SHA256 (BenLangmead-bowtie2-v2.3.5.1_GH0.tar.gz) = 86a018af1090900c160a0990cc106569805aa64a3ec8708e1d2127839e4a94b4
-SIZE (BenLangmead-bowtie2-v2.3.5.1_GH0.tar.gz) = 10587039
+TIMESTAMP = 1583075948
+SHA256 (BenLangmead-bowtie2-v2.4.1_GH0.tar.gz) = 9fb25513886bf294217dd9c5ca26d18dd5e02e0ae999935ac7ba5700befc492e
+SIZE (BenLangmead-bowtie2-v2.4.1_GH0.tar.gz) = 10588621
diff --git a/biology/bowtie2/files/patch-Makefile b/biology/bowtie2/files/patch-Makefile
index 8312e59dc84d..85d870c135cc 100644
--- a/biology/bowtie2/files/patch-Makefile
+++ b/biology/bowtie2/files/patch-Makefile
@@ -1,52 +1,30 @@
---- Makefile.orig 2019-04-17 02:40:25 UTC
+--- Makefile.orig 2020-03-01 15:16:08 UTC
+++ Makefile
-@@ -21,8 +21,9 @@
- # Makefile for bowtie, bowtie2-build, bowtie2-inspect
- #
-
--prefix := /usr/local
--bindir := $(prefix)/bin
-+# Use PREFIX (upper case) provided by many package managers
-+PREFIX ?= /usr/local
-+bindir := $(PREFIX)/bin
-
- LDLIBS := -lz
- GCC_PREFIX := $(shell dirname `which gcc`)
-@@ -30,8 +31,9 @@ GCC_SUFFIX :=
- CC ?= $(GCC_PREFIX)/gcc$(GCC_SUFFIX)
- CPP ?= $(GCC_PREFIX)/g++$(GCC_SUFFIX)
- CXX ?= $(CPP)
--CXXFLAGS += -std=c++98
--ifeq (aarch64,$(shell uname -m))
-+# long long is unsupported in c++98
-+# CXXFLAGS += -std=c++98
-+ifeq (aarch64,$(shell uname -p))
- CXXFLAGS += -fopenmp-simd
- CPPFLAGS += -Ithird_party/simde
- endif
-@@ -198,13 +200,13 @@ SEARCH_FRAGMENTS := $(wildcard search_*_phase*.c)
- VERSION := $(shell cat VERSION)
+@@ -200,22 +200,22 @@ endif
BITS := 32
+ SSE_FLAG := -msse2
-ifeq (x86_64,$(shell uname -m))
+ifeq (x86_64,$(shell uname -p))
- BITS := 64
- endif
--ifeq (amd64,$(shell uname -m))
-+ifeq (amd64,$(shell uname -p))
- BITS := 64
- endif
--ifeq (aarch64,$(shell uname -m))
-+ifeq (aarch64,$(shell uname -p))
- BITS := 64
- endif
- # msys will always be 32 bit so look at the cpu arch instead.
-@@ -219,7 +221,7 @@ endif
-
- SSE_FLAG := -msse2
- M64_FLAG := -m64
--ifeq (aarch64,$(shell uname -m))
-+ifeq (aarch64,$(shell uname -p))
- SSE_FLAG =
- M64_FLAG =
- endif
+ BITS := 64
+-else ifeq (amd64,$(shell uname -m))
++else ifeq (amd64,$(shell uname -p))
+ BITS := 64
+-else ifeq (aarch64,$(shell uname -m))
++else ifeq (aarch64,$(shell uname -p))
+ BITS := 64
+ SSE_FLAG :=
+ CXXFLAGS := -fopenmp-simd
+ CPPFLAGS := -Ithird_party/simde
+-else ifeq (s390x,$(shell uname -m))
++else ifeq (s390x,$(shell uname -p))
+ BITS := 64
+ SSE_FLAG :=
+ CXXFLAGS := -fopenmp-simd
+ CPPFLAGS := -Ithird_party/simde
+ SANITIZER_FLAGS :=
+-else ifeq (ppc64le,$(shell uname -m))
++else ifeq (ppc64le,$(shell uname -p))
+ BITS := 64
+ SSE_FLAG :=
+ CXXFLAGS := -fopenmp-simd