aboutsummaryrefslogtreecommitdiff
path: root/biology
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2015-05-30 12:31:59 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2015-05-30 12:31:59 +0000
commit9464d224cace880ee1211d8e40926fc577a796e1 (patch)
treefb976741b769b8e34742b5c56fff6d5dc445fb9c /biology
parent73428e8a991def0c49d2943f02fe0100eae074f8 (diff)
downloadports-9464d224cace880ee1211d8e40926fc577a796e1.tar.gz
ports-9464d224cace880ee1211d8e40926fc577a796e1.zip
Notes
Diffstat (limited to 'biology')
-rw-r--r--biology/p5-bioperl/Makefile12
1 files changed, 9 insertions, 3 deletions
diff --git a/biology/p5-bioperl/Makefile b/biology/p5-bioperl/Makefile
index cd42295c1c57..da1b1d5ed9d2 100644
--- a/biology/p5-bioperl/Makefile
+++ b/biology/p5-bioperl/Makefile
@@ -3,7 +3,7 @@
PORTNAME= bioperl
PORTVERSION= 1.6.924
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= biology perl5
MASTER_SITES= CPAN
MASTER_SITE_SUBDIR= CPAN:CJFIELDS
@@ -59,10 +59,11 @@ BUILD_DEPENDS= p5-Algorithm-Munkres>=0:${PORTSDIR}/math/p5-Algorithm-Munkres \
RUN_DEPENDS:= ${BUILD_DEPENDS}
-USES= perl5
+USES= perl5 shebangfix
USE_PERL5= modbuild
+NO_ARCH= yes
-OPTIONS_DEFINE= DOCS PGTEST SQLITETEST
+OPTIONS_DEFINE= DOCS EXAMPLES PGTEST SQLITETEST
PGTEST_DESC= Test PostGreSQL
SQLITETEST_DESC= Test SQLite
PGTEST_RUN_DEPENDS= p5-DBD-Pg>=3:${PORTSDIR}/databases/p5-DBD-Pg
@@ -70,6 +71,11 @@ PGTEST_BUILD_DEPENDS= p5-DBD-Pg>=3:${PORTSDIR}/databases/p5-DBD-Pg
SQLITETEST_RUN_DEPENDS= p5-DBD-SQLite>=1:${PORTSDIR}/databases/p5-DBD-SQLite
SQLITETEST_BUILD_DEPENDS= p5-DBD-SQLite>=1:${PORTSDIR}/databases/p5-DBD-SQLite
+post-patch:
+ @${FIND} ${WRKSRC}/examples ${WRKSRC}/doc -name "*.pl" -o -name "*.cgi" \
+ -o -name "*.PL" | ${XARGS} ${REINPLACE_CMD} -i '' -Ee \
+ '1s|(/usr)?/bin/perl|${perl_CMD}|'
+
post-install:
@${MKDIR} ${STAGEDIR}${DATADIR}
${CP} -R ${WRKSRC}/scripts ${WRKSRC}/models ${STAGEDIR}${DATADIR}