aboutsummaryrefslogtreecommitdiff
path: root/biology
diff options
context:
space:
mode:
authorSam Lawrance <lawrance@FreeBSD.org>2006-02-10 09:45:28 +0000
committerSam Lawrance <lawrance@FreeBSD.org>2006-02-10 09:45:28 +0000
commit0e94382809626e9e9b7a39e0efc59ce513db3d28 (patch)
tree25154e975390a440fb86cc4ffc0aea6778275805 /biology
parentf4cdc25a8794786e9c4a82e7395d74a86a972242 (diff)
downloadports-0e94382809626e9e9b7a39e0efc59ce513db3d28.tar.gz
ports-0e94382809626e9e9b7a39e0efc59ce513db3d28.zip
Notes
Diffstat (limited to 'biology')
-rw-r--r--biology/t_coffee/Makefile14
-rw-r--r--biology/t_coffee/distinfo6
-rw-r--r--biology/t_coffee/files/patch-Makefile8
3 files changed, 18 insertions, 10 deletions
diff --git a/biology/t_coffee/Makefile b/biology/t_coffee/Makefile
index 4e5c42e7afd1..c3e1cd994411 100644
--- a/biology/t_coffee/Makefile
+++ b/biology/t_coffee/Makefile
@@ -7,7 +7,7 @@
#
PORTNAME= t_coffee
-PORTVERSION= 3.18
+PORTVERSION= 3.27
CATEGORIES= biology
MASTER_SITES= http://igs-server.cnrs-mrs.fr/~cnotred/Packages/
DISTNAME= T-COFFEE_distribution_Version_${PORTVERSION}
@@ -25,25 +25,25 @@ MAKE_ENV= MV=${MV} USER_BIN=${PREFIX}/bin \
MAKEFILE= makefile
do-install:
- @ ${INSTALL_PROGRAM} ${WRKSRC}/bin/t_coffee ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/bin/t_coffee ${PREFIX}/bin
post-install:
.if !defined(NOPORTDOCS)
@ ${MKDIR} ${DOCSDIR}
- @ ${INSTALL_DATA} ${WRKSRC}/doc/* ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/doc/* ${DOCSDIR}
@ ${MKDIR} ${EXAMPLESDIR}
@ cd ${WRKSRC}/example && ${FIND} * \
| ${CPIO} --quiet -pdum -R ${SHAREOWN}:${SHAREGRP} ${EXAMPLESDIR}
@ ${MKDIR} ${DATADIR}
- @ ${INSTALL_DATA} ${WRKSRC}/license.txt ${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/license.txt ${DATADIR}
@ ${MKDIR} ${DATADIR}/html
- @ ${INSTALL_DATA} ${WRKSRC}/html/* ${DATADIR}/html
+ ${INSTALL_DATA} ${WRKSRC}/html/* ${DATADIR}/html
.endif
.include <bsd.port.pre.mk>
-.if ${OSVERSION} >= 600000
-BROKEN= "Does not build on FreeBSD >= 6.x"
+.if ${OSVERSION} > 502126
+USE_GCC=3.3
.endif
.include <bsd.port.post.mk>
diff --git a/biology/t_coffee/distinfo b/biology/t_coffee/distinfo
index 4c8f07bac74e..cde81b662a5c 100644
--- a/biology/t_coffee/distinfo
+++ b/biology/t_coffee/distinfo
@@ -1,3 +1,3 @@
-MD5 (T-COFFEE_distribution_Version_3.18.tar.gz) = e671383b9e6b90ded56c615acd2f51c4
-SHA256 (T-COFFEE_distribution_Version_3.18.tar.gz) = e6769bbfecbcd4a00493564ab8e08aefd0d89c7452e5b30114d0d8aec4d36aee
-SIZE (T-COFFEE_distribution_Version_3.18.tar.gz) = 1540558
+MD5 (T-COFFEE_distribution_Version_3.27.tar.gz) = 747d907f4b87e07d7b1e670a2b263e23
+SHA256 (T-COFFEE_distribution_Version_3.27.tar.gz) = ffb7920919b24a6144492bec71580cda8a3ef4698acf762f76ebadfcae9aa01a
+SIZE (T-COFFEE_distribution_Version_3.27.tar.gz) = 1295287
diff --git a/biology/t_coffee/files/patch-Makefile b/biology/t_coffee/files/patch-Makefile
new file mode 100644
index 000000000000..5cf4496b912f
--- /dev/null
+++ b/biology/t_coffee/files/patch-Makefile
@@ -0,0 +1,8 @@
+--- t_coffee_source/makefile.orig Tue Feb 7 15:11:00 2006
++++ t_coffee_source/makefile Tue Feb 7 15:10:36 2006
+@@ -1,4 +1,4 @@
+-CC=cc
++#CC=cc
+ t_coffee: util_constraints_list.o util_job_handling.o util_dps.o util_domain_constraints_list.o util_analyse_constraints_list.o aln_convertion_util.o util_declare.o hsearch.o random.o util_make_tree.o util.o reformat_struc.o reformat.o aln_compare.o io_func.o pb_util_read_sequence.o pb_util_read_seq_util.o tree_util.o util_graph_maln.o util_dp_clean_maln.o util_dp_ssec_pwaln.o util_dp_sim.o util_dp_mm_nw.o util_dp_gotoh_nw.o util_dp_suboptimal_nw.o util_dp_cdna_fasta_nw.o util_dp_generic_fasta_nw.o util_ dp_fasta_nw.o util_dp_fasta_sw.o util_dp_gotoh_sw.o util_dp_est.o util_domain_dp_drivers.o util_dp_drivers.o util_domain_dp.o CUSTOM_evaluate_for_struc.o evaluate_for_struc.o evaluate_for_domain.o evaluate_dirichlet.o evaluate.o showpair.o fsa_dp.o pavie_dp.o t_coffee.o
+ $(CC) -o t_coffee util_constraints_list.o util_job_handling.o util_dps.o util_domain_constraints_list.o util_analyse_constraints_list.o aln_convertion_util.o util_declare.o hsearch.o random.o util_make_tree.o util.o reformat_struc.o reformat.o aln_compare.o io_func.o pb_util_read_sequence.o pb_util_read_seq_util.o tree_util.o util_graph_maln.o util_dp_clean_maln.o util_dp_ssec_pwaln.o util_dp_sim.o util_dp_mm_nw.o util_dp_gotoh_nw.o util_dp_suboptimal_nw.o util_dp_cdna_fasta_nw.o util_dp_generic_fasta_ nw.o util_dp_fasta_nw.o util_dp_fasta_sw.o util_dp_gotoh_sw.o util_dp_est.o util_domain_dp_drivers.o util_dp_drivers.o util_domain_dp.o CUSTOM_evaluate_for_struc.o evaluate_for_struc.o evaluate_for_domain.o evaluate_dirichlet.o evaluate.o showpair.o fsa_dp.o pavie_dp.o t_coffee.o -lm
+ mv t_coffee ../bin