aboutsummaryrefslogtreecommitdiff
path: root/biology
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2020-09-29 18:23:04 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2020-09-29 18:23:04 +0000
commit4453cd341c90b857a7818ca0a696606186678c68 (patch)
treef5ef823be977324b2ae2fb047bf68a35074cef16 /biology
parentb5ae471a75dcb7f6edfbc9345d2acaa2941d7221 (diff)
downloadports-4453cd341c90b857a7818ca0a696606186678c68.tar.gz
ports-4453cd341c90b857a7818ca0a696606186678c68.zip
Convert REINPLACE_CMD to patch file
Notes
Notes: svn path=/head/; revision=550609
Diffstat (limited to 'biology')
-rw-r--r--biology/libsbml/Makefile2
-rw-r--r--biology/libsbml/files/patch-CMakeLists.txt21
2 files changed, 22 insertions, 1 deletions
diff --git a/biology/libsbml/Makefile b/biology/libsbml/Makefile
index 1ca440f7bb5b..2024b48a431c 100644
--- a/biology/libsbml/Makefile
+++ b/biology/libsbml/Makefile
@@ -33,7 +33,7 @@ RUBY_CMAKE_BOOL= WITH_RUBY
RUBY_USE= ruby=yes
post-patch:
- @${REINPLACE_CMD} -e 's|/usr/local|${LOCALBASE}|g; /$${DOCUMENTATION_FILES}/ s|^|#|' ${WRKSRC}/CMakeLists.txt
+ @${REINPLACE_CMD} -e 's|/usr/local|${LOCALBASE}|g' ${WRKSRC}/CMakeLists.txt
post-install-EXAMPLES-on:
${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
diff --git a/biology/libsbml/files/patch-CMakeLists.txt b/biology/libsbml/files/patch-CMakeLists.txt
new file mode 100644
index 000000000000..5dd387b89bb3
--- /dev/null
+++ b/biology/libsbml/files/patch-CMakeLists.txt
@@ -0,0 +1,21 @@
+--- CMakeLists.txt.orig 2019-04-16 12:18:24 UTC
++++ CMakeLists.txt
+@@ -1277,18 +1277,6 @@ endif()
+ # Install documentation
+ #
+
+-set(DOCUMENTATION_FILES
+- COPYING.txt
+- FUNDING.txt
+- LICENSE.txt
+- NEWS.txt
+- OLD_NEWS.txt
+- README.txt
+- VERSION.txt
+-)
+-
+-install(FILES ${DOCUMENTATION_FILES} DESTINATION ${MISC_PREFIX})
+-
+ ###############################################################################
+ #
+ # Write libsbml.pc