aboutsummaryrefslogtreecommitdiff
path: root/biology
diff options
context:
space:
mode:
authorRong-En Fan <rafan@FreeBSD.org>2008-10-21 15:24:46 +0000
committerRong-En Fan <rafan@FreeBSD.org>2008-10-21 15:24:46 +0000
commit1153c04ff780949d9bcbb77bf38f797ea3e650c7 (patch)
tree2675a8c228154260664f5658932b5cc6e6304f8a /biology
parentf246a0ef5bd867fc39402c5b06ad60b1aef3e0cd (diff)
downloadports-1153c04ff780949d9bcbb77bf38f797ea3e650c7.tar.gz
ports-1153c04ff780949d9bcbb77bf38f797ea3e650c7.zip
Notes
Diffstat (limited to 'biology')
-rw-r--r--biology/p5-bioperl-devel/Makefile10
-rw-r--r--biology/p5-bioperl-devel/files/patch-Build.PL19
-rw-r--r--biology/p5-bioperl-devel/files/patch-ModuleBuildBioperl.pm20
3 files changed, 42 insertions, 7 deletions
diff --git a/biology/p5-bioperl-devel/Makefile b/biology/p5-bioperl-devel/Makefile
index bee2b490e0eb..8a7685235279 100644
--- a/biology/p5-bioperl-devel/Makefile
+++ b/biology/p5-bioperl-devel/Makefile
@@ -33,6 +33,7 @@ BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/${PERL_VER}/Text/Wrap.pm:${PORTSDIR}/lang/
${SITE_PERL}/Spreadsheet/ParseExcel.pm:${PORTSDIR}/textproc/p5-Spreadsheet-ParseExcel \
${SITE_PERL}/SVG.pm:${PORTSDIR}/textproc/p5-SVG \
${SITE_PERL}/SVG/Graph.pm:${PORTSDIR}/graphics/p5-SVG-Graph \
+ ${SITE_PERL}/Test/Harness.pm:${PORTSDIR}/devel/p5-Test-Harness \
${SITE_PERL}/Text/Shellwords.pm:${PORTSDIR}/textproc/p5-Text-Shellwords \
${SITE_PERL}/XML/DOM.pm:${PORTSDIR}/textproc/p5-XML-DOM \
${SITE_PERL}/XML/DOM/XPath.pm:${PORTSDIR}/textproc/p5-XML-DOM-XPath \
@@ -53,18 +54,12 @@ BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/${PERL_VER}/Text/Wrap.pm:${PORTSDIR}/lang/
${SITE_PERL}/${PERL_ARCH}/XML/Parser.pm:${PORTSDIR}/textproc/p5-XML-Parser
RUN_DEPENDS= ${BUILD_DEPENDS}
-BROKEN= missing dependencies
-
CONFLICTS= p5-bioperl-1.[02468]*
LATEST_LINK= p5-bioperl-devel
PERL_MODBUILD= YES
-NOPORTDOCS= yes
-NOPORTEXAMPLES= yes
-NOPORTDATA= yes
-
MAN1= bp_aacomp.pl.1 \
bp_biblio.pl.1 \
bp_biofetch_genbank_proxy.pl.1 \
@@ -106,6 +101,7 @@ MAN1= bp_aacomp.pl.1 \
bp_nrdb.pl.1 \
bp_oligo_count.pl.1 \
bp_pairwise_kaks.pl.1 \
+ bp_parse_hmmsearch.pl.1 \
bp_process_gadfly.pl.1 \
bp_process_sgd.pl.1 \
bp_process_wormbase.pl.1 \
@@ -123,6 +119,7 @@ MAN1= bp_aacomp.pl.1 \
bp_split_seq.pl.1 \
bp_sreformat.pl.1 \
bp_taxid4species.pl.1 \
+ bp_taxonomy2tree.pl.1 \
bp_translate_seq.pl.1 \
bp_tree2pag.pl.1 \
bp_unflatten_seq.pl.1
@@ -1006,4 +1003,3 @@ post-install:
.endif
.include <bsd.port.post.mk>
-
diff --git a/biology/p5-bioperl-devel/files/patch-Build.PL b/biology/p5-bioperl-devel/files/patch-Build.PL
new file mode 100644
index 000000000000..58442ee46006
--- /dev/null
+++ b/biology/p5-bioperl-devel/files/patch-Build.PL
@@ -0,0 +1,19 @@
+--- Build.PL.orig Wed Feb 14 05:37:47 2007
++++ Build.PL Sun Jun 15 02:24:07 2008
+@@ -32,7 +32,6 @@
+ 'Test::More' => 0,
+ 'Module::Build' => 0.2805,
+ 'Test::Harness' => 2.62,
+- 'CPAN' => 1.81
+ },
+ recommends => { # does what you would expect of recommends, except more informative output and generates optional_features in META.yml
+ 'Ace' => '0/access of ACeDB database/Bio::DB::Ace,Bio::DB::GFF::Adaptor::ace',
+@@ -174,7 +173,7 @@
+ }
+
+ sub prompt_for_biodbgff {
+- my $proceed = $build->y_n("Do you want to run the BioDBGFF live database tests? y/n", 'n');
++ my $proceed = undef; # $build->y_n("Do you want to run the BioDBGFF live database tests? y/n", 'n');
+
+ if ($proceed) {
+ my @driver_choices;
diff --git a/biology/p5-bioperl-devel/files/patch-ModuleBuildBioperl.pm b/biology/p5-bioperl-devel/files/patch-ModuleBuildBioperl.pm
new file mode 100644
index 000000000000..5f627035c3f3
--- /dev/null
+++ b/biology/p5-bioperl-devel/files/patch-ModuleBuildBioperl.pm
@@ -0,0 +1,20 @@
+--- ModuleBuildBioperl.pm.orig 2007-02-14 05:37:47.000000000 -0600
++++ ModuleBuildBioperl.pm 2008-10-17 23:16:52.000000000 -0500
+@@ -93,7 +93,7 @@
+ closedir($scripts_dir);
+ my $question = $int_ok ? "Install [a]ll Bioperl scripts, [n]one, or choose groups [i]nteractively?" : "Install [a]ll Bioperl scripts or [n]one?";
+
+- my $prompt = $self->prompt($question, 'a');
++ my $prompt = 'a'; # $self->prompt($question, 'a');
+
+ if ($prompt =~ /^[aA]/) {
+ $self->log_info(" - will install all scripts\n");
+@@ -328,7 +328,7 @@
+
+ $status->{message} .= "\n (wanted for $why, used by $by_what)";
+
+- my $installed = $self->install_optional($modname, $preferred_version, $status->{message});
++ my $installed = 'skip'; # $self->install_optional($modname, $preferred_version, $status->{message});
+ next if $installed eq 'ok';
+ $status->{message} = $installed unless $installed eq 'skip';
+ }