aboutsummaryrefslogtreecommitdiff
path: root/biology
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2017-05-06 06:07:03 +0000
committerMartin Wilke <miwi@FreeBSD.org>2017-05-06 06:07:03 +0000
commit177c8291a7fb82dc4d16333d1f0640000e48b97b (patch)
tree487de24c5733ae59d1b7cd5ca02979be6511732f /biology
parent9ca211c1ffa8212e7c9e781a7aa1070bd977541b (diff)
downloadports-177c8291a7fb82dc4d16333d1f0640000e48b97b.tar.gz
ports-177c8291a7fb82dc4d16333d1f0640000e48b97b.zip
Notes
Diffstat (limited to 'biology')
-rw-r--r--biology/Makefile1
-rw-r--r--biology/py-bx-python/Makefile26
-rw-r--r--biology/py-bx-python/distinfo3
-rw-r--r--biology/py-bx-python/pkg-descr17
4 files changed, 47 insertions, 0 deletions
diff --git a/biology/Makefile b/biology/Makefile
index 85155f710443..6732768052c0 100644
--- a/biology/Makefile
+++ b/biology/Makefile
@@ -83,6 +83,7 @@
SUBDIR += psi88
SUBDIR += py-biom-format
SUBDIR += py-biopython
+ SUBDIR += py-bx-python
SUBDIR += py-pysam
SUBDIR += pycogent
SUBDIR += pyfasta
diff --git a/biology/py-bx-python/Makefile b/biology/py-bx-python/Makefile
new file mode 100644
index 000000000000..89ccb9749a3e
--- /dev/null
+++ b/biology/py-bx-python/Makefile
@@ -0,0 +1,26 @@
+# Created by: Yuri Victorovich <yuri@rawbw.com>
+# $FreeBSD$
+
+PORTNAME= bx-python
+PORTVERSION= 0.7.4
+DISTVERSIONPREFIX= v
+CATEGORIES= biology python
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= yuri@rawbw.com
+COMMENT= Python module for reading, manipulating and writing genomic data sets
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= ${PYNUMPY} \
+ ${PYTHON_PKGNAMEPREFIX}python-lzo>0:archivers/py-python-lzo
+RUN_DEPENDS:= ${BUILD_DEPENDS}
+
+USE_GITHUB= yes
+GH_ACCOUNT= bxlab
+
+USES= compiler python
+USE_PYTHON= autoplist distutils
+
+.include <bsd.port.mk>
diff --git a/biology/py-bx-python/distinfo b/biology/py-bx-python/distinfo
new file mode 100644
index 000000000000..65e3ff91b1fd
--- /dev/null
+++ b/biology/py-bx-python/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1492586227
+SHA256 (bxlab-bx-python-v0.7.4_GH0.tar.gz) = 1066d1e56d062d0661f23c19942eb757bd7ab7cb8bc7d89a72fdc3931c995cb4
+SIZE (bxlab-bx-python-v0.7.4_GH0.tar.gz) = 2277893
diff --git a/biology/py-bx-python/pkg-descr b/biology/py-bx-python/pkg-descr
new file mode 100644
index 000000000000..b5bab083ebcc
--- /dev/null
+++ b/biology/py-bx-python/pkg-descr
@@ -0,0 +1,17 @@
+bx-python is a python library and associated set of scripts to allow for rapid
+implementation of genome scale analyses. The library contains a variety of
+useful modules, but the particular strengths are:
+
+Classes for reading and working with genome-scale multiple local alignments
+(in MAF, AXT, and LAV formats). Generic data structure for indexing on disk
+files that contain blocks of data associated with intervals on various
+sequences (used, for example, to provide random access to individual
+alignments in huge files; optomized for use over network filesystems).
+Data structures for working with intervals on sequences:
+ * "Binned bitsets" which act just like chromosome sized bit arrays,
+ but lazily allocate regions and allow large blocks of all set or
+ all unset bits to be stored compactly
+ * "Intersecter" for performing fast intersection tests that preserve
+ both query and target intervals and associated annotation
+
+WWW: https://github.com/bxlab/bx-python