aboutsummaryrefslogtreecommitdiff
path: root/biology
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2021-09-19 18:13:21 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2021-09-19 18:15:35 +0000
commitdd804e98719a5c2376d15b79e6b745f45ab1de40 (patch)
tree084c5bfd33153677226c3b1f8203de8321ab7358 /biology
parentb20ce0d06160182d00a66f4ff51b6970381f368b (diff)
downloadports-dd804e98719a5c2376d15b79e6b745f45ab1de40.tar.gz
ports-dd804e98719a5c2376d15b79e6b745f45ab1de40.zip
biology/libsedml: New port: C++ SED-ML library
Diffstat (limited to 'biology')
-rw-r--r--biology/Makefile1
-rw-r--r--biology/libsedml/Makefile30
-rw-r--r--biology/libsedml/distinfo3
-rw-r--r--biology/libsedml/pkg-descr4
-rw-r--r--biology/libsedml/pkg-plist111
5 files changed, 149 insertions, 0 deletions
diff --git a/biology/Makefile b/biology/Makefile
index ec370d664a52..f57fe3e300fd 100644
--- a/biology/Makefile
+++ b/biology/Makefile
@@ -78,6 +78,7 @@
SUBDIR += libgtextutils
SUBDIR += libnuml
SUBDIR += libsbml
+ SUBDIR += libsedml
SUBDIR += linux-foldingathome
SUBDIR += mafft
SUBDIR += mapm3
diff --git a/biology/libsedml/Makefile b/biology/libsedml/Makefile
new file mode 100644
index 000000000000..6f13d1379a99
--- /dev/null
+++ b/biology/libsedml/Makefile
@@ -0,0 +1,30 @@
+PORTNAME= libsedml
+DISTVERSIONPREFIX= v
+DISTVERSION= 2.0.26
+CATEGORIES= biology devel
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= C++ SED-ML library
+
+LICENSE= BSD2CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+
+BUILD_DEPENDS= libsbml>0:biology/libsbml \
+ libnuml>0:biology/libnuml # statically linked, even into a shared library, see https://github.com/fbergmann/libSEDML/issues/155
+RUN_DEPENDS= libsbml>0:biology/libsbml \
+ libnuml>0:biology/libnuml # when static lib libnuml.a is fixed these should be run-time dependency
+
+USES= cmake gnome
+USE_GNOME= libxml2
+USE_LDCONFIG= yes
+
+USE_GITHUB= yes
+GH_ACCOUNT= fbergmann
+GH_PROJECT= libSEDML
+
+post-install:
+ @${RM} -r ${STAGEDIR}${DATADIR}
+
+# the project builds static libs with -fPIC, see https://github.com/fbergmann/libSEDML/issues/155
+
+.include <bsd.port.mk>
diff --git a/biology/libsedml/distinfo b/biology/libsedml/distinfo
new file mode 100644
index 000000000000..305ade0a4d35
--- /dev/null
+++ b/biology/libsedml/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1632069547
+SHA256 (fbergmann-libSEDML-v2.0.26_GH0.tar.gz) = 74334f2d2e0f4aae2f58f4013c432220ba12a6a6be4cf9478adbbefab7441b41
+SIZE (fbergmann-libSEDML-v2.0.26_GH0.tar.gz) = 956845
diff --git a/biology/libsedml/pkg-descr b/biology/libsedml/pkg-descr
new file mode 100644
index 000000000000..5a7f83016d46
--- /dev/null
+++ b/biology/libsedml/pkg-descr
@@ -0,0 +1,4 @@
+The libSEDML project makes use of libSBML XML layer as well as code generation
+as starting point to produce a library for reading and writing of SED-ML models.
+
+WWW: https://github.com/fbergmann/libSEDML
diff --git a/biology/libsedml/pkg-plist b/biology/libsedml/pkg-plist
new file mode 100644
index 000000000000..e88aa1bac57f
--- /dev/null
+++ b/biology/libsedml/pkg-plist
@@ -0,0 +1,111 @@
+include/sedml/SedAbstractCurve.h
+include/sedml/SedAbstractTask.h
+include/sedml/SedAddXML.h
+include/sedml/SedAdjustableParameter.h
+include/sedml/SedAlgorithm.h
+include/sedml/SedAlgorithmParameter.h
+include/sedml/SedAnalysis.h
+include/sedml/SedAppliedDimension.h
+include/sedml/SedAxis.h
+include/sedml/SedBase.h
+include/sedml/SedBounds.h
+include/sedml/SedChange.h
+include/sedml/SedChangeAttribute.h
+include/sedml/SedChangeXML.h
+include/sedml/SedComputeChange.h
+include/sedml/SedConstructorException.h
+include/sedml/SedCurve.h
+include/sedml/SedDataDescription.h
+include/sedml/SedDataGenerator.h
+include/sedml/SedDataRange.h
+include/sedml/SedDataSet.h
+include/sedml/SedDataSource.h
+include/sedml/SedDocument.h
+include/sedml/SedElementFilter.h
+include/sedml/SedError.h
+include/sedml/SedErrorLog.h
+include/sedml/SedErrorTable.h
+include/sedml/SedExperimentReference.h
+include/sedml/SedFigure.h
+include/sedml/SedFill.h
+include/sedml/SedFitExperiment.h
+include/sedml/SedFitMapping.h
+include/sedml/SedFunctionalRange.h
+include/sedml/SedLeastSquareObjectiveFunction.h
+include/sedml/SedLine.h
+include/sedml/SedListOf.h
+include/sedml/SedListOfAdjustableParameters.h
+include/sedml/SedListOfAlgorithmParameters.h
+include/sedml/SedListOfAppliedDimensions.h
+include/sedml/SedListOfChanges.h
+include/sedml/SedListOfCurves.h
+include/sedml/SedListOfDataDescriptions.h
+include/sedml/SedListOfDataGenerators.h
+include/sedml/SedListOfDataSets.h
+include/sedml/SedListOfDataSources.h
+include/sedml/SedListOfExperimentReferences.h
+include/sedml/SedListOfFitExperiments.h
+include/sedml/SedListOfFitMappings.h
+include/sedml/SedListOfModels.h
+include/sedml/SedListOfOutputs.h
+include/sedml/SedListOfParameters.h
+include/sedml/SedListOfRanges.h
+include/sedml/SedListOfSetValues.h
+include/sedml/SedListOfSimulations.h
+include/sedml/SedListOfSlices.h
+include/sedml/SedListOfStyles.h
+include/sedml/SedListOfSubPlots.h
+include/sedml/SedListOfSubTasks.h
+include/sedml/SedListOfSurfaces.h
+include/sedml/SedListOfTasks.h
+include/sedml/SedListOfVariables.h
+include/sedml/SedMarker.h
+include/sedml/SedModel.h
+include/sedml/SedNamespaces.h
+include/sedml/SedObjective.h
+include/sedml/SedOneStep.h
+include/sedml/SedOutput.h
+include/sedml/SedParameter.h
+include/sedml/SedParameterEstimationReport.h
+include/sedml/SedParameterEstimationResultPlot.h
+include/sedml/SedParameterEstimationTask.h
+include/sedml/SedPlot.h
+include/sedml/SedPlot2D.h
+include/sedml/SedPlot3D.h
+include/sedml/SedRange.h
+include/sedml/SedReader.h
+include/sedml/SedRemoveXML.h
+include/sedml/SedRepeatedTask.h
+include/sedml/SedReport.h
+include/sedml/SedSetValue.h
+include/sedml/SedShadedArea.h
+include/sedml/SedSimulation.h
+include/sedml/SedSlice.h
+include/sedml/SedSteadyState.h
+include/sedml/SedStyle.h
+include/sedml/SedSubPlot.h
+include/sedml/SedSubTask.h
+include/sedml/SedSurface.h
+include/sedml/SedTask.h
+include/sedml/SedTypeCodes.h
+include/sedml/SedTypes.h
+include/sedml/SedUniformRange.h
+include/sedml/SedUniformTimeCourse.h
+include/sedml/SedVariable.h
+include/sedml/SedVectorRange.h
+include/sedml/SedVisitor.h
+include/sedml/SedWaterfallPlot.h
+include/sedml/SedWriter.h
+include/sedml/common/SedOperationReturnValues.h
+include/sedml/common/SedmlEnumerations.h
+include/sedml/common/common.h
+include/sedml/common/extern.h
+include/sedml/common/libsedml-config-common.h
+include/sedml/common/libsedml-config.h
+include/sedml/common/libsedml-namespace.h
+include/sedml/common/libsedml-version.h
+include/sedml/common/sedmlfwd.h
+lib/libsedml-static.a
+lib/libsedml.so
+lib/libsedml.so.2
+lib/libsedml.so.2.0.26