aboutsummaryrefslogtreecommitdiff
path: root/biology
diff options
context:
space:
mode:
authorJason W. Bacon <jwb@FreeBSD.org>2021-09-06 14:21:44 +0000
committerJason W. Bacon <jwb@FreeBSD.org>2021-09-06 14:21:44 +0000
commitfa2e0b8c66d459b05b1a6624cd482950f9ea3376 (patch)
treea9aa7a7aacf3ee6d8ee32861ccd2d783878ee809 /biology
parent74c66d50fd5f3f12469881d4f9c5634f8722ccc5 (diff)
downloadports-fa2e0b8c66d459b05b1a6624cd482950f9ea3376.tar.gz
ports-fa2e0b8c66d459b05b1a6624cd482950f9ea3376.zip
biology/emboss: Add emboss-shell: Run subshell with proper PATH
Also silence portlint and stage-qa warnings PR: 258316 Approved by: wen
Diffstat (limited to 'biology')
-rw-r--r--biology/emboss/Makefile10
-rw-r--r--biology/emboss/distinfo1
-rwxr-xr-xbiology/emboss/files/emboss-shell.in26
-rw-r--r--biology/emboss/files/patch-Makefile.in16
-rw-r--r--biology/emboss/files/patch-emboss-Makefile.in6
-rw-r--r--biology/emboss/files/patch-emboss_emboss.default.template (renamed from biology/emboss/files/patch-emboss.default.template)4
-rw-r--r--biology/emboss/pkg-plist1
7 files changed, 47 insertions, 17 deletions
diff --git a/biology/emboss/Makefile b/biology/emboss/Makefile
index 3fd93f959e77..aa966ad37b6d 100644
--- a/biology/emboss/Makefile
+++ b/biology/emboss/Makefile
@@ -2,7 +2,7 @@
PORTNAME= emboss
PORTVERSION= 6.6.0
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= biology
MASTER_SITES= ftp://emboss.open-bio.org/pub/EMBOSS/
DISTNAME= ${PORTNAME:tu}-${PORTVERSION}
@@ -18,15 +18,16 @@ BUILD_DEPENDS= clustalw:biology/clustalw \
LIB_DEPENDS= libgd.so:graphics/gd \
libpng.so:graphics/png
+USES= gmake libtool iconv mysql pgsql ssl
+USE_SUBMAKE= yes
+
CONFLICTS= qmail-ldap-[0-9]* digest-[0-9]*
PREFIX?= ${LOCALBASE}/emboss
NO_MTREE= yes
-USES= gmake libtool iconv
-USE_SUBMAKE= yes
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
-SUB_FILES= pkg-message
+SUB_FILES= pkg-message emboss-shell
SUB_LIST= PREFIX=${PREFIX} DATADIR=${DATADIR}
LDFLAGS+= -L${LOCALBASE}/lib
CONFIGURE_ARGS+=${ICONV_CONFIGURE_ARG}
@@ -54,5 +55,6 @@ pre-install:
post-install:
${INSTALL_DATA} ${CONFIG_FILE} ${STAGEDIR}${DATADIR}
+ ${INSTALL_SCRIPT} ${WRKDIR}/emboss-shell ${STAGEDIR}${PREFIX}/bin
.include <bsd.port.mk>
diff --git a/biology/emboss/distinfo b/biology/emboss/distinfo
index ed69bf264b49..d36d2d7c9e0b 100644
--- a/biology/emboss/distinfo
+++ b/biology/emboss/distinfo
@@ -1,2 +1,3 @@
+TIMESTAMP = 1630936830
SHA256 (emboss/EMBOSS-6.6.0.tar.gz) = 7184a763d39ad96bb598bfd531628a34aa53e474db9e7cac4416c2a40ab10c6e
SIZE (emboss/EMBOSS-6.6.0.tar.gz) = 117962028
diff --git a/biology/emboss/files/emboss-shell.in b/biology/emboss/files/emboss-shell.in
new file mode 100755
index 000000000000..525b04bcc397
--- /dev/null
+++ b/biology/emboss/files/emboss-shell.in
@@ -0,0 +1,26 @@
+#!/bin/sh -e
+
+emboss_bin=%%PREFIX%%/bin
+cat << EOM
+
+Prefixing \$PATH with $emboss_bin.
+
+Emboss contains commands that conflict with other tools, including at least
+"charge", "cons", "garnier", "prophet", and "tcode".
+
+The other commands with these names may serve entirely different functions
+and will not be accessible while running this shell unless you refer to them
+by their absolute path name (e.g. %%LOCALBASE%%/bin/garnier), which is not
+portable, BTW, so don't hard-code such paths into your scripts.
+
+Type "exit" or "Ctrl+D" to return to your normal shell.
+
+EOM
+
+export PATH=${emboss_bin}:$PATH
+
+# Invoke the user's chosen shell
+if echo $SHELL | grep -q '/t?csh'; then
+ args='-f'
+fi
+exec $SHELL $args
diff --git a/biology/emboss/files/patch-Makefile.in b/biology/emboss/files/patch-Makefile.in
index b79dd7233e0f..469f8acfc64e 100644
--- a/biology/emboss/files/patch-Makefile.in
+++ b/biology/emboss/files/patch-Makefile.in
@@ -1,6 +1,6 @@
---- Makefile.in.orig 2014-05-29 03:27:28.070199330 +0600
-+++ Makefile.in 2014-05-29 03:28:00.167196553 +0600
-@@ -756,7 +756,7 @@
+--- Makefile.in.orig 2013-07-15 21:27:28 UTC
++++ Makefile.in
+@@ -756,7 +756,7 @@ install-dvi-am:
install-exec-am:
@$(NORMAL_INSTALL)
@@ -9,7 +9,7 @@
install-html: install-html-recursive
install-html-am:
-@@ -810,7 +810,7 @@
+@@ -810,7 +810,7 @@ uninstall-am:
distclean-libtool distclean-tags distcleancheck distdir \
distuninstallcheck dvi dvi-am html html-am info info-am \
install install-am install-data install-data-am install-dvi \
@@ -18,13 +18,13 @@
install-html install-html-am install-info install-info-am \
install-man install-pdf install-pdf-am install-ps \
install-ps-am install-strip installcheck installcheck-am \
-@@ -832,9 +832,6 @@
+@@ -831,9 +831,6 @@ dist-hook:
+ ### tar cBf - plplot/lib | ( cd $(distdir); tar xBf - ; find plplot -name CVS | xargs rm -rf )
tar cBf - doc | ( cd $(distdir); tar xBf - ; find doc -name CVS | xargs rm -rf; )
tar cBf - jemboss | ( cd $(distdir); tar xBf - ; find jemboss -name CVS | xargs rm -rf; find jemboss -name Makefile | xargs rm -rf; find jemboss -name .cvsignore | xargs rm -rf )
-
+-
-install-exec-hook:
- $(bindir)/embossupdate
--
+
# Tell versions [3.59,3.63) of GNU make to not export all variables.
# Otherwise a system limit (for SysV at least) may be exceeded.
- .NOEXPORT:
diff --git a/biology/emboss/files/patch-emboss-Makefile.in b/biology/emboss/files/patch-emboss-Makefile.in
index 8ee767984aa5..f6278c64dded 100644
--- a/biology/emboss/files/patch-emboss-Makefile.in
+++ b/biology/emboss/files/patch-emboss-Makefile.in
@@ -1,6 +1,6 @@
---- emboss/Makefile.in.orig 2014-05-29 14:42:20.540406535 +0600
-+++ emboss/Makefile.in 2014-05-29 14:42:42.364404204 +0600
-@@ -3216,7 +3216,6 @@
+--- emboss/Makefile.in.orig 2013-07-15 21:27:30 UTC
++++ emboss/Makefile.in
+@@ -3216,7 +3216,6 @@ LDADD = ../nucleus/libnucleus.la ../ajax/acd/libacd.la
$(am__append_3) ../ajax/pcre/libepcre.la \
../plplot/libeplplot.la $(XLIB)
dist_pkgdata_DATA = \
diff --git a/biology/emboss/files/patch-emboss.default.template b/biology/emboss/files/patch-emboss_emboss.default.template
index 04ee586b4bfb..0f06201f5f80 100644
--- a/biology/emboss/files/patch-emboss.default.template
+++ b/biology/emboss/files/patch-emboss_emboss.default.template
@@ -1,5 +1,5 @@
---- emboss/emboss.default.template.orig Wed Feb 8 00:43:42 2006
-+++ emboss/emboss.default.template Wed Feb 8 00:40:34 2006
+--- emboss/emboss.default.template.orig 2011-03-11 09:04:31 UTC
++++ emboss/emboss.default.template
@@ -4,7 +4,7 @@
# By default this is /usr/local/share/EMBOSS/test but the directory can
# be changed with --prefix when you configure EMBOSS.
diff --git a/biology/emboss/pkg-plist b/biology/emboss/pkg-plist
index c8161feb85cc..7ab1e1f9b74b 100644
--- a/biology/emboss/pkg-plist
+++ b/biology/emboss/pkg-plist
@@ -77,6 +77,7 @@ bin/edamisid
bin/edamname
bin/edialign
bin/einverted
+bin/emboss-shell
bin/embossdata
bin/embossupdate
bin/embossversion