aboutsummaryrefslogtreecommitdiff
path: root/biology
diff options
context:
space:
mode:
authorJason W. Bacon <jwb@FreeBSD.org>2021-12-01 14:55:49 +0000
committerJason W. Bacon <jwb@FreeBSD.org>2021-12-01 14:56:30 +0000
commitc74d9767d204035f671225a70227a2b24ecb2491 (patch)
treec1fd842637b238cbf3dbffa286c6c83f01c57e80 /biology
parentae9c01a00d6ae5884b1f2911884ceb55bb3dc20c (diff)
downloadports-c74d9767d204035f671225a70227a2b24ecb2491.tar.gz
ports-c74d9767d204035f671225a70227a2b24ecb2491.zip
biology/bwa: Unbreak on most non-x86 platforms using simde
Diffstat (limited to 'biology')
-rw-r--r--biology/bwa/Makefile11
-rw-r--r--biology/bwa/files/patch-ksw.c13
2 files changed, 17 insertions, 7 deletions
diff --git a/biology/bwa/Makefile b/biology/bwa/Makefile
index a6302394411c..5075bda611bc 100644
--- a/biology/bwa/Makefile
+++ b/biology/bwa/Makefile
@@ -1,6 +1,7 @@
PORTNAME= bwa
PORTVERSION= 0.7.17
DISTVERSIONPREFIX=v
+PORTREVISION= 1
CATEGORIES= biology
PATCH_SITES= https://github.com/lh3/bwa/commit/
@@ -11,16 +12,12 @@ COMMENT= Burrows-Wheeler sequence aligner
LICENSE= GPLv3
-# From 0.7.9a: Recheck for 0.7.17.
-BROKEN_aarch64= fails to compile: invalid conversion between vector type and integer type
-BROKEN_armv6= fails to compile: invalid conversion between vector type and integer type
-BROKEN_armv7= fails to compile: invalid conversion between vector type and integer type
BROKEN_mips= fails to compile: cc1: unrecognized command line option "-msse2"
BROKEN_mips64= fails to compile: cc1: unrecognized command line option "-msse2"
-BROKEN_powerpc64= fails to compile: ksw.c: emmintrin.h: No such file or directory
-BROKEN_riscv64= fails to compile: invalid conversion between vector type and integer type
-USES= gmake perl5 shebangfix tar:bzip2
+BUILD_DEPENDS= simde>0:devel/simde
+
+USES= gmake localbase perl5 shebangfix tar:bzip2
SHEBANG_FILES= qualfa2fq.pl xa2multi.pl
USE_PERL5= run
diff --git a/biology/bwa/files/patch-ksw.c b/biology/bwa/files/patch-ksw.c
new file mode 100644
index 000000000000..c86cabf2e497
--- /dev/null
+++ b/biology/bwa/files/patch-ksw.c
@@ -0,0 +1,13 @@
+--- ksw.c.orig 2021-12-01 13:48:35 UTC
++++ ksw.c
+@@ -26,7 +26,9 @@
+ #include <stdlib.h>
+ #include <stdint.h>
+ #include <assert.h>
+-#include <emmintrin.h>
++// #include <emmintrin.h>
++#define SIMDE_ENABLE_NATIVE_ALIASES
++#include <simde/x86/sse2.h>
+ #include "ksw.h"
+
+ #ifdef USE_MALLOC_WRAPPERS