aboutsummaryrefslogtreecommitdiff
path: root/biology
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2009-04-02 18:24:59 +0000
committerMartin Wilke <miwi@FreeBSD.org>2009-04-02 18:24:59 +0000
commit9de088104296724367c2f7dff72615474672d653 (patch)
tree212d47139222a77a4aece674e0bbfcd311f65119 /biology
parent85245ba154ec9ff878cc20390fb1efd5aee2f6e5 (diff)
downloadports-9de088104296724367c2f7dff72615474672d653.tar.gz
ports-9de088104296724367c2f7dff72615474672d653.zip
Notes
Diffstat (limited to 'biology')
-rw-r--r--biology/Makefile1
-rw-r--r--biology/p5-Bio-Glite/Makefile25
-rw-r--r--biology/p5-Bio-Glite/distinfo3
-rw-r--r--biology/p5-Bio-Glite/pkg-descr18
-rw-r--r--biology/p5-Bio-Glite/pkg-plist5
5 files changed, 52 insertions, 0 deletions
diff --git a/biology/Makefile b/biology/Makefile
index 3ef71baedf0e..1a9b5e34ef95 100644
--- a/biology/Makefile
+++ b/biology/Makefile
@@ -57,6 +57,7 @@
SUBDIR += p5-AcePerl
SUBDIR += p5-Bio-ASN1-EntrezGene
SUBDIR += p5-Bio-Das
+ SUBDIR += p5-Bio-Glite
SUBDIR += p5-Bio-Graphics
SUBDIR += p5-Bio-Phylo
SUBDIR += p5-bioperl
diff --git a/biology/p5-Bio-Glite/Makefile b/biology/p5-Bio-Glite/Makefile
new file mode 100644
index 000000000000..61e52557e15e
--- /dev/null
+++ b/biology/p5-Bio-Glite/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: p5-Bio-Glite
+# Date created: 1st April, 2009
+# Whom: Wen Heping <wenheping@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Bio-Glite
+PORTVERSION= 0.10
+CATEGORIES= biology perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= wenheping@gmail.com
+COMMENT= An Perl Interface to G-language
+
+BUILD_DEPENDS= p5-Data-Dumper>=2.121:${PORTSDIR}/devel/p5-Data-Dumper \
+ p5-libwww>=5:${PORTSDIR}/www/p5-libwww
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= YES
+
+MAN3= Bio::Glite.3
+
+.include <bsd.port.mk>
diff --git a/biology/p5-Bio-Glite/distinfo b/biology/p5-Bio-Glite/distinfo
new file mode 100644
index 000000000000..7b2bc868908a
--- /dev/null
+++ b/biology/p5-Bio-Glite/distinfo
@@ -0,0 +1,3 @@
+MD5 (Bio-Glite-0.10.tar.gz) = 54a973b4d7332fb9eca63e8b8a712161
+SHA256 (Bio-Glite-0.10.tar.gz) = f747af67efe6feb6daca599034624510f75c6f73f1509f3eef3836f2030dfc71
+SIZE (Bio-Glite-0.10.tar.gz) = 25801
diff --git a/biology/p5-Bio-Glite/pkg-descr b/biology/p5-Bio-Glite/pkg-descr
new file mode 100644
index 000000000000..89e4faf5bede
--- /dev/null
+++ b/biology/p5-Bio-Glite/pkg-descr
@@ -0,0 +1,18 @@
+Bio::Glite is an interface to G-language Genome Analysis Environment
+through its REST web service (http://www.g-language.org). This module
+allows almost everything G-language GAE can do, without installing
+all necessary tookits and modules.
+
+Advantage of this module over the standard installation of
+G-language GAE package is:
+ 1. Easy installation from CPAN
+ 2. Extremely light-weight (less than 1000 lines of code)
+ 3. Does not require much CPU/RAM (all calculation is done on
+the cloud)
+
+Disadvantages includes:
+ 1. Slower analysis speed
+ 2. Internet connection is required
+ 3. No other software interfaces such as the G-language Shell
+
+WWW: http://search.cpan.org/dist/Bio-Glite/
diff --git a/biology/p5-Bio-Glite/pkg-plist b/biology/p5-Bio-Glite/pkg-plist
new file mode 100644
index 000000000000..7334c1e52566
--- /dev/null
+++ b/biology/p5-Bio-Glite/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Bio/Glite/.packlist
+%%SITE_PERL%%/Bio/Glite.pm
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Bio/Glite
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Bio
+@dirrmtry %%SITE_PERL%%/Bio