aboutsummaryrefslogtreecommitdiff
path: root/biology
diff options
context:
space:
mode:
authorMark Linimon <linimon@FreeBSD.org>2017-05-01 19:24:00 +0000
committerMark Linimon <linimon@FreeBSD.org>2017-05-01 19:24:00 +0000
commit3980169c5f07bd29aca9d4622d79e2992d3adb6a (patch)
treee590a1fe25ef8fd6c3924c68296537c795f3af31 /biology
parent25b71d968896ec6828ca461daccf177519d7cd7f (diff)
downloadports-3980169c5f07bd29aca9d4622d79e2992d3adb6a.tar.gz
ports-3980169c5f07bd29aca9d4622d79e2992d3adb6a.zip
Provide error messages for some ports failing on aarch64, and, in a
few cases, other tier-2 archs. While here, pet portlint. Approved by: portmgr (tier-2 blanket)
Notes
Notes: svn path=/head/; revision=439905
Diffstat (limited to 'biology')
-rw-r--r--biology/crux/Makefile3
-rw-r--r--biology/seqan-apps/Makefile2
2 files changed, 5 insertions, 0 deletions
diff --git a/biology/crux/Makefile b/biology/crux/Makefile
index 50dc846b8459..0e33f688b500 100644
--- a/biology/crux/Makefile
+++ b/biology/crux/Makefile
@@ -13,6 +13,9 @@ COMMENT= Software toolkit for phylogenetic inference
LICENSE= BSD2CLAUSE BSD3CLAUSE
LICENSE_COMB= multi
+BROKEN_aarch64= Fails to link: ImportError: /lib/libgcc_s.so.1: version GCC_4.5.0 required by /usr/local/lib/gcc5/libgfortran.so.3 not found
+BROKEN_armv64= Fails to link: ImportError: /usr/local/lib/gcc49/libgfortran.so.3: Undefined symbol "__aeabi_ldivmod"
+
USES= fortran gmake python tar:bzip2
USE_CSTD= gnu99
GNU_CONFIGURE= yes
diff --git a/biology/seqan-apps/Makefile b/biology/seqan-apps/Makefile
index 0191a80d8a5a..5b20f03f759e 100644
--- a/biology/seqan-apps/Makefile
+++ b/biology/seqan-apps/Makefile
@@ -26,7 +26,9 @@ CMAKE_ARGS= -DSEQAN_BUILD_SYSTEM="SEQAN_RELEASE_APPS"
USE_GCC= yes
+BROKEN_aarch64= fails to compile: Error: unknown mnemonic rep -- rep
BROKEN_armv6= fails to link: undefined reference to _Unwind_GetIP@GCC_3.0
+BROKEN_powerpc64= fails to compile: Error: unrecognized opcode: rep
.include <bsd.port.pre.mk>