aboutsummaryrefslogtreecommitdiff
path: root/biology
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2017-04-21 16:28:25 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2017-04-21 16:28:25 +0000
commit709dd50bc494044d56b6557737eea9a043995e32 (patch)
tree25d149988b30f5a98a05ef1cd4528a26c574f4ba /biology
parente48fca964cd38e10159d6cd4b3f4203265a6a5ef (diff)
downloadports-709dd50bc494044d56b6557737eea9a043995e32.tar.gz
ports-709dd50bc494044d56b6557737eea9a043995e32.zip
- Fix shebangs
- Add NO_ARCH - Switch to relative links
Notes
Notes: svn path=/head/; revision=439093
Diffstat (limited to 'biology')
-rw-r--r--biology/artemis/Makefile10
1 files changed, 7 insertions, 3 deletions
diff --git a/biology/artemis/Makefile b/biology/artemis/Makefile
index 4dcee45a2973..45c24324e979 100644
--- a/biology/artemis/Makefile
+++ b/biology/artemis/Makefile
@@ -3,7 +3,7 @@
PORTNAME= artemis
PORTVERSION= 9
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= biology java
MASTER_SITES= http://www.sanger.ac.uk/Software/Artemis/v${PORTVERSION}/ \
ftp://ftp.sanger.ac.uk/pub/pathogens/software/artemis/v${PORTVERSION}/
@@ -14,8 +14,12 @@ COMMENT= DNA sequence viewer and annotation tool
WRKSRC= ${WRKDIR}/${PORTNAME}
+USES= shebangfix
+SHEBANG_FILES= etc/go_associations.pl
+perl_OLD_CMD= /usr/local/bin/perl5.6.1
USE_JAVA= yes
JAVA_VERSION= 1.6+
+NO_ARCH= yes
NO_BUILD= yes
PLIST_SUB= PORTVERSION="${PORTVERSION}"
@@ -26,7 +30,7 @@ post-extract:
do-install:
@${MKDIR} ${STAGEDIR}${PREFIX}/${PORTNAME}-${PORTVERSION}
@${TAR} -C ${WRKSRC} -cf- . | ${TAR} -C ${STAGEDIR}${PREFIX}/${PORTNAME}-${PORTVERSION} -xpf-
- @${LN} -s ${PREFIX}/${PORTNAME}-${PORTVERSION}/art ${STAGEDIR}${PREFIX}/bin/art
- @${LN} -s ${PREFIX}/${PORTNAME}-${PORTVERSION}/act ${STAGEDIR}${PREFIX}/bin/act
+ @${LN} -s ../${PORTNAME}-${PORTVERSION}/art ${STAGEDIR}${PREFIX}/bin/art
+ @${LN} -s ../${PORTNAME}-${PORTVERSION}/act ${STAGEDIR}${PREFIX}/bin/act
.include <bsd.port.mk>