aboutsummaryrefslogtreecommitdiff
path: root/biology
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2017-02-27 14:09:25 +0000
committerJan Beich <jbeich@FreeBSD.org>2017-02-27 14:09:25 +0000
commitc899e00b62bcbba78734f1228c9ba2e864c2a88e (patch)
treee181dcd7acfae8266a40578eee51f73e3304c6ac /biology
parentfe0cf6e90960398815faa4ad06731a78ac9ef124 (diff)
downloadports-c899e00b62bcbba78734f1228c9ba2e864c2a88e.tar.gz
ports-c899e00b62bcbba78734f1228c9ba2e864c2a88e.zip
biology/plinkseq: unbreak with clang 4.0
PR: 216618 Submitted by: Jason Bacon <bacon4000@gmail.com> (maintainer)
Notes
Notes: svn path=/head/; revision=434941
Diffstat (limited to 'biology')
-rw-r--r--biology/plinkseq/Makefile1
-rw-r--r--biology/plinkseq/files/patch-sources_plinkseq_sources_lib_r8lib.cpp11
2 files changed, 12 insertions, 0 deletions
diff --git a/biology/plinkseq/Makefile b/biology/plinkseq/Makefile
index 826d3d0f427c..05a8a59792ce 100644
--- a/biology/plinkseq/Makefile
+++ b/biology/plinkseq/Makefile
@@ -3,6 +3,7 @@
PORTNAME= plinkseq
PORTVERSION= 0.10
+PORTREVISION= 1
CATEGORIES= biology science
MASTER_SITES= http://psychgen.u.hpc.mssm.edu/plinkseq_downloads/
# Default DISTNAME is correct, so leave it alone.
diff --git a/biology/plinkseq/files/patch-sources_plinkseq_sources_lib_r8lib.cpp b/biology/plinkseq/files/patch-sources_plinkseq_sources_lib_r8lib.cpp
new file mode 100644
index 000000000000..10d4005f15dc
--- /dev/null
+++ b/biology/plinkseq/files/patch-sources_plinkseq_sources_lib_r8lib.cpp
@@ -0,0 +1,11 @@
+--- sources/plinkseq/sources/lib/r8lib.cpp.orig 2014-07-09 14:37:16 UTC
++++ sources/plinkseq/sources/lib/r8lib.cpp
+@@ -31828,7 +31828,7 @@ void r8vec_index_sorted_range ( int n, d
+ if ( r_hi < r[indx[*i_hi]] )
+ {
+ *i_hi = *i_hi - 1;
+- if ( i_hi < 0 )
++ if ( *i_hi < 0 )
+ {
+ *i_lo = *i_hi + 1;
+ }