aboutsummaryrefslogtreecommitdiff
path: root/biology
diff options
context:
space:
mode:
authorWesley Shields <wxs@FreeBSD.org>2008-11-11 02:21:28 +0000
committerWesley Shields <wxs@FreeBSD.org>2008-11-11 02:21:28 +0000
commita8dc52d3dc047446ca98fa4d4bb0f80f23da05d4 (patch)
tree49e7f209ae4d990cbf159e615522fd59ad5872eb /biology
parent07a28c243885f33c02c07a1a3b9f84e13c5f5942 (diff)
downloadports-a8dc52d3dc047446ca98fa4d4bb0f80f23da05d4.tar.gz
ports-a8dc52d3dc047446ca98fa4d4bb0f80f23da05d4.zip
Notes
Diffstat (limited to 'biology')
-rw-r--r--biology/molden/Makefile18
-rw-r--r--biology/molden/distinfo6
-rw-r--r--biology/molden/files/patch-aa (renamed from biology/molden/files/patch-makefile)6
-rw-r--r--biology/molden/files/patch-xwin.c91
-rw-r--r--biology/molden/pkg-plist106
5 files changed, 117 insertions, 110 deletions
diff --git a/biology/molden/Makefile b/biology/molden/Makefile
index 177b352b4c09..a16f75d51f32 100644
--- a/biology/molden/Makefile
+++ b/biology/molden/Makefile
@@ -6,7 +6,8 @@
#
PORTNAME= molden
-PORTVERSION= 4.7
+PORTVERSION= 4.6
+PORTEPOCH= 1
CATEGORIES= biology
MASTER_SITES= ftp://ftp.cmbi.kun.nl/pub/molgraph/molden/
DISTNAME= ${PORTNAME}${PORTVERSION}
@@ -15,8 +16,6 @@ DIST_SUBDIR= ${PKGNAME}
MAINTAINER= oivulf@gmail.com
COMMENT= Display molecular orbitals and electron densities in 2D and 3D
-BROKEN= Does not fetch
-
USE_XORG= x11 xmu
USE_GL= glut
USE_FORTRAN= yes
@@ -28,9 +27,6 @@ MAKEFILE= ${WRKSRC}/makefile
PORTDOCS= docs/*
.endif
-post-patch:
- @${REINPLACE_CMD} -e 's,malloc.h,stdlib.h,' ${WRKSRC}/xwin.c
-
post-configure:
@${ECHO_MSG} "********************"
@${ECHO_MSG} "** If you want to use a larger MOLDEN,"
@@ -47,9 +43,11 @@ do-install:
${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/doc/* ${DOCSDIR}
.endif
- ${MKDIR} ${PREFIX}/share/molden/test
- ${MKDIR} ${PREFIX}/share/molden/utils
- ${INSTALL_DATA} ${WRKSRC}/test/* ${PREFIX}/share/molden/test
- ${INSTALL_DATA} ${WRKSRC}/utils/* ${PREFIX}/share/molden/utils
+.if !defined(NOPORTDATA)
+ ${MKDIR} ${DATADIR}/test
+ ${MKDIR} ${DATADIR}/utils
+ ${INSTALL_DATA} ${WRKSRC}/test/* ${DATADIR}/test
+ ${INSTALL_DATA} ${WRKSRC}/utils/* ${DATADIR}/utils
+.endif
.include <bsd.port.mk>
diff --git a/biology/molden/distinfo b/biology/molden/distinfo
index 9fbacbc7a84f..ad263a13e821 100644
--- a/biology/molden/distinfo
+++ b/biology/molden/distinfo
@@ -1,3 +1,3 @@
-MD5 (molden-4.7/molden4.7.tar.gz) = 27ed92f0e4a7e7ff02879f72f06e4af8
-SHA256 (molden-4.7/molden4.7.tar.gz) = d76facb939f912f493b480669f39474a2b848dbbd3d5515835ca0fbc57cdad37
-SIZE (molden-4.7/molden4.7.tar.gz) = 2817858
+MD5 (molden-4.6,1/molden4.6.tar.gz) = 3b4e7fa4a323c7e283c0348fc6bb3b2d
+SHA256 (molden-4.6,1/molden4.6.tar.gz) = e18583d3e3234426b06403b056aed50e98397d6733e3b635c7011725e2816380
+SIZE (molden-4.6,1/molden4.6.tar.gz) = 2786093
diff --git a/biology/molden/files/patch-makefile b/biology/molden/files/patch-aa
index ac9cc36e67b1..e4c75e6ed719 100644
--- a/biology/molden/files/patch-makefile
+++ b/biology/molden/files/patch-aa
@@ -1,5 +1,5 @@
---- makefile.orig 2008-08-25 19:55:57.000000000 +0200
-+++ makefile 2008-11-01 21:48:37.000000000 +0100
+--- makefile.orig 2008-06-24 15:44:16.000000000 +0200
++++ makefile 2008-11-10 22:53:22.000000000 +0100
@@ -12,9 +12,23 @@
#
# Disregard compiler warnings on rdmolf.f
@@ -57,7 +57,7 @@
surf/surf: surf/*.h surf/*.c
- $(MAKE) -C surf depend
-+# $(MAKE) -C surf depend
++ #$(MAKE) -C surf depend
$(MAKE) -C surf
# noxwin will not work as long as the old ocglbck calls arent in dummys
diff --git a/biology/molden/files/patch-xwin.c b/biology/molden/files/patch-xwin.c
index bb8017792ddf..f521bc4e51a5 100644
--- a/biology/molden/files/patch-xwin.c
+++ b/biology/molden/files/patch-xwin.c
@@ -1,15 +1,24 @@
---- xwin.c.orig 2008-11-03 09:37:45.707629185 -0500
-+++ xwin.c 2008-11-03 09:37:55.118628907 -0500
-@@ -3747,7 +3747,7 @@
- static int ibopth = 0;
- static int iboptl = 0;
- static int iboptm = 0;
+--- ./xwin.c.orig 2008-11-10 12:27:25.647441620 -0500
++++ ./xwin.c 2008-11-10 12:29:25.515496080 -0500
+@@ -22,7 +22,7 @@
+ #endif
+ #if defined(DARWIN) || defined(FREEBSD)
+ #else
+-#include <malloc.h>
++#include <stdlib.h>
+ #endif
+ #endif
+
+@@ -3360,7 +3360,7 @@
+ static int *icopth;
+ static int *icoptl;
+ static int *icoptm;
-static int linkat = 0;
+static int link_at = 0;
static QBOXSTRU IANZboxes[MAXAT];
static QBOXSTRU IZboxes[MAXAT][4];
-@@ -19086,7 +19086,7 @@
+@@ -17466,7 +17466,7 @@
if (ioniom == 1) {
int ism, isl;
@@ -18,20 +27,20 @@
/* Counting the number of Link atoms between H and lower
levels*/
-@@ -19099,10 +19099,10 @@
+@@ -17479,10 +17479,10 @@
if (ionij != 0) continue;
- nconn = xyzp->iconn[j*(MXCON+1)];
+ nconn = xyz.iconn[j*(MXCON+1)];
for (k=1;k<=nconn;k++) {
-- if (xyzp->ityp[xyzp->iconn[j*(MXCON+1)+k]-1]/10000 > 0) linkat++;
-+ if (xyzp->ityp[xyzp->iconn[j*(MXCON+1)+k]-1]/10000 > 0) link_at++;
+- if (xyz.ityp[xyz.iconn[j*(MXCON+1)+k]-1]/10000 > 0) linkat++;
++ if (xyz.ityp[xyz.iconn[j*(MXCON+1)+k]-1]/10000 > 0) link_at++;
}
}
- linkat += 20000;
+ link_at += 20000;
- jobcom->itotc = jobcom->icopth;
- jobcom->imult = jobcom->ispopth;
+ *itotc = *icopth;
+ *imult = *ispopth;
if (CheckChargeMult()) {
-@@ -19123,7 +19123,7 @@
+@@ -17503,7 +17503,7 @@
} else if (ioniom == 2) {
@@ -40,20 +49,20 @@
/* Counting the number of Link atoms between H and
lower levels*/
-@@ -19133,10 +19133,10 @@
+@@ -17513,10 +17513,10 @@
if(ionij != 0) continue;
- nconn = xyzp->iconn[j*(MXCON+1)];
+ nconn = xyz.iconn[j*(MXCON+1)];
for (k=1;k<=nconn;k++) {
-- if (xyzp->ityp[xyzp->iconn[j*(MXCON+1)+k]-1]/10000 > 0) linkat++;
-+ if (xyzp->ityp[xyzp->iconn[j*(MXCON+1)+k]-1]/10000 > 0) link_at++;
+- if (xyz.ityp[xyz.iconn[j*(MXCON+1)+k]-1]/10000 > 0) linkat++;
++ if (xyz.ityp[xyz.iconn[j*(MXCON+1)+k]-1]/10000 > 0) link_at++;
}
}
- linkat += 20000;
+ link_at += 20000;
- jobcom->itotc = jobcom->icopth;
- jobcom->imult = jobcom->ispopth;
+ *itotc = *icopth;
+ *imult = *ispopth;
if (CheckChargeMult()) {
-@@ -19148,7 +19148,7 @@
+@@ -17528,7 +17528,7 @@
break;
*/
}
@@ -62,29 +71,29 @@
/* Counting the number of Link atoms between H+M and
lower levels*/
-@@ -19158,10 +19158,10 @@
+@@ -17538,10 +17538,10 @@
if (ionij == 2) continue;
- nconn = xyzp->iconn[j*(MXCON+1)];
+ nconn = xyz.iconn[j*(MXCON+1)];
for (k=1;k<=nconn;k++) {
-- if (xyzp->ityp[xyzp->iconn[j*(MXCON+1)+k]-1]/10000 == 2) linkat++;
-+ if (xyzp->ityp[xyzp->iconn[j*(MXCON+1)+k]-1]/10000 == 2) link_at++;
+- if (xyz.ityp[xyz.iconn[j*(MXCON+1)+k]-1]/10000 == 2) linkat++;
++ if (xyz.ityp[xyz.iconn[j*(MXCON+1)+k]-1]/10000 == 2) link_at++;
}
}
- linkat += 20000;
+ link_at += 20000;
- jobcom->itotc = jobcom->icoptm;
- jobcom->imult = jobcom->ispoptm;
+ *itotc = *icoptm;
+ *imult = *ispoptm;
if (CheckChargeMult()) {
-@@ -19176,7 +19176,7 @@
- icopt = jobcom->icoptl+3;
- ispopt = jobcom->ispoptl-1;
+@@ -17556,7 +17556,7 @@
+ icopt = *icoptl+3;
+ ispopt = *ispoptl-1;
}
- linkat = 0;
+ link_at = 0;
- jobcom->itotc = icopt - 3;
- jobcom->imult = ispopt + 1;
- jobcom->ito = itopt[jmode] + 1;
-@@ -19428,10 +19428,10 @@
+ *itotc = icopt - 3;
+ *imult = ispopt + 1;
+ *ito = itopt[jmode] + 1;
+@@ -17808,10 +17808,10 @@
ionil = 0;
if (ioniom) {
@@ -97,18 +106,18 @@
+ link_at = 0;
}
- if (*zmptrp->ihaszm) {
-@@ -19454,10 +19454,10 @@
+ if (*zmptr.ihaszm) {
+@@ -17834,10 +17834,10 @@
}
}
/*
- fprintf(stderr,"ionil %d ne %d itotc %d linkat %d mult %d\n",
-- ionil,ne,jobcom->itotc,linkat,jobcom->imult);
+- ionil,ne,*itotc,linkat,*imult);
+ fprintf(stderr,"ionil %d ne %d itotc %d link_at %d mult %d\n",
-+ ionil,ne,jobcom->itotc,link_at,jobcom->imult);
++ ionil,ne,*itotc,link_at,*imult);
*/
-- ne = ne - jobcom->itotc + linkat;
-+ ne = ne - jobcom->itotc + link_at;
- if (ne % 2 == jobcom->imult % 2) return(1);
+- ne = ne - *itotc + linkat;
++ ne = ne - *itotc + link_at;
+ if (ne % 2 == *imult % 2) return(1);
return(0);
}
diff --git a/biology/molden/pkg-plist b/biology/molden/pkg-plist
index 169d1e39d52a..53b0cc1ff4b6 100644
--- a/biology/molden/pkg-plist
+++ b/biology/molden/pkg-plist
@@ -5,56 +5,56 @@ bin/surf
%%PORTDOCS%%%%DOCSDIR%%/manual.txt.Z
%%PORTDOCS%%%%DOCSDIR%%/manual.ps.Z
%%PORTDOCS%%%%DOCSDIR%%/figures.ps.Z
-share/molden/test/adf.molf
-share/molden/test/ambfor_amber.xyz
-share/molden/test/ambfor_gaff.xyz
-share/molden/test/ampac.arc
-share/molden/test/ampac.test
-share/molden/test/bucky.xyz
-share/molden/test/chemx.test
-share/molden/test/complex2.out
-share/molden/test/cpeptide.gro
-share/molden/test/esp.test
-share/molden/test/esp.txt
-share/molden/test/esp.xyz
-share/molden/test/fragment
-share/molden/test/gamess_uk.freq
-share/molden/test/gamess_uk.input
-share/molden/test/gamess_uk.test1
-share/molden/test/gamess_uk.test2
-share/molden/test/gamess_us.h2o_631g_opt.out
-share/molden/test/gamess_us.irc
-share/molden/test/gamess_us_uhf_opt
-share/molden/test/gaussian.freq
-share/molden/test/gaussian.input
-share/molden/test/gaussian.test
-share/molden/test/jaguar.cube
-share/molden/test/molden.ogl
-share/molden/test/mopac.freq
-share/molden/test/mopac.test
-share/molden/test/pdb.test
-share/molden/test/pdb.test.omap
-share/molden/test/qchem.test
-share/molden/test/reacpth.xyz
-share/molden/test/shelx.ins
-share/molden/test/surface.molf
-share/molden/test/test.fdat
-share/molden/test/test.mol2
-share/molden/test/test_homo.cube
-share/molden/test/tinker_charmm.xyz
-share/molden/test/tinker_mm3.xyz
-share/molden/test/uracil.fdat
-share/molden/test/uracil_gauss.out
-share/molden/test/vamp.test
-share/molden/utils/INFO
-share/molden/utils/ch_backspace
-share/molden/utils/ch_mxcon
-share/molden/utils/ch_par
-share/molden/utils/colors
-share/molden/utils/ircextract.awk
-share/molden/utils/molden
-share/molden/utils/multi_vrml.csh
-share/molden/utils/multi_vrml_orbitals.csh
-@dirrm share/molden/utils
-@dirrm share/molden/test
-@dirrm share/molden
+%%PORTDATA%%%%DATADIR%%/test/adf.molf
+%%PORTDATA%%%%DATADIR%%/test/ambfor_amber.xyz
+%%PORTDATA%%%%DATADIR%%/test/ambfor_gaff.xyz
+%%PORTDATA%%%%DATADIR%%/test/ampac.arc
+%%PORTDATA%%%%DATADIR%%/test/ampac.test
+%%PORTDATA%%%%DATADIR%%/test/bucky.xyz
+%%PORTDATA%%%%DATADIR%%/test/chemx.test
+%%PORTDATA%%%%DATADIR%%/test/complex2.out
+%%PORTDATA%%%%DATADIR%%/test/cpeptide.gro
+%%PORTDATA%%%%DATADIR%%/test/esp.test
+%%PORTDATA%%%%DATADIR%%/test/esp.txt
+%%PORTDATA%%%%DATADIR%%/test/esp.xyz
+%%PORTDATA%%%%DATADIR%%/test/fragment
+%%PORTDATA%%%%DATADIR%%/test/gamess_uk.freq
+%%PORTDATA%%%%DATADIR%%/test/gamess_uk.input
+%%PORTDATA%%%%DATADIR%%/test/gamess_uk.test1
+%%PORTDATA%%%%DATADIR%%/test/gamess_uk.test2
+%%PORTDATA%%%%DATADIR%%/test/gamess_us.h2o_631g_opt.out
+%%PORTDATA%%%%DATADIR%%/test/gamess_us.irc
+%%PORTDATA%%%%DATADIR%%/test/gamess_us_uhf_opt
+%%PORTDATA%%%%DATADIR%%/test/gaussian.freq
+%%PORTDATA%%%%DATADIR%%/test/gaussian.input
+%%PORTDATA%%%%DATADIR%%/test/gaussian.test
+%%PORTDATA%%%%DATADIR%%/test/jaguar.cube
+%%PORTDATA%%%%DATADIR%%/test/molden.ogl
+%%PORTDATA%%%%DATADIR%%/test/mopac.freq
+%%PORTDATA%%%%DATADIR%%/test/mopac.test
+%%PORTDATA%%%%DATADIR%%/test/pdb.test
+%%PORTDATA%%%%DATADIR%%/test/pdb.test.omap
+%%PORTDATA%%%%DATADIR%%/test/qchem.test
+%%PORTDATA%%%%DATADIR%%/test/reacpth.xyz
+%%PORTDATA%%%%DATADIR%%/test/shelx.ins
+%%PORTDATA%%%%DATADIR%%/test/surface.molf
+%%PORTDATA%%%%DATADIR%%/test/test.fdat
+%%PORTDATA%%%%DATADIR%%/test/test.mol2
+%%PORTDATA%%%%DATADIR%%/test/test_homo.cube
+%%PORTDATA%%%%DATADIR%%/test/tinker_charmm.xyz
+%%PORTDATA%%%%DATADIR%%/test/tinker_mm3.xyz
+%%PORTDATA%%%%DATADIR%%/test/uracil.fdat
+%%PORTDATA%%%%DATADIR%%/test/uracil_gauss.out
+%%PORTDATA%%%%DATADIR%%/test/vamp.test
+%%PORTDATA%%%%DATADIR%%/utils/INFO
+%%PORTDATA%%%%DATADIR%%/utils/ch_backspace
+%%PORTDATA%%%%DATADIR%%/utils/ch_mxcon
+%%PORTDATA%%%%DATADIR%%/utils/ch_par
+%%PORTDATA%%%%DATADIR%%/utils/colors
+%%PORTDATA%%%%DATADIR%%/utils/ircextract.awk
+%%PORTDATA%%%%DATADIR%%/utils/molden
+%%PORTDATA%%%%DATADIR%%/utils/multi_vrml.csh
+%%PORTDATA%%%%DATADIR%%/utils/multi_vrml_orbitals.csh
+%%PORTDATA%%@dirrm %%DATADIR%%/utils
+%%PORTDATA%%@dirrm %%DATADIR%%/test
+%%PORTDATA%%@dirrm %%DATADIR%%