aboutsummaryrefslogtreecommitdiff
path: root/biology
diff options
context:
space:
mode:
authorJason W. Bacon <jwb@FreeBSD.org>2019-07-12 23:58:22 +0000
committerJason W. Bacon <jwb@FreeBSD.org>2019-07-12 23:58:22 +0000
commitdf8230f473a59350229f2e498383a9029cfb1f82 (patch)
tree1e1811a7ba47aa50c9edb3735760ce33ed6c1454 /biology
parent96ec6abecd308e55bbffb19e603b179ebf9a14ab (diff)
downloadports-df8230f473a59350229f2e498383a9029cfb1f82.tar.gz
ports-df8230f473a59350229f2e498383a9029cfb1f82.zip
ncbi-blast+: Unbreak build with gcc8 following gcc9 patch
GCC 8 and 9 are incompatible in handling const variables with OpenMP default(none). All const variables default to shared even with default(none) present. 8 errors out if a const variable is explicitly defined as shared and 9 requires an explicit definition. Using an upstream trunk patch for now, which checks the compiler version. Also discussing more portable approaches to avoid future issues. Reported by: jrm
Notes
Notes: svn path=/head/; revision=506497
Diffstat (limited to 'biology')
-rw-r--r--biology/ncbi-blast+/Makefile2
-rw-r--r--biology/ncbi-blast+/files/patch-src_objtools_blast_seqdb__reader_test_seqdb__perf.cpp14
2 files changed, 9 insertions, 7 deletions
diff --git a/biology/ncbi-blast+/Makefile b/biology/ncbi-blast+/Makefile
index 06bc21a59392..f4570f142696 100644
--- a/biology/ncbi-blast+/Makefile
+++ b/biology/ncbi-blast+/Makefile
@@ -2,7 +2,7 @@
PORTNAME= ncbi-blast+
DISTVERSION= 2.9.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= biology perl5 python
MASTER_SITES= https://ftp.ncbi.nlm.nih.gov/blast/executables/blast+/LATEST/ \
https://ftp.ncbi.nlm.nih.gov/blast/executables/blast+/${PORTVERSION}/
diff --git a/biology/ncbi-blast+/files/patch-src_objtools_blast_seqdb__reader_test_seqdb__perf.cpp b/biology/ncbi-blast+/files/patch-src_objtools_blast_seqdb__reader_test_seqdb__perf.cpp
index 64f24cecd4cc..f9320d36865f 100644
--- a/biology/ncbi-blast+/files/patch-src_objtools_blast_seqdb__reader_test_seqdb__perf.cpp
+++ b/biology/ncbi-blast+/files/patch-src_objtools_blast_seqdb__reader_test_seqdb__perf.cpp
@@ -1,14 +1,16 @@
---- src/objtools/blast/seqdb_reader/test/seqdb_perf.cpp.orig 2019-07-10 10:11:51.713901000 -0500
-+++ src/objtools/blast/seqdb_reader/test/seqdb_perf.cpp 2019-07-10 10:15:40.994964000 -0500
-@@ -137,8 +137,10 @@ CSeqDBPerfApp::x_ScanDatabase()
+--- src/objtools/blast/seqdb_reader/test/seqdb_perf.cpp.orig 2018-10-23 19:28:52 UTC
++++ src/objtools/blast/seqdb_reader/test/seqdb_perf.cpp
+@@ -137,8 +137,13 @@ CSeqDBPerfApp::x_ScanDatabase()
}
LOG_POST(Info << "Will go over " << oids2iterate.size() << " sequences");
-+ // kScanUncompressed is read only and initialized before threading
-+ // so shared should be fine here
++#if defined(NCBI_COMPILER_GCC) && (NCBI_COMPILER_VERSION >= 900)
#pragma omp parallel default(none) num_threads(m_DbHandles.size()) \
-- shared(oids2iterate) if(m_DbHandles.size() > 1)
+ shared(oids2iterate,kScanUncompressed) if(m_DbHandles.size() > 1)
++#else
++ #pragma omp parallel default(none) num_threads(m_DbHandles.size()) \
+ shared(oids2iterate) if(m_DbHandles.size() > 1)
++#endif
{
int thread_id = 0;
#ifdef _OPENMP