aboutsummaryrefslogtreecommitdiff
path: root/biology
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2021-09-19 06:46:04 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2021-09-19 06:47:03 +0000
commit74c998634a3910153179e59ed3fa5f43df3d7332 (patch)
tree0c7032181855e6b0435b04cd4fbe23404aa4d7e0 /biology
parentad2bdb6508797ea89b8e554df96ebbd08b6835ee (diff)
downloadports-74c998634a3910153179e59ed3fa5f43df3d7332.tar.gz
ports-74c998634a3910153179e59ed3fa5f43df3d7332.zip
biology/py-libnuml: New port: Numerical Markup Language for Python
Diffstat (limited to 'biology')
-rw-r--r--biology/Makefile1
-rw-r--r--biology/py-libnuml/Makefile31
-rw-r--r--biology/py-libnuml/distinfo3
-rw-r--r--biology/py-libnuml/files/patch-CMakeLists.txt22
-rw-r--r--biology/py-libnuml/pkg-descr8
-rw-r--r--biology/py-libnuml/pkg-plist3
6 files changed, 68 insertions, 0 deletions
diff --git a/biology/Makefile b/biology/Makefile
index e24861f2a317..ec370d664a52 100644
--- a/biology/Makefile
+++ b/biology/Makefile
@@ -150,6 +150,7 @@
SUBDIR += py-loompy
SUBDIR += py-macs2
SUBDIR += py-multiqc
+ SUBDIR += py-libnuml
SUBDIR += py-ont-fast5-api
SUBDIR += py-orange3-bioinformatics
SUBDIR += py-orange3-single-cell
diff --git a/biology/py-libnuml/Makefile b/biology/py-libnuml/Makefile
new file mode 100644
index 000000000000..dcd1b9df3d08
--- /dev/null
+++ b/biology/py-libnuml/Makefile
@@ -0,0 +1,31 @@
+PORTNAME= libnuml
+DISTVERSIONPREFIX= v
+DISTVERSION= 1.1.4
+CATEGORIES= biology devel
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Numerical Markup Language for Python
+
+LICENSE= LGPL21
+
+BUILD_DEPENDS= swig:devel/swig
+LIB_DEPENDS= libnuml.so:biology/libnuml
+
+USES= cmake localbase:ldflags python
+USE_PYTHON= flavors
+
+USE_GITHUB= yes
+GH_ACCOUNT= NuML
+GH_PROJECT= NuML
+
+WKSRC_SUBDIR= ${PORTNAME}/src/bindings/python
+
+CMAKE_ARGS= -DCMAKE_INSTALL_LIBDIR=lib
+
+LDFLAGS+= -lnuml # otherwise it builds a broken shared object, see https://github.com/NuML/NuML/issues/21
+
+post-extract:
+ @${RLN} ${WRKSRC}/../../../VERSION.txt ${WRKSRC}/VERSION.txt
+
+.include <bsd.port.mk>
diff --git a/biology/py-libnuml/distinfo b/biology/py-libnuml/distinfo
new file mode 100644
index 000000000000..6d10a1bca0ea
--- /dev/null
+++ b/biology/py-libnuml/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1632027367
+SHA256 (NuML-NuML-v1.1.4_GH0.tar.gz) = 18e8f6d9b0c261f34123bc2e1bd601730993d63fb53f7434b5901b1059aa9109
+SIZE (NuML-NuML-v1.1.4_GH0.tar.gz) = 3419841
diff --git a/biology/py-libnuml/files/patch-CMakeLists.txt b/biology/py-libnuml/files/patch-CMakeLists.txt
new file mode 100644
index 000000000000..12167a58575d
--- /dev/null
+++ b/biology/py-libnuml/files/patch-CMakeLists.txt
@@ -0,0 +1,22 @@
+--- CMakeLists.txt.orig 2021-04-29 08:24:05 UTC
++++ CMakeLists.txt
+@@ -62,6 +62,7 @@ ADD_CUSTOM_COMMAND(
+ OUTPUT ${CMAKE_CURRENT_BINARY_DIR}/libnuml_wrap.cpp
+ COMMAND "${SWIG_EXECUTABLE}"
+ ARGS -I${CMAKE_CURRENT_SOURCE_DIR}/../swig/
++ -I${CMAKE_INSTALL_PREFIX}/include
+ -I${CMAKE_SOURCE_DIR}/
+ -I${CMAKE_BINARY_DIR}/
+ -I${CMAKE_BINARY_DIR}/src
+@@ -142,9 +143,9 @@ if (PYTHON_USE_DYNAMIC_LOOKUP)
+ if (APPLE)
+ set_target_properties (binding_python_lib PROPERTIES LINK_FLAGS "-undefined dynamic_lookup")
+ endif()
+- target_link_libraries(binding_python_lib ${LIBNUML_LIBRARY}-static)
++ target_link_libraries(binding_python_lib ${LIBNUML_LIBRARY})
+ else()
+- target_link_libraries(binding_python_lib ${LIBNUML_LIBRARY}-static ${PYTHON_LIBRARIES})
++ target_link_libraries(binding_python_lib ${LIBNUML_LIBRARY} ${PYTHON_LIBRARIES})
+ endif()
+
+
diff --git a/biology/py-libnuml/pkg-descr b/biology/py-libnuml/pkg-descr
new file mode 100644
index 000000000000..a8a267cc7f76
--- /dev/null
+++ b/biology/py-libnuml/pkg-descr
@@ -0,0 +1,8 @@
+This is a Python binding for libnuml, the Numerical Markup Language library.
+
+The Numerical Markup Language (NuML) aims to standardize the exchange and
+archiving of numerical results. NuML originates from the numerical aspects of
+the Systems Biology Results Markup Language (SBRML) with the aim of re-using it
+in multiple other standardization efforts.
+
+WWW: https://github.com/NuML/NuML
diff --git a/biology/py-libnuml/pkg-plist b/biology/py-libnuml/pkg-plist
new file mode 100644
index 000000000000..8156ea3a6416
--- /dev/null
+++ b/biology/py-libnuml/pkg-plist
@@ -0,0 +1,3 @@
+%%PYTHON_SITELIBDIR%%/libnuml.pth
+%%PYTHON_SITELIBDIR%%/libnuml/_libnuml.so
+%%PYTHON_SITELIBDIR%%/libnuml/libnuml.py