aboutsummaryrefslogtreecommitdiff
path: root/biology
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2021-09-19 06:15:20 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2021-09-19 06:47:02 +0000
commitad2bdb6508797ea89b8e554df96ebbd08b6835ee (patch)
tree1394ae174cf9c641b2fad80e8087c937b5625672 /biology
parent54307857c77dd37da3c5f3608294eb7361700a38 (diff)
downloadports-ad2bdb6508797ea89b8e554df96ebbd08b6835ee.tar.gz
ports-ad2bdb6508797ea89b8e554df96ebbd08b6835ee.zip
biology/libnuml: New port: C++ library for Numerical Markup Language
Diffstat (limited to 'biology')
-rw-r--r--biology/Makefile1
-rw-r--r--biology/libnuml/Makefile26
-rw-r--r--biology/libnuml/distinfo3
-rw-r--r--biology/libnuml/pkg-descr6
-rw-r--r--biology/libnuml/pkg-plist44
5 files changed, 80 insertions, 0 deletions
diff --git a/biology/Makefile b/biology/Makefile
index 294a87ca4e78..e24861f2a317 100644
--- a/biology/Makefile
+++ b/biology/Makefile
@@ -76,6 +76,7 @@
SUBDIR += lamarc
SUBDIR += libbigwig
SUBDIR += libgtextutils
+ SUBDIR += libnuml
SUBDIR += libsbml
SUBDIR += linux-foldingathome
SUBDIR += mafft
diff --git a/biology/libnuml/Makefile b/biology/libnuml/Makefile
new file mode 100644
index 000000000000..890a2e919ee8
--- /dev/null
+++ b/biology/libnuml/Makefile
@@ -0,0 +1,26 @@
+PORTNAME= libnuml
+DISTVERSIONPREFIX= v
+DISTVERSION= 1.1.4
+CATEGORIES= biology devel
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= C++ library for Numerical Markup Language
+
+LICENSE= LGPL21
+
+LIB_DEPENDS= libsbml.so:biology/libsbml
+
+USES= cmake gnome
+USE_GNOME= libxml2
+USE_LDCONFIG= yes
+
+USE_GITHUB= yes
+GH_ACCOUNT= NuML
+GH_PROJECT= NuML
+
+WRKSRC_SUBDIR= ${PORTNAME}
+
+post-install:
+ @${RM} -r ${STAGEDIR}${DATADIR}
+
+.include <bsd.port.mk>
diff --git a/biology/libnuml/distinfo b/biology/libnuml/distinfo
new file mode 100644
index 000000000000..6d10a1bca0ea
--- /dev/null
+++ b/biology/libnuml/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1632027367
+SHA256 (NuML-NuML-v1.1.4_GH0.tar.gz) = 18e8f6d9b0c261f34123bc2e1bd601730993d63fb53f7434b5901b1059aa9109
+SIZE (NuML-NuML-v1.1.4_GH0.tar.gz) = 3419841
diff --git a/biology/libnuml/pkg-descr b/biology/libnuml/pkg-descr
new file mode 100644
index 000000000000..011a4793507b
--- /dev/null
+++ b/biology/libnuml/pkg-descr
@@ -0,0 +1,6 @@
+The Numerical Markup Language (NuML) aims to standardize the exchange and
+archiving of numerical results. NuML originates from the numerical aspects of
+the Systems Biology Results Markup Language (SBRML) with the aim of re-using it
+in multiple other standardization efforts.
+
+WWW: https://github.com/NuML/NuML
diff --git a/biology/libnuml/pkg-plist b/biology/libnuml/pkg-plist
new file mode 100644
index 000000000000..44b188050119
--- /dev/null
+++ b/biology/libnuml/pkg-plist
@@ -0,0 +1,44 @@
+include/numl/AtomicDescription.h
+include/numl/AtomicValue.h
+include/numl/CompositeDescription.h
+include/numl/CompositeValue.h
+include/numl/Dimension.h
+include/numl/DimensionDescription.h
+include/numl/NMBase.h
+include/numl/NUMLDocument.h
+include/numl/NUMLError.h
+include/numl/NUMLErrorLog.h
+include/numl/NUMLErrorTable.h
+include/numl/NUMLList.h
+include/numl/NUMLNamespaces.h
+include/numl/NUMLReader.h
+include/numl/NUMLSimpleTester.h
+include/numl/NUMLTypeCodes.h
+include/numl/NUMLTypes.h
+include/numl/NUMLVisitor.h
+include/numl/NUMLWriter.h
+include/numl/OntologyTerm.h
+include/numl/ResultComponent.h
+include/numl/Tuple.h
+include/numl/TupleDescription.h
+include/numl/common/common.h
+include/numl/common/extern.h
+include/numl/common/libnuml-config-common.h
+include/numl/common/libnuml-config-unix.h
+include/numl/common/libnuml-config-win.h
+include/numl/common/libnuml-config.h
+include/numl/common/libnuml-namespace.h
+include/numl/common/libnuml-package.h
+include/numl/common/libnuml-version.h
+include/numl/common/numlfwd.h
+include/numl/common/operationReturnValues.h
+lib/cmake/numl-config-%%CMAKE_BUILD_TYPE%%.cmake
+lib/cmake/numl-config-version.cmake
+lib/cmake/numl-config.cmake
+lib/cmake/numl-static-config-%%CMAKE_BUILD_TYPE%%.cmake
+lib/cmake/numl-static-config-version.cmake
+lib/cmake/numl-static-config.cmake
+lib/libnuml-static.a
+lib/libnuml.so
+lib/libnuml.so.1
+lib/libnuml.so.1.1.4