aboutsummaryrefslogtreecommitdiff
path: root/biology
diff options
context:
space:
mode:
authorWill Andrews <will@FreeBSD.org>2000-06-07 17:10:12 +0000
committerWill Andrews <will@FreeBSD.org>2000-06-07 17:10:12 +0000
commita500b8cdd1955375822ee5a246f860aea3d72dec (patch)
tree5de9214f8eaa297c48fd84abfc83a589aad96738 /biology
parentaa9def47a9d3a14dec0ab97cc4ae1a801bd08b5f (diff)
downloadports-a500b8cdd1955375822ee5a246f860aea3d72dec.tar.gz
ports-a500b8cdd1955375822ee5a246f860aea3d72dec.zip
Notes
Diffstat (limited to 'biology')
-rw-r--r--biology/deft/Makefile44
-rw-r--r--biology/deft/files/Makefile.deft20
-rw-r--r--biology/deft/files/patch-aa77
-rw-r--r--biology/deft/pkg-descr6
-rw-r--r--biology/deft/pkg-plist199
5 files changed, 181 insertions, 165 deletions
diff --git a/biology/deft/Makefile b/biology/deft/Makefile
index 47e5bbb8b9e2..2a081c757d47 100644
--- a/biology/deft/Makefile
+++ b/biology/deft/Makefile
@@ -1,6 +1,6 @@
-# New ports collection makefile for: DeFT
-# Date created: 1999-01-11
-# Whom: Ryo MIYAMOTO <rmiya@cc.hirosaki-u.ac.jp>
+# New ports collection makefile for: DeFT
+# Date created: 1999-01-11
+# Whom: Ryo MIYAMOTO <rmiya@cc.hirosaki-u.ac.jp>
#
# $FreeBSD$
#
@@ -16,28 +16,38 @@ MAINTAINER= rmiya@cc.hirosaki-u.ac.jp
WRKSRC= ${WRKDIR}/${DISTNAME}/source
-post-configure:
- ${CP} ${FILESDIR}/Makefile.deft ${WRKSRC}/Makefile
+.include <bsd.port.pre.mk>
-pre-install:
- ${RM} -rf ${PREFIX}/share/doc/DeFT
- ${MKDIR} ${PREFIX}/share/doc/DeFT
-.if !defined(NOPORTDOCS)
- ${MKDIR} ${PREFIX}/share/doc/DeFT/examples
+.if ${OSVERSION} >= 400005
+# Using g77 is troublesome, then it is better to use f2c/cc.
+BUILD_DEPENDS= fc:${PORTSDIR}/lang/f77
.endif
+post-configure:
+ ${CP} ${FILESDIR}/Makefile.deft ${WRKSRC}/Makefile
+
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/DeFT.exec ${PREFIX}/bin/
${INSTALL_SCRIPT} ${WRKDIR}/${DISTNAME}/examples/DeFT ${PREFIX}/bin/
- ${INSTALL_DATA} ${WRKDIR}/${DISTNAME}/bases ${PREFIX}/share/doc/DeFT/
+ ${MKDIR} ${PREFIX}/share/doc/DeFT
+ ${MKDIR} ${PREFIX}/share/DeFT
+ ${INSTALL_DATA} ${WRKDIR}/${DISTNAME}/bases ${PREFIX}/share/DeFT/
post-install:
.if !defined(NOPORTDOCS)
- ${INSTALL_DATA} ${WRKDIR}/${DISTNAME}/README_Liability ${PREFIX}/share/doc/DeFT/
- ${INSTALL_DATA} ${WRKDIR}/${DISTNAME}/input.* ${PREFIX}/share/doc/DeFT/
- ${INSTALL_DATA} ${WRKDIR}/${DISTNAME}/install.* ${PREFIX}/share/doc/DeFT/
- ${INSTALL_DATA} ${WRKDIR}/${DISTNAME}/examples/* ${PREFIX}/share/doc/DeFT/examples/
- ${RM} -f ${PREFIX}/share/doc/DeFT/examples/DeFT*
+ ${MKDIR} ${PREFIX}/share/examples/DeFT
+ ${INSTALL_DATA} ${WRKDIR}/${DISTNAME}/README_Liability \
+ ${PREFIX}/share/doc/DeFT/
+ ${INSTALL_DATA} ${WRKDIR}/${DISTNAME}/input.* \
+ ${PREFIX}/share/doc/DeFT/
+ ${INSTALL_DATA} ${WRKDIR}/${DISTNAME}/install.* \
+ ${PREFIX}/share/doc/DeFT/
+ ${INSTALL_DATA} ${WRKDIR}/${DISTNAME}/examples/README \
+ ${PREFIX}/share/examples/DeFT
+ ${INSTALL_DATA} ${WRKDIR}/${DISTNAME}/examples/*.dft \
+ ${PREFIX}/share/examples/DeFT
+ ${INSTALL_DATA} ${WRKDIR}/${DISTNAME}/examples/*.out \
+ ${PREFIX}/share/examples/DeFT
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/biology/deft/files/Makefile.deft b/biology/deft/files/Makefile.deft
index 2567e4881e24..92451c41cbb1 100644
--- a/biology/deft/files/Makefile.deft
+++ b/biology/deft/files/Makefile.deft
@@ -2,10 +2,18 @@
# Makefile for DeFT
#
TARGET = DeFT.exec
-.if ${MACHINE_ARCH} != "i386"
-FFLAGS = -O2
-.else
-FFLAGS = -O2 -malign-double -Nn802
+FFLAGS += -w
+CFLAGS += -w
+.if ${MACHINE_ARCH} == "i386"
+FFLAGS += -malign-double
+CFLAGS += -malign-double
+.endif
+F2C = f2c
+F2CFLAGS += -w -Nn802
+.if ${OSVERSION} >= 400005
+#FC = ftn77
+FC = fc
+CFLAGS += -I${PREFIX}/include
.endif
LFLAGS =
SRCS:sh = ls *.f
@@ -16,6 +24,10 @@ all: ${TARGET}
${TARGET}: ${OBJS}
${FC} ${LFLAGS} ${OBJS} -o $@
+cdgrxx.o:
+ ${F2C} ${F2CFLAGS} cdgrxx.f
+ ${CC} ${CFLAGS} -c cdgrxx.c
+
clean:
rm -f ${OBJS} ${TARGET}
diff --git a/biology/deft/files/patch-aa b/biology/deft/files/patch-aa
index e498e1717194..933341927f96 100644
--- a/biology/deft/files/patch-aa
+++ b/biology/deft/files/patch-aa
@@ -1,45 +1,32 @@
-*** ../examples/DeFT Fri Aug 28 06:35:41 1998
---- ../examples/DeFT.new Sun May 9 23:41:43 1999
-***************
-*** 1,10 ****
- #
-! # here is the shell for running DeFT
- #
-
-! setenv my_directory $HOME/DeFT_2.2/examples
-! setenv DeFT_directory $HOME/DeFT_2.2
-! setenv temp_directory /scratch/tmp$$
-
- mkdir $temp_directory
- cd $temp_directory
---- 1,11 ----
-+ #!/bin/csh -f
- #
-! # running DeFT
- #
-
-! setenv my_directory $2
-! setenv DeFT_directory /usr/local/share/doc/DeFT
-! setenv temp_directory /usr/tmp/tmp$$
-
- mkdir $temp_directory
- cd $temp_directory
-***************
-*** 19,27 ****
-
- chmod u+w $temp_directory/*
-
-! cp $DeFT_directory/source/DeFT DeFT
-!
-! time DeFT < input >& $my_directory/$1.out
-
- cp new_restart $my_directory/$1.rst
- cp espf $my_directory/$1.espf
---- 20,26 ----
-
- chmod u+w $temp_directory/*
-
-! time DeFT.exec < input >& $my_directory/$1.out
-
- cp new_restart $my_directory/$1.rst
- cp espf $my_directory/$1.espf
+--- ../examples/DeFT.orig Thu Aug 27 16:35:41 1998
++++ ../examples/DeFT Wed May 31 18:40:28 2000
+@@ -1,10 +1,14 @@
++#!/bin/csh -f
+ #
+-# here is the shell for running DeFT
++# running DeFT
+ #
+
+-setenv my_directory $HOME/DeFT_2.2/examples
+-setenv DeFT_directory $HOME/DeFT_2.2
+-setenv temp_directory /scratch/tmp$$
++setenv my_directory $2
++if (null$my_directory == null) then
++ setenv my_directory `echo $PWD`
++endif
++setenv DeFT_directory /usr/local/share/DeFT
++setenv temp_directory /usr/tmp/tmp$$
+
+ mkdir $temp_directory
+ cd $temp_directory
+@@ -19,9 +23,7 @@
+
+ chmod u+w $temp_directory/*
+
+-cp $DeFT_directory/source/DeFT DeFT
+-
+-time DeFT < input >& $my_directory/$1.out
++time DeFT.exec < input >& $my_directory/$1.out
+
+ cp new_restart $my_directory/$1.rst
+ cp espf $my_directory/$1.espf
diff --git a/biology/deft/pkg-descr b/biology/deft/pkg-descr
index b186e8e06ac6..7b1956635801 100644
--- a/biology/deft/pkg-descr
+++ b/biology/deft/pkg-descr
@@ -5,5 +5,11 @@ Basis sets are prepared for H to Xe.
WWW: http://www.chem.uottawa.ca/DeFT.html
+Potring to 4.0-CURRENT (__FreeBSD_version == 400005) and later versions
+have been assisted greatly by Glenn Johnson <gjohnson@nola.srrc.usda.gov>,
+thanks a lot !
+He found a couple of troublesome in optimization using g77 at FreeBSD 4,
+then it is recommended to use f2c/cc.
+
--
rmiya
diff --git a/biology/deft/pkg-plist b/biology/deft/pkg-plist
index 35ad781fdf26..42df8676f40c 100644
--- a/biology/deft/pkg-plist
+++ b/biology/deft/pkg-plist
@@ -1,109 +1,110 @@
bin/DeFT.exec
bin/DeFT
share/doc/DeFT/README_Liability
-share/doc/DeFT/bases
+share/DeFT/bases
share/doc/DeFT/input.dvi
share/doc/DeFT/input.ps
share/doc/DeFT/input.tex
share/doc/DeFT/install.dvi
share/doc/DeFT/install.ps
share/doc/DeFT/install.tex
-share/doc/DeFT/examples/1,3-difluorobenzene.dft
-share/doc/DeFT/examples/1,3-difluorobenzene.out
-share/doc/DeFT/examples/2-hydroxybicyclopentane.dft
-share/doc/DeFT/examples/2-hydroxybicyclopentane.out
-share/doc/DeFT/examples/README
-share/doc/DeFT/examples/acetone.dft
-share/doc/DeFT/examples/acetone.out
-share/doc/DeFT/examples/acetone_a.dft
-share/doc/DeFT/examples/acetone_a.out
-share/doc/DeFT/examples/acetone_b.dft
-share/doc/DeFT/examples/acetone_b.out
-share/doc/DeFT/examples/acetylene.dft
-share/doc/DeFT/examples/acetylene.out
-share/doc/DeFT/examples/allene.dft
-share/doc/DeFT/examples/allene.out
-share/doc/DeFT/examples/ammonia.dft
-share/doc/DeFT/examples/ammonia.out
-share/doc/DeFT/examples/benzaldehyde.dft
-share/doc/DeFT/examples/benzaldehyde.out
-share/doc/DeFT/examples/benzene.dft
-share/doc/DeFT/examples/benzene.out
-share/doc/DeFT/examples/bh4-.dft
-share/doc/DeFT/examples/bh4-.out
-share/doc/DeFT/examples/c_atom.dft
-share/doc/DeFT/examples/c_atom.out
-share/doc/DeFT/examples/ch2.dft
-share/doc/DeFT/examples/ch2.out
-share/doc/DeFT/examples/disilyl_ether.dft
-share/doc/DeFT/examples/disilyl_ether.out
-share/doc/DeFT/examples/ethane.dft
-share/doc/DeFT/examples/ethane.out
-share/doc/DeFT/examples/ethanol.dft
-share/doc/DeFT/examples/ethanol.out
-share/doc/DeFT/examples/ethylene_a.dft
-share/doc/DeFT/examples/ethylene_a.out
-share/doc/DeFT/examples/ethylene_b.dft
-share/doc/DeFT/examples/ethylene_b.out
-share/doc/DeFT/examples/f_atom.dft
-share/doc/DeFT/examples/f_atom.out
-share/doc/DeFT/examples/formaldehyde_a.dft
-share/doc/DeFT/examples/formaldehyde_a.out
-share/doc/DeFT/examples/formaldehyde_b.dft
-share/doc/DeFT/examples/formaldehyde_b.out
-share/doc/DeFT/examples/furan.dft
-share/doc/DeFT/examples/furan.out
-share/doc/DeFT/examples/hcn_a.dft
-share/doc/DeFT/examples/hcn_a.out
-share/doc/DeFT/examples/hcn_b.dft
-share/doc/DeFT/examples/hcn_b.out
-share/doc/DeFT/examples/hydroxide_a.dft
-share/doc/DeFT/examples/hydroxide_a.out
-share/doc/DeFT/examples/hydroxide_b.dft
-share/doc/DeFT/examples/hydroxide_b.out
-share/doc/DeFT/examples/hydroxide_c.dft
-share/doc/DeFT/examples/hydroxide_c.out
-share/doc/DeFT/examples/hydroxysulphane.dft
-share/doc/DeFT/examples/hydroxysulphane.out
-share/doc/DeFT/examples/malonaldehyde_a.dft
-share/doc/DeFT/examples/malonaldehyde_a.out
-share/doc/DeFT/examples/malonaldehyde_b.dft
-share/doc/DeFT/examples/malonaldehyde_b.out
-share/doc/DeFT/examples/malonaldehyde_c.dft
-share/doc/DeFT/examples/malonaldehyde_c.out
-share/doc/DeFT/examples/malonaldehyde_d.dft
-share/doc/DeFT/examples/malonaldehyde_d.out
-share/doc/DeFT/examples/malonaldehyde_e.dft
-share/doc/DeFT/examples/malonaldehyde_e.out
-share/doc/DeFT/examples/malonaldehyde_f.dft
-share/doc/DeFT/examples/malonaldehyde_f.out
-share/doc/DeFT/examples/malonaldehyde_g.dft
-share/doc/DeFT/examples/malonaldehyde_g.out
-share/doc/DeFT/examples/malonaldehyde_h.dft
-share/doc/DeFT/examples/malonaldehyde_h.out
-share/doc/DeFT/examples/malonaldehyde_i.dft
-share/doc/DeFT/examples/malonaldehyde_i.out
-share/doc/DeFT/examples/methanol.dft
-share/doc/DeFT/examples/methanol.out
-share/doc/DeFT/examples/methylamine.dft
-share/doc/DeFT/examples/methylamine.out
-share/doc/DeFT/examples/neopentane.dft
-share/doc/DeFT/examples/neopentane.out
-share/doc/DeFT/examples/nh4+.dft
-share/doc/DeFT/examples/nh4+.out
-share/doc/DeFT/examples/o2.dft
-share/doc/DeFT/examples/o2.out
-share/doc/DeFT/examples/peroxide_a.dft
-share/doc/DeFT/examples/peroxide_a.out
-share/doc/DeFT/examples/peroxide_b.dft
-share/doc/DeFT/examples/peroxide_b.out
-share/doc/DeFT/examples/peroxide_c.dft
-share/doc/DeFT/examples/peroxide_c.out
-share/doc/DeFT/examples/peroxide_d.dft
-share/doc/DeFT/examples/peroxide_d.out
-share/doc/DeFT/examples/peroxide_e.dft
-share/doc/DeFT/examples/peroxide_e.out
-share/doc/DeFT/examples/water.dft
-share/doc/DeFT/examples/water.out
-@dirrm share/doc/DeFT/examples
+share/examples/DeFT/1,3-difluorobenzene.dft
+share/examples/DeFT/1,3-difluorobenzene.out
+share/examples/DeFT/2-hydroxybicyclopentane.dft
+share/examples/DeFT/2-hydroxybicyclopentane.out
+share/examples/DeFT/README
+share/examples/DeFT/acetone.dft
+share/examples/DeFT/acetone.out
+share/examples/DeFT/acetone_a.dft
+share/examples/DeFT/acetone_a.out
+share/examples/DeFT/acetone_b.dft
+share/examples/DeFT/acetone_b.out
+share/examples/DeFT/acetylene.dft
+share/examples/DeFT/acetylene.out
+share/examples/DeFT/allene.dft
+share/examples/DeFT/allene.out
+share/examples/DeFT/ammonia.dft
+share/examples/DeFT/ammonia.out
+share/examples/DeFT/benzaldehyde.dft
+share/examples/DeFT/benzaldehyde.out
+share/examples/DeFT/benzene.dft
+share/examples/DeFT/benzene.out
+share/examples/DeFT/bh4-.dft
+share/examples/DeFT/bh4-.out
+share/examples/DeFT/c_atom.dft
+share/examples/DeFT/c_atom.out
+share/examples/DeFT/ch2.dft
+share/examples/DeFT/ch2.out
+share/examples/DeFT/disilyl_ether.dft
+share/examples/DeFT/disilyl_ether.out
+share/examples/DeFT/ethane.dft
+share/examples/DeFT/ethane.out
+share/examples/DeFT/ethanol.dft
+share/examples/DeFT/ethanol.out
+share/examples/DeFT/ethylene_a.dft
+share/examples/DeFT/ethylene_a.out
+share/examples/DeFT/ethylene_b.dft
+share/examples/DeFT/ethylene_b.out
+share/examples/DeFT/f_atom.dft
+share/examples/DeFT/f_atom.out
+share/examples/DeFT/formaldehyde_a.dft
+share/examples/DeFT/formaldehyde_a.out
+share/examples/DeFT/formaldehyde_b.dft
+share/examples/DeFT/formaldehyde_b.out
+share/examples/DeFT/furan.dft
+share/examples/DeFT/furan.out
+share/examples/DeFT/hcn_a.dft
+share/examples/DeFT/hcn_a.out
+share/examples/DeFT/hcn_b.dft
+share/examples/DeFT/hcn_b.out
+share/examples/DeFT/hydroxide_a.dft
+share/examples/DeFT/hydroxide_a.out
+share/examples/DeFT/hydroxide_b.dft
+share/examples/DeFT/hydroxide_b.out
+share/examples/DeFT/hydroxide_c.dft
+share/examples/DeFT/hydroxide_c.out
+share/examples/DeFT/hydroxysulphane.dft
+share/examples/DeFT/hydroxysulphane.out
+share/examples/DeFT/malonaldehyde_a.dft
+share/examples/DeFT/malonaldehyde_a.out
+share/examples/DeFT/malonaldehyde_b.dft
+share/examples/DeFT/malonaldehyde_b.out
+share/examples/DeFT/malonaldehyde_c.dft
+share/examples/DeFT/malonaldehyde_c.out
+share/examples/DeFT/malonaldehyde_d.dft
+share/examples/DeFT/malonaldehyde_d.out
+share/examples/DeFT/malonaldehyde_e.dft
+share/examples/DeFT/malonaldehyde_e.out
+share/examples/DeFT/malonaldehyde_f.dft
+share/examples/DeFT/malonaldehyde_f.out
+share/examples/DeFT/malonaldehyde_g.dft
+share/examples/DeFT/malonaldehyde_g.out
+share/examples/DeFT/malonaldehyde_h.dft
+share/examples/DeFT/malonaldehyde_h.out
+share/examples/DeFT/malonaldehyde_i.dft
+share/examples/DeFT/malonaldehyde_i.out
+share/examples/DeFT/methanol.dft
+share/examples/DeFT/methanol.out
+share/examples/DeFT/methylamine.dft
+share/examples/DeFT/methylamine.out
+share/examples/DeFT/neopentane.dft
+share/examples/DeFT/neopentane.out
+share/examples/DeFT/nh4+.dft
+share/examples/DeFT/nh4+.out
+share/examples/DeFT/o2.dft
+share/examples/DeFT/o2.out
+share/examples/DeFT/peroxide_a.dft
+share/examples/DeFT/peroxide_a.out
+share/examples/DeFT/peroxide_b.dft
+share/examples/DeFT/peroxide_b.out
+share/examples/DeFT/peroxide_c.dft
+share/examples/DeFT/peroxide_c.out
+share/examples/DeFT/peroxide_d.dft
+share/examples/DeFT/peroxide_d.out
+share/examples/DeFT/peroxide_e.dft
+share/examples/DeFT/peroxide_e.out
+share/examples/DeFT/water.dft
+share/examples/DeFT/water.out
@dirrm share/doc/DeFT
+@dirrm share/examples/DeFT
+@dirrm share/DeFT