aboutsummaryrefslogtreecommitdiff
path: root/cad/astk-serveur
diff options
context:
space:
mode:
authorOliver Lehmann <oliver@FreeBSD.org>2003-12-08 02:07:22 +0000
committerOliver Lehmann <oliver@FreeBSD.org>2003-12-08 02:07:22 +0000
commitc29377595853802138b1496fc9f863cbc5de7293 (patch)
treee17f447c50d55f732d3f1b503915ac39c736785c /cad/astk-serveur
parentf1102dce01f030f26a766eba8124ef2b7b4eb82a (diff)
downloadports-c29377595853802138b1496fc9f863cbc5de7293.tar.gz
ports-c29377595853802138b1496fc9f863cbc5de7293.zip
Notes
Diffstat (limited to 'cad/astk-serveur')
-rw-r--r--cad/astk-serveur/Makefile30
-rw-r--r--cad/astk-serveur/distinfo2
-rw-r--r--cad/astk-serveur/files.client/patch-lib::ASTK::astkrc::outils18
-rw-r--r--cad/astk-serveur/files/patch-conf::config52
-rw-r--r--cad/astk-serveur/pkg-plist1
5 files changed, 76 insertions, 27 deletions
diff --git a/cad/astk-serveur/Makefile b/cad/astk-serveur/Makefile
index ce183086c346..27628f1250a9 100644
--- a/cad/astk-serveur/Makefile
+++ b/cad/astk-serveur/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= astk
-PORTVERSION= 1.0.14
-PORTREVISION?= 2
+PORTVERSION= 1.0.21
CATEGORIES= cad tk84
MASTER_SITES= http://www.code-aster.org/FICHIERS/code_aster/
.if !defined(CLIENT_SEUL)
@@ -15,7 +14,7 @@ PKGNAMESUFFIX= -serveur
.else
PKGNAMESUFFIX= -client
.endif
-DISTNAME= aster_src_${ASTER_VER}
+DISTNAME= aster-${ASTER_VER}.src
EXTRACT_SUFX= .tar
MAINTAINER= ports@FreeBSD.org
@@ -48,24 +47,25 @@ NO_BUILD= yes
USE_REINPLACE= yes
REINPLACE_ARGS= -i ""
+EXTDIR= ${WRKDIR}/${DISTNAME}
.if !defined(CLIENT_SEUL)
-WRKSRC= ${WRKDIR}/ASTK_SERV
+WRKSRC= ${EXTDIR}/ASTK_SERV
PATCHDIR= ${MASTERDIR}/files
PLIST_SUB= SERV="" CLIENT="@comment " vaster=${vaster}
.else
-WRKSRC= ${WRKDIR}/ASTK_CLIENT
+WRKSRC= ${EXTDIR}/ASTK_CLIENT
PATCHDIR= ${MASTERDIR}/files.client
PLIST_SUB= SERV="@comment " CLIENT="" vaster=""
PKGMESSAGE= ${PKGDIR}/pkg-message.client
.endif
-SLAVEDIRS= french/astk-client
+SLAVEDIRS= cad/astk-client
TK_VER?= 8.4
TCL_VER?= ${TK_VER}
TKTAB_VER?= 2.8
-ASTER_VER= 7.1
+ASTER_VER= 7.2.0-2
vaster= STA${ASTER_VER}
.if defined(WITH_ZSH)
@@ -113,14 +113,20 @@ v_ifdef= ${unames:U}
SHELL_INSTALL_ASTER= ${LOCALBASE}/bin/${SHIA}
gzip!= dirname `${WHICH} ${GZIP_CMD}`
+.if defined(LANG) && ${LANG:Mfr*} != ""
+ASTK_LANG= FR
+.else
+ASTK_LANG= ENG
+.endif
+
post-extract:
- @(cd ${WRKDIR} && \
- ${TAR} xfz ${WRKDIR}/astk.tar.gz)
+ @(cd ${EXTDIR} && \
+ ${TAR} xfz ${EXTDIR}/astk.tar.gz)
.if !defined(CLIENT_SEUL)
- @(cd ${WRKDIR} && \
+ @(cd ${EXTDIR} && \
${TAR} xf ASTK_SERV.tar)
.else
- @(cd ${WRKDIR} && \
+ @(cd ${EXTDIR} && \
${TAR} xf ASTK_CLIENT.tar)
.endif
@@ -142,6 +148,7 @@ post-patch:
-e "s#/bin/sh#${SHELL_INSTALL_ASTER}#g" \
-e "s#NODE#${SERVER_NAME}#" \
-e "s#%%vaster%%#${vaster}#" \
+ -e "s#LOCALBASE#${LOCALBASE}#" \
-e "s|#%%v_ifdef%%|${v_ifdef}|" ${WRKSRC}/conf/config
@${RM} ${WRKSRC}/conf/config.orig
@${CP} ${WRKSRC}/conf/config.NEW7 ${WRKSRC}/conf/config.${vaster}
@@ -183,6 +190,7 @@ post-patch:
-e "s#EDITOR#${WITH_ED}#" ${conf_dir}/config_serveurs
@${REINPLACE_CMD} -e "s#HOME_XTERM#${X11BASE}/bin#" \
-e "s#VVV#${vaster}#" \
+ -e "s#langue : ENG#langue : ${ASTK_LANG}#" \
-e "s#EDITOR#${WITH_ED}#" ${conf_dir}/prefs
@${REINPLACE_CMD} -e "s#%%LOCALBASE%%#${LOCALBASE}#g" \
${WRKSRC}/share/tkselecteur.tcl
diff --git a/cad/astk-serveur/distinfo b/cad/astk-serveur/distinfo
index 4ed58de58088..cc4651bf25c0 100644
--- a/cad/astk-serveur/distinfo
+++ b/cad/astk-serveur/distinfo
@@ -1 +1 @@
-MD5 (aster_src_7.1.tar) = 6a76b378c2fbab506c5fe1e8f6713007
+MD5 (aster-7.2.0-2.src.tar) = 3c7163dffba0fa70c6b136480c05712e
diff --git a/cad/astk-serveur/files.client/patch-lib::ASTK::astkrc::outils b/cad/astk-serveur/files.client/patch-lib::ASTK::astkrc::outils
index 05d02a0b832e..d9f38408d7d6 100644
--- a/cad/astk-serveur/files.client/patch-lib::ASTK::astkrc::outils
+++ b/cad/astk-serveur/files.client/patch-lib::ASTK::astkrc::outils
@@ -1,6 +1,6 @@
--- lib/ASTK/astkrc/outils.orig Mon Jun 23 08:42:59 2003
-+++ lib/ASTK/astkrc/outils Mon Aug 18 21:27:52 2003
-@@ -13,3 +13,19 @@
++++ lib/ASTK/astkrc/outils Wed Oct 8 23:45:12 2003
+@@ -13,3 +13,23 @@
ext : comm com0 com1 com2
dist : on
#
@@ -9,14 +9,18 @@
+ext : geo pos
+dist : on
+#
-+# Gibi2000 is not yet implemented (currently for EDF internal use only)
-+#nom : Gibi
-+#cmde : TOOLS_DIR/gibi (@F)
-+#ext : datg
-+#dist : off
++nom : Gibi
++cmde : TOOLS_DIR/gibi (@F)
++ext : dgibi
++dist : on
+#
+nom : Grace
+cmde : TOOLS_DIR/xmgrace (@F)
+ext : dat
+dist : on
+#
++nom : Stanley
++cmde : TOOLS_DIR/../bibpyt/Stanley/stanley.py
++ext : _VIDE
++dist : off
++#
diff --git a/cad/astk-serveur/files/patch-conf::config b/cad/astk-serveur/files/patch-conf::config
index 0634de14bf86..0099bceb5313 100644
--- a/cad/astk-serveur/files/patch-conf::config
+++ b/cad/astk-serveur/files/patch-conf::config
@@ -1,6 +1,6 @@
---- conf/config.orig Fri Jun 20 13:07:15 2003
-+++ conf/config Wed Jul 16 12:11:03 2003
-@@ -60,6 +60,7 @@
+--- conf/config.orig Fri Sep 5 16:48:15 2003
++++ conf/config Fri Nov 14 22:08:22 2003
+@@ -60,39 +60,43 @@
# for each version a config.VVV file must be created.
# DO NOT EDIT FOLLOWING LINE !
#vers : VVV
@@ -8,7 +8,43 @@
#################################################################
# batch commands
-@@ -93,6 +94,9 @@
+-batch_nom : LSF
++#batch_nom : LSF
+ # initialisation (shell script, sh/ksh syntax)
+-batch_ini : /usr/opt/lsf/conf/profile.lsf
++#batch_ini : /usr/opt/lsf/conf/profile.lsf
+ # submission
+-batch_sub : /usr/opt/lsf/4.2/alpha5/bin/bsub
++#batch_sub : /usr/opt/lsf/4.2/alpha5/bin/bsub
+ # variable of the job number
+-batch_jid : LSB_JOBID
++#batch_jid : LSB_JOBID
+ # to display information about jobs
+-batch_job : /usr/opt/lsf/4.2/alpha5/bin/bjobs
++#batch_job : /usr/opt/lsf/4.2/alpha5/bin/bjobs
+ # to delete jobs
+-batch_kil : /usr/opt/lsf/4.2/alpha5/bin/bkill
++#batch_kil : /usr/opt/lsf/4.2/alpha5/bin/bkill
+
+ # PBS example (experimental)
+-#batch_nom : PBS
++batch_nom : PBS
+ # initialisation
+ #batch_ini :
+ # submission
+-#batch_sub : /local/openpbs-2.3.16/bin/qsub
++#batch_sub : LOCALBASE/bin/qsub
+ # variable of the job number
+ #batch_jid : PBS_JOBID
+ # to display information about jobs
+-#batch_job : /local/openpbs-2.3.16/bin/qstat
++#batch_job : LOCALBASE/bin/qstat
+ # to delete jobs
+-#batch_kil : /local/openpbs-2.3.16/bin/qdel
++#batch_kil : LOCALBASE/bin/qdel
+
+ #################################################################
+ # ps commands : uncomment lines corresponding to your platform
# LINUX :
#P_LINUXps_cpu : /bin/ps -e --width=512 -ocputime -ocommand
#P_LINUXps_pid : /bin/ps -e --width=512 -opid -ocommand
@@ -18,11 +54,11 @@
# TRU64 :
#TRU64ps_cpu : /bin/ps -e -ocputime -ocommand
#TRU64ps_pid : /bin/ps -e -opid -ocommand
-@@ -115,6 +119,7 @@
- #
+@@ -116,6 +120,7 @@
# GDB :
- #P_LINUXcmd_dbg : gdb --dbx --command=@D @E @C
+ #P_LINUXcmd_post : gdb --dbx --command=@D @E @C
+ #P_LINUXcmd_dbg : ddd --debugger gdb --command=@D @E @C
+#%%v_ifdef%%cmd_dbg : gdb --dbx --command=@D @E @C
# DBX -c + filename :
+ #TRU64cmd_post : dbx -c @D @E @C
#TRU64cmd_dbg : dbx -c @D @E @C
- #IRIXcmd_dbg : dbx -c @D @E @C
diff --git a/cad/astk-serveur/pkg-plist b/cad/astk-serveur/pkg-plist
index 3366dfab574b..64bf20bd8d2b 100644
--- a/cad/astk-serveur/pkg-plist
+++ b/cad/astk-serveur/pkg-plist
@@ -57,6 +57,7 @@
%%CLIENT%%ASTK/ASTK_CLIENT/share/appli.tcl
%%CLIENT%%ASTK/ASTK_CLIENT/share/config.tcl
%%CLIENT%%ASTK/ASTK_CLIENT/share/file_funct.tcl
+%%CLIENT%%ASTK/ASTK_CLIENT/share/icons/sans_helpB.gif
%%CLIENT%%ASTK/ASTK_CLIENT/share/icons/vaio_browseB.gif
%%CLIENT%%ASTK/ASTK_CLIENT/share/icons/vaio_browseS.gif
%%CLIENT%%ASTK/ASTK_CLIENT/share/icons/vaio_comp1.gif