aboutsummaryrefslogtreecommitdiff
path: root/cad/basicdsp
diff options
context:
space:
mode:
authorDiane Bruce <db@FreeBSD.org>2008-11-05 17:05:17 +0000
committerDiane Bruce <db@FreeBSD.org>2008-11-05 17:05:17 +0000
commit584fec74d446aba2faca126e0bbaaa82c62054b9 (patch)
tree4a395a085cbb8e97a6d79684f6e9fbbeb951be17 /cad/basicdsp
parent11bdd00753180ace63a252c42019c234adaa1eb0 (diff)
downloadports-584fec74d446aba2faca126e0bbaaa82c62054b9.tar.gz
ports-584fec74d446aba2faca126e0bbaaa82c62054b9.zip
Notes
Diffstat (limited to 'cad/basicdsp')
-rw-r--r--cad/basicdsp/Makefile4
-rw-r--r--cad/basicdsp/distinfo6
-rw-r--r--cad/basicdsp/files/basicdsp.141
-rw-r--r--cad/basicdsp/files/patch-Makefile22
-rw-r--r--cad/basicdsp/files/patch-aboutdialog.cpp11
-rw-r--r--cad/basicdsp/files/patch-book.cpp14
-rw-r--r--cad/basicdsp/files/patch-book.h10
-rw-r--r--cad/basicdsp/files/patch-gui.cpp12
8 files changed, 18 insertions, 102 deletions
diff --git a/cad/basicdsp/Makefile b/cad/basicdsp/Makefile
index acf4d05224ca..ecb219c6076a 100644
--- a/cad/basicdsp/Makefile
+++ b/cad/basicdsp/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= basicdsp
-PORTVERSION= 1.0
+PORTVERSION= 1.01
CATEGORIES= cad hamradio
MASTER_SITES= http://wwwhome.cs.utwente.nl/~ptdeboer/ham/basicdsp/ \
${MASTER_SITE_LOCAL}
@@ -28,7 +28,7 @@ post-patch:
@${REINPLACE_CMD} -e 's|%%WX_CONFIG%%|${WX_CONFIG}|g' ${WRKSRC}/Makefile
do-install:
- ${INSTALL_MAN} ${FILESDIR}/basicdsp.1 ${MANPREFIX}/man/man1/basicdsp.1
+ ${INSTALL_MAN} ${WRKSRC}/basicdsp.1 ${MANPREFIX}/man/man1/basicdsp.1
${INSTALL_PROGRAM} ${WRKSRC}/basicdsp ${PREFIX}/bin/
.include <bsd.port.mk>
diff --git a/cad/basicdsp/distinfo b/cad/basicdsp/distinfo
index ca0b1a9153ce..552289ed856c 100644
--- a/cad/basicdsp/distinfo
+++ b/cad/basicdsp/distinfo
@@ -1,3 +1,3 @@
-MD5 (basicdsp-1.0.tgz) = 2d7f0f1c56a3398657b876f20c2a5311
-SHA256 (basicdsp-1.0.tgz) = ca2f2c22bd2974fc9dd8bbc1791630bf533f1c739e834926b9aa7e99edb485f7
-SIZE (basicdsp-1.0.tgz) = 56542
+MD5 (basicdsp-1.01.tgz) = 521ddd472a51d7f7c60b2fe9c530d41f
+SHA256 (basicdsp-1.01.tgz) = ce1cabed4ac23961ca9a1cd1e4df0c857aaca41179d9b916a038a1557e2bc0d9
+SIZE (basicdsp-1.01.tgz) = 57122
diff --git a/cad/basicdsp/files/basicdsp.1 b/cad/basicdsp/files/basicdsp.1
deleted file mode 100644
index 2bd112485a5e..000000000000
--- a/cad/basicdsp/files/basicdsp.1
+++ /dev/null
@@ -1,41 +0,0 @@
-.Dd June 16, 2008
-.Os Unix
-.Dt basicdsp 1
-.Sh NAME
-.Nm basicdsp
-.Nd DSP demonstration program
-.Sh SYNOPSIS
-A program for experimenting with simple audio DSP algorithms.
-.Sh DESCRIPTION
-.Pp
-BasicDSP is a program to apply simple Digital Signal Processing algorithms
-to audio signals. The input can either be taken from the sound card, or
-be a locally generated sine wave, white noise or impulse signal. The output
-is fed to the sound card, as well as to a virtual oscilloscope and spectrum
-analyzer.
-.Pp
-The DSP algorithm itself is specified in a very straightforward programming
-language which has only assignment statements (and on unix a print statement).
-Each line contains one statement, and all lines are executed once for each
-incoming sample. The input sample is available in variables named 'in',
-'inl' (left channel) and 'inr' (right channel). The program should write the
-output into variables named 'out', 'outl' and/or 'outr'.
-Here's a simple example program:
-
- a = a + slider1 * (in - a)
- outl = a
- outr = fir(in, 0.1, 0.3, 0.3, 0.1)
-.Pp
-This illustrates defining new variables ('a' in the example), the use of
-the sliders, and the use of a built-in function like fir().
-The help-menu gives access to a complete list of built-in variables and
-functions.
-.Pp
-Note: the program was originally written to accompany a series of articles
-on Software-Defined Radio appearing in the Dutch amateur radio journal
-\'Electron\'. Another tutorial appeared in the December 2007 issue of SPRAT.
-.Sh PROJECT WEBSITE, DOCUMENTATION
-http://wwwhome.cs.utwente.nl/~ptdeboer/ham/basicdsp/
-.Pp
-.Sh AUTHORS
-Pieter-Tjerk de Boer, Niels A. Moseley
diff --git a/cad/basicdsp/files/patch-Makefile b/cad/basicdsp/files/patch-Makefile
index ef61085c2c97..96b1b4b5a3ef 100644
--- a/cad/basicdsp/files/patch-Makefile
+++ b/cad/basicdsp/files/patch-Makefile
@@ -1,17 +1,21 @@
---- Makefile.orig 2007-12-02 17:18:59.000000000 -0500
-+++ Makefile 2008-08-14 10:13:05.000000000 -0400
+--- Makefile.orig 2008-11-05 11:38:45.000000000 -0500
++++ Makefile 2008-11-05 11:51:30.000000000 -0500
@@ -1,5 +1,5 @@
-CXXFLAGS = -O9 -g -Wall `wx-config --cxxflags` -g -Wall -pg
-LDFLAGS = `wx-config --libs` -lm -g -pg
-+CXXFLAGS += -Wall `%%WX_CONFIG%% --cxxflags --unicode=yes`
-+LDFLAGS = `%%WX_CONFIG%% --libs --unicode=yes` -lm
++CXXFLAGS += -g -Wall `%%WX_CONFIG%% --cxxflags` -g -Wall -pg
++LDFLAGS = `%%WX_CONFIG%% --libs` -lm -g -pg
OBJS = aboutdialog.o book.o core.o displayslider.o graphframe.o gui.o linux.o vu_meter.o spectrumplot.o fft4g.o wav_streamer.o
-@@ -11,5 +11,5 @@
- ./mkhelp > help.h
+@@ -7,8 +7,8 @@
- basicdsp: help.h $(OBJS)
-- g++ $(LDFLAGS) $(OBJS) -o basicdsp
-+ ${CXX} $(LDFLAGS) $(OBJS) -o basicdsp
+ gui.o: help.h gui.cpp
+
+-help.h: help_variables.html help_functions.html
+- ./mkhelp > help.h
++#help.h: help_variables.html help_functions.html
++# ./mkhelp > help.h
+ basicdsp: help.h $(OBJS)
+ g++ $(LDFLAGS) $(OBJS) -o basicdsp
diff --git a/cad/basicdsp/files/patch-aboutdialog.cpp b/cad/basicdsp/files/patch-aboutdialog.cpp
deleted file mode 100644
index 733a17d2aae8..000000000000
--- a/cad/basicdsp/files/patch-aboutdialog.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- aboutdialog.cpp.orig 2008-08-16 23:33:09.000000000 -0400
-+++ aboutdialog.cpp 2008-08-16 23:34:13.000000000 -0400
-@@ -29,7 +29,7 @@
- // to clean this up would mean patching wxWidgets :(
- splash_xpm = new wxImage(basicdsp_splash_xpm);
- if (splash_xpm != NULL)
-- splash_bitmap = new wxBitmap(splash_xpm);
-+ splash_bitmap = new wxBitmap((const wxImage&)splash_xpm);
-
- if ((splash_bitmap!=NULL) && (splash_bitmap->Ok()))
- {
diff --git a/cad/basicdsp/files/patch-book.cpp b/cad/basicdsp/files/patch-book.cpp
deleted file mode 100644
index d3e6d985c2f5..000000000000
--- a/cad/basicdsp/files/patch-book.cpp
+++ /dev/null
@@ -1,14 +0,0 @@
---- book.cpp.orig 2008-08-16 23:28:51.000000000 -0400
-+++ book.cpp 2008-08-16 23:31:02.000000000 -0400
-@@ -30,6 +30,11 @@
- {
- }
-
-+int wxBook::ChangeSelection(size_t n)
-+{
-+ return n;
-+}
-+
- int wxBook::SetSelection(size_t n)
- {
- int old_selected = m_selected;
diff --git a/cad/basicdsp/files/patch-book.h b/cad/basicdsp/files/patch-book.h
deleted file mode 100644
index 0295be8e622a..000000000000
--- a/cad/basicdsp/files/patch-book.h
+++ /dev/null
@@ -1,10 +0,0 @@
---- book.h.orig 2008-08-16 23:28:06.000000000 -0400
-+++ book.h 2008-08-16 23:29:07.000000000 -0400
-@@ -27,6 +27,7 @@
- virtual int GetSelection() const { return m_selected;};
- virtual wxSize CalcSizeFromPage(const wxSize& sizePage) const;
-
-+ virtual int ChangeSelection(size_t n);
- virtual int SetSelection(size_t n);
-
- // the same as AddPage(), but adds the page at the specified position
diff --git a/cad/basicdsp/files/patch-gui.cpp b/cad/basicdsp/files/patch-gui.cpp
deleted file mode 100644
index 7b78e79cc934..000000000000
--- a/cad/basicdsp/files/patch-gui.cpp
+++ /dev/null
@@ -1,12 +0,0 @@
---- gui.cpp.orig 2008-08-16 23:38:20.000000000 -0400
-+++ gui.cpp 2008-08-16 23:38:29.000000000 -0400
-@@ -631,6 +631,9 @@
- #endif
- }
-
-+#ifndef wxHIDE_READONLY
-+#define wxHIDE_READONLY 0
-+#endif
-
- void MyFrame::OnOpen(wxCommandEvent& WXUNUSED(event))
- {