aboutsummaryrefslogtreecommitdiff
path: root/cad/calculix
diff options
context:
space:
mode:
authorMaho Nakata <maho@FreeBSD.org>2013-08-27 04:22:46 +0000
committerMaho Nakata <maho@FreeBSD.org>2013-08-27 04:22:46 +0000
commit96c9fa96465f08ef76e3d029f213e2871739684c (patch)
tree102ee50b8a6569563162e34fc8252011aadb5945 /cad/calculix
parentdbea6b19e01f977c96d1add8a4f27a726c894bdc (diff)
downloadports-96c9fa96465f08ef76e3d029f213e2871739684c.tar.gz
ports-96c9fa96465f08ef76e3d029f213e2871739684c.zip
Notes
Diffstat (limited to 'cad/calculix')
-rw-r--r--cad/calculix/Makefile12
1 files changed, 11 insertions, 1 deletions
diff --git a/cad/calculix/Makefile b/cad/calculix/Makefile
index faf47fb27957..82ad6ecbf482 100644
--- a/cad/calculix/Makefile
+++ b/cad/calculix/Makefile
@@ -32,7 +32,6 @@ LICENSE= GPLv2
LIB_DEPENDS= arpack.1:${PORTSDIR}/math/arpack \
spooles.1:${PORTSDIR}/math/spooles \
- metis.1:${PORTSDIR}/math/metis4 \
taucs.1:${PORTSDIR}/math/taucs
USE_BZIP2= yes
@@ -58,6 +57,17 @@ CCX_VER= ccx_${PORTVERSION}
CGX_VER= cgx_2.6
.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
+
+OPTIONS_DEFINE= METIS METIS_EDF
+OPTIONS_DEFAULT=METIS
+
+.if ${PORT_OPTIONS:MMETIS}
+LIB_DEPENDS+= metis.1:${PORTSDIR}/math/metis4
+.endif
+.if ${PORT_OPTIONS:MMETIS_EDF}
+LIB_DEPENDS+= metis.1:${PORTSDIR}/math/metis-edf
+.endif
.if exists(${LOCALBASE}/lib/libatlas.so) && !defined(WITH_BLAS)
WITH_ATLAS= yes