aboutsummaryrefslogtreecommitdiff
path: root/cad/freecad/Makefile
diff options
context:
space:
mode:
authorChristoph Moench-Tegeder <cmt@FreeBSD.org>2019-07-20 14:11:35 +0000
committerChristoph Moench-Tegeder <cmt@FreeBSD.org>2019-07-20 14:11:35 +0000
commit0e013ea9f4ac7c32cc8b5e48ebad6a00bb310d76 (patch)
tree564cd82442e6b8bd83f559b75f76c4c8a6006d4e /cad/freecad/Makefile
parenteb2f78b719f04ec3147d608196cb2dcee7bc962c (diff)
downloadports-0e013ea9f4ac7c32cc8b5e48ebad6a00bb310d76.tar.gz
ports-0e013ea9f4ac7c32cc8b5e48ebad6a00bb310d76.zip
Notes
Diffstat (limited to 'cad/freecad/Makefile')
-rw-r--r--cad/freecad/Makefile7
1 files changed, 4 insertions, 3 deletions
diff --git a/cad/freecad/Makefile b/cad/freecad/Makefile
index a4108e7ad6f5..4e1e6b54e5e7 100644
--- a/cad/freecad/Makefile
+++ b/cad/freecad/Makefile
@@ -1,8 +1,7 @@
# $FreeBSD$
PORTNAME= FreeCAD
-DISTVERSION= 0.18.2
-PORTREVISION= 1
+DISTVERSION= 0.18.3
# use these for bugfixes/snapshots
# DISTVERSION= 0.18-16093 # git rev-list --count
# DISTVERSIONSUFFIX= -g690774c0e
@@ -15,6 +14,7 @@ LICENSE= LGPL20+
LICENSE_FILE= ${WRKSRC}/LICENSE
BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pyside2-tools>0:devel/pyside2-tools@${PY_FLAVOR} \
+ ${PYTHON_SITELIBDIR}/matplotlib/__init__.py:math/py-matplotlib@${PY_FLAVOR} \
swig3.0:devel/swig30
LIB_DEPENDS= libexpat.so:textproc/expat2 \
libfreetype.so:print/freetype2 \
@@ -31,7 +31,8 @@ LIB_DEPENDS= libexpat.so:textproc/expat2 \
libmed.so:french/med \
libshiboken2.cpython-${PYTHON_SUFFIX}${PYTHON_ABIVER}.so:devel/shiboken2@${PY_FLAVOR} \
libhdf5.so:science/hdf5
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pivy-devel>0:graphics/py-pivy-devel@${PY_FLAVOR}
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pivy-devel>0:graphics/py-pivy-devel@${PY_FLAVOR} \
+ ${PYTHON_SITELIBDIR}/matplotlib/__init__.py:math/py-matplotlib@${PY_FLAVOR}
USES= dos2unix compiler:c++11-lib cmake gl eigen:3 fortran jpeg \
localbase:ldflags pkgconfig python:3.6 localbase qt:5