aboutsummaryrefslogtreecommitdiff
path: root/cad/freehdl
diff options
context:
space:
mode:
authorJohn Marino <marino@FreeBSD.org>2014-07-18 08:09:53 +0000
committerJohn Marino <marino@FreeBSD.org>2014-07-18 08:09:53 +0000
commit32842933d381608ae254820af0aa9725f9602422 (patch)
tree56f26aa1c211414b09bea31eed88f7c36bf772e1 /cad/freehdl
parentdba2c54526c9cb7056c109c324c08075b8dc1eb1 (diff)
downloadports-32842933d381608ae254820af0aa9725f9602422.tar.gz
ports-32842933d381608ae254820af0aa9725f9602422.zip
Notes
Diffstat (limited to 'cad/freehdl')
-rw-r--r--cad/freehdl/Makefile10
-rw-r--r--cad/freehdl/files/patch-kernel_fhdl__stream.cc10
-rw-r--r--cad/freehdl/files/patch-vaul_dunit.cc10
-rw-r--r--cad/freehdl/files/patch-vaul_pool.cc10
-rw-r--r--cad/freehdl/pkg-plist5
5 files changed, 36 insertions, 9 deletions
diff --git a/cad/freehdl/Makefile b/cad/freehdl/Makefile
index 9db1277b287f..d482e9b01fe1 100644
--- a/cad/freehdl/Makefile
+++ b/cad/freehdl/Makefile
@@ -11,20 +11,13 @@ COMMENT= Free VHDL simulator
USE_LDCONFIG= yes
USES= gmake perl5 pkgconfig
+USE_GCC= any
USE_GNOME= gnomehack
USE_AUTOTOOLS= libtool
HAS_CONFIGURE= yes
-MAN1= freehdl-config.1 \
- freehdl-gennodes.1 \
- freehdl-v2cc.1 \
- gvhdl.1
-MAN5= v2cc.libs.5
-
INFO= fire
-MANCOMPRESSED= no
-
PLIST_TMP= ${WRKDIR}/plist_tmp/
PLIST_REPL= ${SED} "s|share/${PORTNAME}|%%DATADIR%%|1"
@@ -53,5 +46,4 @@ plist: build
| ${GREP} -vE '%%DATADIR%%|freehdl' >> ${PLIST}
@${RM} -rf ${PLIST_TMP}
-NO_STAGE= yes
.include <bsd.port.mk>
diff --git a/cad/freehdl/files/patch-kernel_fhdl__stream.cc b/cad/freehdl/files/patch-kernel_fhdl__stream.cc
new file mode 100644
index 000000000000..ad35d23f3bed
--- /dev/null
+++ b/cad/freehdl/files/patch-kernel_fhdl__stream.cc
@@ -0,0 +1,10 @@
+--- kernel/fhdl_stream.cc.orig 2006-01-12 08:05:01.000000000 +0000
++++ kernel/fhdl_stream.cc
+@@ -2,6 +2,7 @@
+ #if HAVE_UNISTD_H
+ #include <unistd.h>
+ #endif
++#include <cstring>
+ #include <sstream>
+ #include <assert.h>
+ #include <freehdl/kernel-error.hh>
diff --git a/cad/freehdl/files/patch-vaul_dunit.cc b/cad/freehdl/files/patch-vaul_dunit.cc
new file mode 100644
index 000000000000..0c63a18e6dd4
--- /dev/null
+++ b/cad/freehdl/files/patch-vaul_dunit.cc
@@ -0,0 +1,10 @@
+--- vaul/dunit.cc.orig 2005-12-14 08:23:06.000000000 +0000
++++ vaul/dunit.cc
+@@ -27,6 +27,7 @@
+
+ #include <errno.h>
+ #include <string.h>
++#include <stdlib.h>
+ #if HAVE_MALLOC_H
+ #include <malloc.h>
+ #endif
diff --git a/cad/freehdl/files/patch-vaul_pool.cc b/cad/freehdl/files/patch-vaul_pool.cc
new file mode 100644
index 000000000000..96ee5a642026
--- /dev/null
+++ b/cad/freehdl/files/patch-vaul_pool.cc
@@ -0,0 +1,10 @@
+--- vaul/pool.cc.orig 2005-12-14 08:23:06.000000000 +0000
++++ vaul/pool.cc
+@@ -24,6 +24,7 @@
+ #include <freehdl/vaul-lexer.h>
+ #include <freehdl/vaul-util.h>
+
++#include <stdlib.h>
+ #if HAVE_MALLOC_H
+ #include <malloc.h>
+ #endif
diff --git a/cad/freehdl/pkg-plist b/cad/freehdl/pkg-plist
index d53e0c85b0f8..644bf7df45c8 100644
--- a/cad/freehdl/pkg-plist
+++ b/cad/freehdl/pkg-plist
@@ -91,6 +91,11 @@ lib/libfreehdl-cdfggen.so.0
lib/libfreehdl-cdfggen.so
lib/libfreehdl-cdfggen.la
lib/libfreehdl-cdfggen.a
+man/man1/freehdl-config.1.gz
+man/man1/freehdl-gennodes.1.gz
+man/man1/freehdl-v2cc.1.gz
+man/man1/gvhdl.1.gz
+man/man5/v2cc.libs.5.gz
%%DATADIR%%/lib/std/standard.vhdl
%%DATADIR%%/lib/std/textio.vhdl
%%DATADIR%%/lib/ieee/std_logic_1164.vhdl