aboutsummaryrefslogtreecommitdiff
path: root/cad/gdt/Makefile
diff options
context:
space:
mode:
authorHiroki Sato <hrs@FreeBSD.org>2013-06-01 11:23:22 +0000
committerHiroki Sato <hrs@FreeBSD.org>2013-06-01 11:23:22 +0000
commit7a823705e4a1c9209aea670a6832f1828c00d667 (patch)
treea9d1a87517a0f3f8576ff6d7dbeefb47fc67e853 /cad/gdt/Makefile
parent0fc3b4248377c4887f57ccde440a4e9a25e152a0 (diff)
downloadports-7a823705e4a1c9209aea670a6832f1828c00d667.tar.gz
ports-7a823705e4a1c9209aea670a6832f1828c00d667.zip
Notes
Diffstat (limited to 'cad/gdt/Makefile')
-rw-r--r--cad/gdt/Makefile20
1 files changed, 9 insertions, 11 deletions
diff --git a/cad/gdt/Makefile b/cad/gdt/Makefile
index 559d6a0e7fe7..c513deefd1e4 100644
--- a/cad/gdt/Makefile
+++ b/cad/gdt/Makefile
@@ -1,30 +1,28 @@
-# New ports collection makefile for: gdt
-# Date created: Sun, Apr 29 2007
-# Whom: Hiroki Sato <hrs@FreeBSD.org>
-#
# $FreeBSD$
-#
PORTNAME= gdt
-PORTVERSION= 3.0.5
+PORTVERSION= 4.0
CATEGORIES= cad
-MASTER_SITES= SF/gds2/gds2/GDT-${PORTVERSION}
+MASTER_SITES= SF/gds2/gds2/
DISTNAME= ${PORTNAME:U}-${PORTVERSION}
MAINTAINER= hrs@FreeBSD.org
COMMENT= GDS2/GDT format translator
+LICENSE= GPLv2
+
USE_PERL5_RUN= yes
+USES= shebangfix
+SHEBANG_FILES= Examples/gdsinfo Examples/scalegds
WRKSRC= ${WRKDIR}/${PORTNAME:U}-${PORTVERSION}
PLIST_FILES= bin/gdsinfo bin/gds2gdt bin/gdt2gds bin/scalegds
post-patch:
- ${REINPLACE_CMD} 's,^#!/usr/bin/perl,#!${PERL},' \
- ${WRKSRC}/Examples/gdsinfo \
- ${WRKSRC}/Examples/scalegds
+ ${REINPLACE_CMD} -e 's,%%PREFIX%%,${PREFIX},' \
+ ${WRKSRC}/Examples/gdsinfo ${WRKSRC}/Examples/scalegds
pre-build:
- ${CP} ${FILESDIR}/Makefile ${WRKSRC}
+ ${INSTALL_DATA} ${FILESDIR}/Makefile ${WRKSRC}
post-install:
${INSTALL_SCRIPT} \